LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Some problems in the new Kate(KDE4.x.x) (http://www.linuxquestions.org/questions/linux-software-2/some-problems-in-the-new-kate-kde4-x-x-702615/)

clintonsk 02-05-2009 08:17 PM

Some problems in the new Kate(KDE4.x.x)
 
I decided to install Kde4 two weeks ago, so far it's been all worth it. So with migrating to KDE4 I've also started using the new Kate. I use Kate all the time for coding and I noticed one or two things that kind of confuse me.

For one, the file browser(on the right) doesn't show up when opening a session. However it does when you create a brand new session or use the default one. Just the recently opened documents are listed. That File Browser icon or tab doesn't show up at all.

The same also happens with the terminal emulator on the bottom below the text editor. No button shows up.

Using Kate 3.5 for the past 2 years and then switching and finding these problems just seems odd. I'm not sure if these are bugs or if there's something I'm doing wrong.

Has any one else encountered these problems? Should I report this as a bug. I noticed a php syntax coloring issue also.

norobro 02-05-2009 09:00 PM

I'm running KDE 4.2. I have an icon on the toolbar for Kate and when I click it a window pops up with all of my sessions and three default choices: Start Kate (no arguments ); New Kate Session; New Anonymous Session. The behavior you describe only occurs when I choose "New Anonymous Session" on my system, so I choose one of the others and save the session by using the tab in the main window.

Wasted some time looking through the menus trying to enable both tabs before figuring out what worked.

So, to answer your question, yes I have had the same problems and it looks like a bug to me.

BTW I really like Kate for coding, too.

mksoft 02-16-2009 05:49 PM

In the session make sure you have the tab bar extension enabled:

Settings | Configure Kate | Plugins | Kate Tab Bar Extension

clintonsk 02-17-2009 10:43 AM

Quote:

Originally Posted by mksoft (Post 3446116)
In the session make sure you have the tab bar extension enabled:

Settings | Configure Kate | Plugins | Kate Tab Bar Extension

Got it!

That wasn't the exact plugin I wanted but you pointed me in the right place. My file browser works now:)

Thanks


All times are GMT -5. The time now is 10:50 PM.