LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 10-10-2003, 09:02 AM   #1
BeerBust
LQ Newbie
 
Registered: Sep 2003
Location: Copenhagen, Denmark
Distribution: RH9 & 7.2
Posts: 5

Rep: Reputation: 0
Angry Smtp vs. Smtpd on Postfix


Hi

For some time I've been working on a problem where I'm unable to send from my server to external domains, from either Squirrelmail, Openwebmail or a POP3 client. BUT using the command 'mail <recipient>' from a telnet session will allow me to send mail!!! Hhhmmmmm - I've be looking north, east, south and I think west and have not been able to locate the problem.

Now, today I saw something i my maillog file :
postfix/pickup[8873]: 7D3D1235BE: uid=0 from=<root>
postfix/cleanup[8885]: 7D3D1235BE: message-id=<20031010133009.7D3D1235BE@mail.myhost.dk>
postfix/nqmgr[2531]: 7D3D1235BE: from=<root@myhost.dk>, size=304, nrcpt=1 (queue active)
postfix/smtp[8887]: 7D3D1235BE: to=<jeo@anotherdomain.dk>, relay=mailgw1.anotherdomain.dk[IPaddress], delay=0, status=sent (250 <3F7962F4003FFDFE> Mail accepted)

So opposed to :
postfix/smtpd[8486]: connect from unknown[192.168.135.4]
postfix/smtpd[8486]: 07499235BD: client=unknown[192.168.135.4]
postfix/smtpd[8486]: reject: RCPT from unknown[192.168.135.4]: 554 <jeo@anotherdomain.dk>: Recipient address rejected: Relay access denied; from=<jeo@mydomain.dk> to=<jeo@anotherdomain.dk>

Noted that when it went OK it said postfix/smtp and every time it goes wrong it says smtpd.

Does this have anything to say????
and (not least) what the f... can be wrong - any ideas????


Regards,
BeerBust

---------------------------------------------------
Hey - weekends here Beers UP!
 
Old 10-10-2003, 11:07 AM   #2
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Ubuntu, Debian, SuSE, UnSlung, Android
Posts: 1,819

Rep: Reputation: 46
It appears as though the first log entry is referring to outgoing mail and the second is a blocked incoming message because for some reason the domain in the to field doesn't match the entry in your postfix conf files. It's been a while since I setup my postfix server but I would check the main.cf file for a typo in the entry specifying the domains postfix is allowed to recieve mail for.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix/smtpd lost connection after CONNECT [GOD]Anck Linux - Security 1 12-18-2011 02:10 PM
[Postfix/SMTPD] Getting no AUTH from server; open relay superhausi Linux - Security 2 11-19-2008 05:37 PM
Postfix - Using for SMTP wfernley Linux - Newbie 3 12-29-2005 08:22 AM
Sending mail via Postfix smtpd through remote host requiring authentication Saffsd Linux - Networking 0 01-26-2004 05:05 AM
Postfix - Only SMTP? Thinkgeekness Linux - Software 12 03-11-2003 03:39 PM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration