LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-21-2004, 11:50 AM   #1
carmstrong
LQ Newbie
 
Registered: May 2004
Location: Pittsburgh, PA, USA
Distribution: Fedora Core 1
Posts: 19

Rep: Reputation: 0
Slow proftpd Connections


Just like the thread name implies, I'm experiencing about a 15-second wait after connecting to my proftpd server.

Connecting to l1.fragville.com
Connected to l1.fragville.com -> IP=69.36.35.130 PORT=21
(about 15 seconds)
Then the user information, etc.

What could this be caused by?

My proftpd.conf file:
Code:
ServerName                      "Welcome to Fragville"
ServerType                      standalone
DeferWelcome                    off
ServerIdent                     off
ShowSymlinks                    on
MultilineRFC2228                on
DefaultServer                   on
ShowSymlinks                    on
AllowOverwrite                  on
TimeoutNoTransfer               600
TimeoutStalled                  600
TimeoutIdle                     1200
DisplayLogin                    welcome.msg
DisplayFirstChdir               .message
LsDefaultOptions                "-l"
DenyFilter                      \*.*/
DefaultRoot                     ~
Port                            21
PassivePorts                    51000 51999
MaxInstances                    50
User                            nobody
Group                           nogroup
<Directory /*>
  Umask                         022  022
  AllowOverwrite                on
</Directory>
 
Old 05-21-2004, 12:11 PM   #2
carmstrong
LQ Newbie
 
Registered: May 2004
Location: Pittsburgh, PA, USA
Distribution: Fedora Core 1
Posts: 19

Original Poster
Rep: Reputation: 0
Also, for some reason, I can't follow symlinks. I can see them but I get the error:

CWD html
550 html: No such file or directory

Any ideas?
 
Old 05-21-2004, 01:00 PM   #3
carmstrong
LQ Newbie
 
Registered: May 2004
Location: Pittsburgh, PA, USA
Distribution: Fedora Core 1
Posts: 19

Original Poster
Rep: Reputation: 0
I got around this issue by mounting the directory I wanted to symlink to as a directory in the home directory of the user.

My original problem, the slow login, still exists though.
 
Old 05-22-2004, 07:02 AM   #4
sleddog
Member
 
Registered: Jan 2002
Location: Labrador, Canada
Distribution: CentOS, Debian
Posts: 182

Rep: Reputation: 35
By default ProFTPD tries to do DNS and ident lookups. You can disable this behaviour by adding the following lines to your proftpd.conf:

UseReverseDNS off
IdentLookups off

Restart proftpd and you should see faster connections.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow connections with external modem its_toby Linux - Hardware 0 10-19-2005 05:06 PM
ProFTPd connections hanging - port 113? JamesF1 Linux - Networking 4 08-04-2004 10:16 AM
Proftpd won't accept connections cL4YmAN Linux - Newbie 0 06-09-2004 03:33 PM
Slow down connections with network utilities warned Linux - Networking 5 04-05-2004 08:41 PM
proftpd not accepting outside connections sohmc Linux - Software 0 07-18-2003 07:40 AM


All times are GMT -5. The time now is 08:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration