LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 01-20-2008, 12:24 AM   #1
Molly
Member
 
Registered: Jan 2004
Distribution: Slackware, CentOS, Debian, OpenWRT, FreeBSD, OpenBSD, Solaris
Posts: 37

Rep: Reputation: 16
Unhappy Slow DVD burning k3b or Nero


Greets,

I will start from the beginning. Initially, on this system, I was burning without problems using debian sarge, followed by etch, and finally lenny - all were running kde if it matters. (these are the various debian distro release names, fyi) Just to give you an idea of the timeframe, at some point during my upgrading a few weeks ago on lenny, dvd burning went to hell.

The drive is a 16x, using verbatim datalifeplus 16x dvd+r media (mcc004) and never had problems burning at top speeds in the past. Now every burn just hovers around 3-4x sometimes spiking to 6x and i notice the 'software buffer' in k3b is bouncing all over the place... additionally the write verification process now FAILS about 3/4 of the time and im stuck with a mounting stack of coasters.

I decided it was time for some hardware upgrades and tore the system apart, threw in new memory, hard drive, power supply, and installed a dual boot with slackware 12.0 (running xfce 4 now) and windows xp. Things appeared to be running great.. system never lags.. tons of apps can run at once without problem.. yet the burn issue is STILL there in slackware now. When running nero in windows xp, dvd's burn without problem at top speed without verification problems just like the good old days (i have enabled the realtime burn speed display option so i'm positive). It's depressing but I find myself now having to reboot into xp just to burn dvd's.

so the other day i decide it may be kernel issue and download/recompile latest kernel release with my own optimized .config options including the great preemptible kernel setting and a 1000hz clock. this did nothing for burn quality although desktop is now even speedier .. so to conclude my system runs SOLID .. yet burning is horrible. Ive pretty much ruled out this being a distro specific or hardware issue. Here are my specs:


athlon xp 2400+ @ ~2ghz (15X * 133mhz) @ 1.650volt
biostar m7ncg 400 board, nforce2 chipset (audio/agp/ethernet/ide)
benq dw1640 dvd burner
1GB (2x512mb) DDR400 running @ 333mhz, cas2 @ 2.6volt
pc power & cooling silencer 470 power supply


linux kernel 2.6.24-rc8
growisofs by <appro@fy.chalmers.se>, version 7.0,
front-ending to mkisofs: mkisofs 2.01.01a23
Qt: 3.3.8
KDE: 3.5.7
K3b: 1.0.2

root@virek:~/# hdparm -i /dev/hdc

/dev/hdc:

Model=BENQ DVD DD DW1640, FwRev=BSLB, SerialNo
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no

/dev/hdc:
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)


root@virek:~/# hdparm -t -T /dev/hda

/dev/hda:
Timing cached reads: 714 MB in 2.00 seconds = 356.20 MB/sec
Timing buffered disk reads: 220 MB in 3.01 seconds = 73.08 MB/sec

/dev/hda:
multcount = 0 (off)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 19457/255/63, sectors = 312581808, start = 0

[hda = hard drive, hdc= dvd burner]
One final thing I've noticed which may be a clue is that reading off the hard drive seems to be slow/bottlenecked somehow on linux. In Nero on linux using the test maximum speed function it seems to max out around, ~14mb/s 10x, however on windows xp this same test maxes out around 51x.. which is noticeably faster. I however am at a loss right now to beat this thing. ... now that you have my life story please help!
 
Old 01-20-2008, 02:45 AM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Unfortunately, I have had the same problem for as long as I have had this current drive. Burning in Windows is fine, under Linux I can only get around 4x, and the buffer goes up and down the entire time (the burn will generally have to pause a number of times because there is nothing cached anymore).

I have never been able to find a solution, but honestly I don't use optical media much anymore so I have never really given it much of a try. It appears to be a DMA issue for me though, as my kernel logs start saying things about being unable to configure DMA on my burner during the burn. However, the DMA settings will work fine doing anything else. In fact, I seem to recall that I once checked my DMA settings with hdparm before and after the burn, and sure enough, all of my DMA settings were wiped.
 
Old 01-20-2008, 03:21 AM   #3
Molly
Member
 
Registered: Jan 2004
Distribution: Slackware, CentOS, Debian, OpenWRT, FreeBSD, OpenBSD, Solaris
Posts: 37

Original Poster
Rep: Reputation: 16
arrrg!

Ya your problem description is identical to mine, however my hdparm settings do always remain optimum The worst part about this is that it was working fine up until recently...

Let me know if you come up with any new info.

just curious, are you using a board with an nforce chipset also?
 
Old 01-20-2008, 04:58 AM   #4
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
I have a VIA VT8374 on this machine, burner is a LQ GSA-H10N. I am also running Slackware, but I don't think it is a Slackware issue either. It must something in the kernel. I remember I had to change an option in the kernel just to get the burner working (I would get SeekComplete errors otherwise) but the performance has never been good. On my previous burner I never had an issue like this.

I have tried things like increasing the buffer in K3B, but nothing so far has really made a dent in the problem. I would be interested in seeing if anyone has some suggestions, as I would like to get this sorted out if possible. I'm certainly open to trying things out.

By the way, this problem has persisted from my previous kernel (2.6.16, I believe) all the way to my current 2.6.23. I have never actually used the stock Slackware kernel(s), but it sounds like you are having the problem under multiple kernels as well. It is a strange issue.
 
Old 01-20-2008, 05:16 AM   #5
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,808

Rep: Reputation: 234Reputation: 234Reputation: 234
Quote:
Originally Posted by Molly View Post
UDMA modes: udma0 udma1 *udma2
Odd. That line should read:

Code:
UDMA modes: udma0 udma1 udma2 udma3 *udma4
Are you 100% sure you have built the correct support for your chipset into the kernel? They changed the IDE stuff fairly recently, so if you're using an older kernel config you may be missing a few things.
 
Old 01-20-2008, 04:08 PM   #6
Molly
Member
 
Registered: Jan 2004
Distribution: Slackware, CentOS, Debian, OpenWRT, FreeBSD, OpenBSD, Solaris
Posts: 37

Original Poster
Rep: Reputation: 16
Just to clarify, this is the output for the dvd burner:

/dev/hdc:

Model=BENQ DVD DD DW1640, FwRev=BSLB, SerialNo
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no


According to manufacturer specs, this is a udma2 drive, not udma4. It is also detected as udma2 in xp. I've been digging around in the kernel config some more and so far only managed to get the system locked in a panic on boot so no luck yet.
 
Old 01-20-2008, 06:24 PM   #7
Molly
Member
 
Registered: Jan 2004
Distribution: Slackware, CentOS, Debian, OpenWRT, FreeBSD, OpenBSD, Solaris
Posts: 37

Original Poster
Rep: Reputation: 16
Talking fixed it.

Alright.. I dug into the kernel config some more and streamlined things further. Kernel compiles take quite awhile here, so checking one option at a time is not feasible and so I'm still not sure exactly which option corrected the problem but now at least it's fixed and burns in k3b are back to normal with no problems at full 16x and no verification errors! hdparm -i output is still the same for both drives but ive noticed a twofold increase in speed on the dvd reads with hdparm -t -T. One other thing noticed is the software buffer indicator in k3b is no longer bouncing down to 0% and up and down .. it now remains near 100% during most of the burn.
Goodbye windows!


if anyone is curious:

Heres my current working .config : http://pastebin.com/f6eeb581d

and here's my current dmesg: http://pastebin.com/f4534eb2e


thanks

Last edited by Molly; 01-20-2008 at 06:46 PM.
 
Old 01-20-2008, 07:13 PM   #8
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,808

Rep: Reputation: 234Reputation: 234Reputation: 234
Which options did you change?
 
Old 02-27-2008, 01:26 PM   #9
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Please, answer the Q -- it might help someone else w/ the same problem.
 
Old 02-28-2008, 12:32 AM   #10
Molly
Member
 
Registered: Jan 2004
Distribution: Slackware, CentOS, Debian, OpenWRT, FreeBSD, OpenBSD, Solaris
Posts: 37

Original Poster
Rep: Reputation: 16
unfortunately ...

This problem has cropped up yet again since running 2.6.24.2 kernel and adding in some additional needed options such as nfs, lun probing, usb storage module to support some other devices/services I have ..

One new thing I've attempted: manually setting write buffer in k3b to 96MB or 2MB with no change either way.

It's not feasible for me to completely strip down my kernel disabling everything just to get a decent dvd burn. I have a job now and unfortunately/frustratingly don't have the time to devote to narrowing down the root cause as kernel compiles/reboots are very time consuming when attempting to troubleshoot a needle in a haystack like this one, so i've given up for the time being until free time permits. I will return to this thread in the future if I come up with anything else. As far as I can tell at this point, the issue has something to do with the way the latest run of linux kernels communicate with the chipsets/controller on my motherboard as the problem did not exist until late 2007 and since then has persisted across multiple distros, kernel versions, software configurations, and yet is non-existent in winxp on same box.

thanks
 
Old 02-28-2008, 08:58 AM   #11
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
I have no idea if this is relevant, but last night I did a set of CD burns using Knoppix 5.1 loaded ("toram" boot option) into 2GB of RAM. Source for the .iso was a flash drive & the burner an old Liteon 40x external.

My point is that at 1GB of RAM your system can run Knoppix in its "toram" mode -- this frees the optical drive & drastically speeds up the system. You might try this at least as a temp. work around, & possibly as a diagnostic tool.

Also, I'm not clear: did you make further kernel changes between the time it last burned well & now?
 
Old 02-28-2008, 02:02 PM   #12
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
One thing to try:
Use a filesystem other than ext3

I know it sounds mad, but it's not. Using ext3 filesystem can cause issues specifically with DVD burning. It's worth a try anyway.
 
Old 02-28-2008, 09:54 PM   #13
Molly
Member
 
Registered: Jan 2004
Distribution: Slackware, CentOS, Debian, OpenWRT, FreeBSD, OpenBSD, Solaris
Posts: 37

Original Poster
Rep: Reputation: 16
defeated

well, actually tonight I recompiled the 2.6.24-rc8 kernel I was originally running when I was able to get solid burns and also use the same .config file (the file i linked @ pastebin) and now even with this IDENTICAL configuration I am not able to get solid burns .. so i humbly accept defeat and give up. I've been using linux since '99 and, to date, this is the biggest headache i've yet come across. May god have mercy on all who meet with this problem.. woe unto us! I'm not going to get into this disaster again until I build up another box perhaps with a higher caliber motherboard or one known to be immune to controller/buffer issues with latest linux kernels


as for your filesystem other than ext3 suggestion.. I dont have the resources right now to get another partition going with another filesystem... And also.. I know dvd burning with ext3 was not causing me any problems previously if that matters.

Last edited by Molly; 02-28-2008 at 10:04 PM.
 
Old 02-29-2008, 07:04 AM   #14
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
It does, ergo ext3 is unlikely to be the problem.

The following Q's are numbered for your convenience in answering:
  1. Is it possible for you to undo the changes made since you were last able to burn solidly?
  2. Are you deleting/abandoning the old kernel when you compile a new one?
  3. Are you aware that you can have more that one kernel available to boot? -- MEPIS 7.0 has a mechanism to always maintain 3 in the GRUB boot menu. IIRC, Slack 12 is still using lilo, but lilo also can make more than one kernel available.
  4. Have you tried my live cd suggestion yet? -- It would isolate your problem either to h/w or OS & sh/would point you at a combination of kernel, KDE, & K3b versions that work.
 
Old 02-29-2008, 08:29 AM   #15
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Personally...I just bought a new DVD burner. The issue instantly cleared up, it is definitely a problem with specific burner's and not something systemic.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nero DVD Burning SW dynamic library resolution xxvandusen Linux - Software 0 08-01-2007 02:35 AM
Trouble with K3B and DVD Nero works fine ShaneK Linux - Software 0 12-29-2005 01:02 PM
Dvd burning very slow with k3b ! dadapanda Linux - Software 8 07-27-2005 06:31 AM
Dvd burning so slow , using K3b dadapanda Slackware 5 01-27-2005 08:38 AM
Slow DVD burning (k3b) daihard Linux - Software 8 12-26-2004 11:36 AM


All times are GMT -5. The time now is 12:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration