LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   slackware startx starts the wrong version, i didn't even know i had another version (http://www.linuxquestions.org/questions/linux-software-2/slackware-startx-starts-the-wrong-version-i-didnt-even-know-i-had-another-version-182148/)

edman007 05-16-2004 04:18 PM

slackware startx starts the wrong version, i didn't even know i had another version
 
i have slackware-current and was updating some stuff with slackpkg, most of it was gnome stuff, none of it was xfree86 stuff, it was all going good, then i logged out, i could have swarn i saw the xserver successufly restart for the login screen, but when i came back it said that it could not start the xserver because the config fine was gone (it just started looking for it in /etc instead of /etc/X11, strange, but i put link to the file to see if it would work, it didn't) it started giving an error on every part of the file, then i looked at the top, it said it was xfree86 3.3.39 compiled in 1999 and i'm using the very newest version from the slackware site (4.4.0), what happened?

then i found that this works just fine

Code:

startx -- /usr/X11/bin/XFree86
that starts the right version and gets me to a GUI, but i cant use that to start gdm and have a nice login

what do i have to do to get this to work right? please help :cry:

320mb 05-16-2004 04:25 PM

just re-do X


Code:

xf86config
it will re-write a new one for you...........

edman007 05-16-2004 04:31 PM

no i have a config file, its just looking in the wrong place and using a 5 year old version of xfree86 that i don't know where it came from, i can only get the right version to run if i use that startx command with an option giving the path to the server, and gdm won't run either because it has the same probem

edman007 05-16-2004 08:38 PM

i reinstalled Xfree86 and it all works now :)


All times are GMT -5. The time now is 08:13 PM.