LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-16-2004, 03:18 PM   #1
edman007
Member
 
Registered: Sep 2003
Distribution: Slamd64
Posts: 168

Rep: Reputation: 30
Angry slackware startx starts the wrong version, i didn't even know i had another version


i have slackware-current and was updating some stuff with slackpkg, most of it was gnome stuff, none of it was xfree86 stuff, it was all going good, then i logged out, i could have swarn i saw the xserver successufly restart for the login screen, but when i came back it said that it could not start the xserver because the config fine was gone (it just started looking for it in /etc instead of /etc/X11, strange, but i put link to the file to see if it would work, it didn't) it started giving an error on every part of the file, then i looked at the top, it said it was xfree86 3.3.39 compiled in 1999 and i'm using the very newest version from the slackware site (4.4.0), what happened?

then i found that this works just fine

Code:
startx -- /usr/X11/bin/XFree86
that starts the right version and gets me to a GUI, but i cant use that to start gdm and have a nice login

what do i have to do to get this to work right? please help
 
Old 05-16-2004, 03:25 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
just re-do X


Code:
xf86config
it will re-write a new one for you...........
 
Old 05-16-2004, 03:31 PM   #3
edman007
Member
 
Registered: Sep 2003
Distribution: Slamd64
Posts: 168

Original Poster
Rep: Reputation: 30
no i have a config file, its just looking in the wrong place and using a 5 year old version of xfree86 that i don't know where it came from, i can only get the right version to run if i use that startx command with an option giving the path to the server, and gdm won't run either because it has the same probem
 
Old 05-16-2004, 07:38 PM   #4
edman007
Member
 
Registered: Sep 2003
Distribution: Slamd64
Posts: 168

Original Poster
Rep: Reputation: 30
i reinstalled Xfree86 and it all works now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 02:54 PM
Wrong version of FSCK: HOW TO ? penguinlnx Linux - Newbie 12 05-28-2005 05:12 AM
startx failed Enterprise Version 3.0 dridge Linux - General 2 07-25-2004 09:21 PM
Self compiled modules have wrong version id ewschone Linux - General 1 06-20-2004 01:13 PM
wrong kernel version? enrico Slackware 4 05-01-2003 12:05 AM


All times are GMT -5. The time now is 12:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration