LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 07-21-2004, 11:27 AM   #1
scribble
LQ Newbie
 
Registered: Jul 2004
Location: Perth, W.A
Distribution: Slackware Current
Posts: 17

Rep: Reputation: 0
Unhappy Slackware only one channel of sound?


Ok i upgraded from slackware 9.1 to 10.0 and before this my sound was working perfectly. Now i only have sound coming through one channel.

I have run and re-run alsaconf many times and it goes flawlessly and detects my card and installs it. All volumes are up and theres no obvious balance probs.

I have checked all wiring and tried many different speakers and cables.


Can anyone help me with this debachel?


Thanks for your time,
Scribble
 
Old 07-21-2004, 12:25 PM   #2
netmask
Member
 
Registered: Jul 2004
Location: Sherbrooke, Quebec, Canada, North America, World, Milky Way
Distribution: Gentoo
Posts: 103

Rep: Reputation: 15
Make sure your programs use alsa and not oss.

I have Slackware 10 and I can play multiple sound files at once, or playing some music and play a game at the same time with sound

EDIT: Uh wait.. one channel as in one speaker?
 
Old 07-21-2004, 03:44 PM   #3
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Rep: Reputation: 0
I had the same problem (I had sound only in my headphones output)

Delete the /etc/asound.state
Run alsaconf again and set up your soundcard.
run alsamixer again to set volumes
run alsactl store
That was all I needed to do =)
Good luck...
 
Old 07-21-2004, 11:03 PM   #4
scribble
LQ Newbie
 
Registered: Jul 2004
Location: Perth, W.A
Distribution: Slackware Current
Posts: 17

Original Poster
Rep: Reputation: 0
Yep just one speaker.

I tried removing the asound and running everything again but that had no effect..
 
Old 07-22-2004, 12:28 PM   #5
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Rep: Reputation: 0
Strange...did alsaconf find your card?
Is your card the default in alsamixer?

Everything worked fine when I rm /etc/asound.state before I ran alsaconf again...I have soundblaster live 5.1 and Slack 10
 
Old 07-25-2004, 06:42 AM   #6
scribble
LQ Newbie
 
Registered: Jul 2004
Location: Perth, W.A
Distribution: Slackware Current
Posts: 17

Original Poster
Rep: Reputation: 0
Alsa config runs smooth as , detects my card to the T and the mixer also shows all the cards details so i know thats using it fine. Im completely stumped on this one
 
Old 01-09-2006, 11:54 PM   #7
tacogrande
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by Nihongoga
I had the same problem (I had sound only in my headphones output)

Delete the /etc/asound.state
Run alsaconf again and set up your soundcard.
run alsamixer again to set volumes
run alsactl store
That was all I needed to do =)
Good luck...

Thanks! worked like a charm!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
6 channel sound no sub Delphinusnz Mandriva 9 10-17-2004 06:43 AM
Slackware irc channel??? rosariowong Slackware 1 08-07-2004 09:49 AM
4 Channel Sound How to? bongski55 Slackware 5 07-27-2003 11:00 AM
ethernet channel bonding under slackware sublett Linux - Networking 1 05-08-2003 06:36 PM
ethernet channel bonding in slackware sublett Slackware 1 04-11-2003 12:43 AM


All times are GMT -5. The time now is 12:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration