LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-04-2003, 01:18 PM   #1
Timeturtle
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 42

Rep: Reputation: 15
Slackware 9.1 and mouse wheel


I just installed slack 9.1 and everything is up and working great but my mouse wheel. I dont know exactly how to set it up manually throught xf86config--Ive tried to add zaxismapping, but nothing seems to work. Maybe im not doing it right, or i just need to add something different, I dont know.

Any help would be greatly appreciated as this is really annoying.

My mouse is a logitech wheel mouse optical usb.

Thanks for any help.
(sorry, I know this is probably in the wrong forum. I realised this after the fact)

Last edited by Timeturtle; 10-04-2003 at 01:24 PM.
 
Old 10-04-2003, 02:05 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Hi Timeturtle!!

And welcome to LinuxQuestions.org. I don't know if this will also work with a USB mouse (I use a PS2 one). At your /etc/X11/XF86Config file, make sure that into Section "InputDevice", you have those lines:

Code:
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
	Option	    "Protocol" "IMPS/2"
That's how I got it to work under Slack. Good luck!

Last edited by Mega Man X; 10-04-2003 at 02:13 PM.
 
Old 10-04-2003, 03:55 PM   #3
Timeturtle
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 15
Hey, Megaman X that did the trick. Thanks a lot for that bit of advice, my mouse is working great now.
 
Old 10-04-2003, 05:41 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
You are welcome. I've to thank you too Timeturtle It is great when peoples answer us back saying if it worked or not . thanks again buddy
 
Old 10-05-2003, 01:42 AM   #5
FireLinux
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
Hi,

My Slackware 9.0 PS/2 mouse was working fine before I recompile the kernel to 2.4.22.

My /etc/X11/XF86Config for Pointer Section look like this:
Identifier "Mouse1"
Driver "mouse"
Option "ZAxisMapping" "4 5"
Option "Protocol" "IMPS/2"

My "ls -l /dev/mouse" output is /dev/mouse->psaux

But when I startx, error xf86OpenSerial: ... Device or resource busy

The xf86OpenSerial means Serial port?

Any advice is much appreciated..thx
 
Old 10-05-2003, 02:44 AM   #6
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Rep: Reputation: 30
Should it look like this?

[SIZE=1# Identifier and driver

Identifier "Mouse1"
Driver "mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

# Option "Protocol" "Auto"
Option. "ZAxisMapping" "4 5"
Option. "Emulate3Buttons" "no"
Option. "Protocol" "IMPS/2"

# The available mouse protocols types that you can set below are:
# Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
# Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
# MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
# ThinkingMouse ThinkingMousePS/2 Xqueue
Option "Protocol" "PS/2"
[/SIZE]

Or do I need the #?

Originally when I put it in, there were periods at the beginning of the line. I deleted those. What about the periods after option?

thanks
 
Old 10-05-2003, 05:11 AM   #7
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Hi FireLinux!!!

Welcome to LinuxQuestions.org. I'm not pretty sure what your problem might be, but one thing is for sure, if Slack is saying that the mouse is busy, then the mouse is busy . Assuming that you login in text mode (because you said you type startx ) there are some applications that allows you to use the mouse under text mode so you have the ability to copy/paste using the mouse. I cannot remember how it's called, but somebody may remember it and post here (let's cross our fingers..gheh). If you know which program that is, disable it to do not autostart when you boot.
Just a silly try too, at your /etc/XF86Config there is a section called "ServerFlags", add this line:

AllowMouseOpenFail

And see if you can start the server and use the mouse as usual. If not (but if you can start the X Servers) try to identify the program that is using your mouse, kill it at the console and re-start X.

I cannot think about anything else I never have had that problem, but I wish you good luck!.

@ flamesrock

I'm not sure if I've understood your question. The hash (#) is used as a "comment". When commented, a line has no effect at all when the computer reads the file. If you for example uncomment the line :


# Option "Protocol" "Auto"

to

Option "Protocol" "Auto"

The this line is now active and will be used when the computer looks after that file. You have to do that if you need an specific function to work. The art of commenting is used for you to remember what a specific part of a program does. I think all programming languages has a way to comment:


# comment
// comment (C style)
/* comment */ (C++ style)
<! comment -> (HTML style)


Be very careful removing the hash symbol from files, most likely you will kill your system if you don't know what you are doing . For instance, removing the hash from

# The available mouse protocols types that you can set below are:

Will make your X server to fail, because that is an invalid argument... also called as "statement"

Last edited by Mega Man X; 10-05-2003 at 05:16 AM.
 
Old 10-05-2003, 05:41 AM   #8
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
FireLinux, the program that Megaman is referring to is gpm. You can disable it with the following commands, run as root:

cd /etc/rc.d
./rc.gpm stop
chmod 644 rc.gpm

to enable it again:

cd /etc/rc.d
chmod 755 rc.gpm
./rc.gpm start

Enjoy!
--- Cerbere
 
Old 10-05-2003, 05:45 AM   #9
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Cool . Thanks a lot for the quick and helpful info Cerbere, nice LinuxQuestions.org team work .
 
Old 10-05-2003, 03:20 PM   #10
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Rep: Reputation: 30
Thanks, MM
 
Old 10-06-2003, 12:13 AM   #11
FireLinux
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
Thanks for your prompt respond Megaman X and Cerbere.. :-)

For your info, initially I suspect that gpm busy up my /dev/mouse resource, so I remove it... but I still have the same problem..

How to identifiy which process occupied which resource ?

I will try it out and let you guy know the result..


Thxs.
:-)
 
Old 10-06-2003, 09:57 PM   #12
FireLinux
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
I tried to add "AllowMouseOpenFail
" into my /etc/X11/XF86Config in ServerFlags section, but the problem still can't be solved.

Anyway, I successfully bring up my Serial mouse which previously can't work, coz the serial port was disabled in my Pheonix BIOS.

I believe it have something related to the setting in my new kernel image, I will go through the log file again to see what I can do..

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware - how to get mouse scroll wheel working xanas3712 Slackware 17 10-21-2007 05:04 PM
Mouse wheel doesn't work in slackware thorney Linux - Newbie 3 08-02-2005 11:02 AM
Where's my mouse wheel? Slackware 10 windeath Slackware 3 08-05-2004 11:50 PM
wheel/mouse with slackware Harp00 Linux - Newbie 2 09-26-2003 10:07 AM
Mouse Wheel In Slackware 8.1 Tenaka2k Linux - Newbie 3 04-11-2003 09:27 PM


All times are GMT -5. The time now is 03:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration