LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-29-2003, 10:09 PM   #1
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Rep: Reputation: 30
Slackware 9.0 GUI?


Im able to boot in Linux but when I do I get text mode instead GUI like Gnome or Kde? how can I get it right? Always I need to type startx. And now I cant enter into Windows. Do I need enable Windows as bootable in the flag partition? what is the problem now?

Last edited by Gerardoj; 06-29-2003 at 10:14 PM.
 
Old 06-29-2003, 10:36 PM   #2
andrew001
Member
 
Registered: Nov 2002
Distribution: Slackware 9.0
Posts: 321

Rep: Reputation: 30
What do you mean enter into windows? If you want to start up graphically with kde or gnome, you need to enable run level 3 (sorry I can't be more specific, but I've never done it).

Or, you can put 'startx' in your '.profile' and it will execute automatically when you login.
 
Old 06-29-2003, 10:43 PM   #3
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Original Poster
Rep: Reputation: 30
Respect Log in into Microsoft Windows I configured lilo but not appear me nothing and what did you mean about enable run level 3? and where is the '.profile_? and I forget always I need to put the root login and password is this a problem? Thanks
 
Old 06-30-2003, 01:12 AM   #4
JunLitsu
Member
 
Registered: Apr 2002
Distribution: Gentoo
Posts: 95

Rep: Reputation: 15
If u want to boot directly into x you switch the default to run level 5, run level 3 is just the command line. What do you mean by not being able to boot into windows, there an error message on the boot loader?
 
Old 06-30-2003, 01:23 AM   #5
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
open /etc/inittab and change id:3:initdefault (or something like this, it's the first uncommented line) by id:4:initdefault (of course you need to have a working X11)

about windows, not sure about the question, but with fdisk (or cfdisk if you want something with menu) you can make windows partition bootable, but you should not need it to boot with lilo.
 
Old 06-30-2003, 01:32 AM   #6
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Original Poster
Rep: Reputation: 30
- about windows , I have installed Win2k but I cant see it in the LILO menu , I tried to configure LILO.conf with:

other = /dev/hda1
table=/dev/hda
label=Windows

but nothing happened,
-How can I switch the default to run level 5?

- also I want to change my keyboar map to Spanish, how can I do that?

- and How can I change the resolution of my gnome I tried Crtl, Alt, -+ but I would like to change to 840 for my default resolution

Thanks

Last edited by Gerardoj; 06-30-2003 at 01:35 AM.
 
Old 06-30-2003, 02:00 AM   #7
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Quote:
-How can I switch the default to run level 5?
open /etc/inittab and change id:3:initdefault (or something like this, it's the first uncommented line) by id:4:initdefault
Have you read my post???


to install lilo.conf modification, you need to run lilo again.
type "lilo"

dont remember for the keyboard, take a look in /etc/rd.d and search for keyboard map I believe.

take a look to /etc/X11/XF86Config files, change your default resolution in it, I'm too tired to takea look at mine but it should be easy. In worst case, backup it and then run xf86config to create a new file (a script will help you doing it).
 
Old 06-30-2003, 07:44 PM   #8
grym
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Gentoo/Slackware/Debian/Mandrake
Posts: 285

Rep: Reputation: 30
run level

i wouldn't change runlevel at all
just add

/opt/kde/bin/kdm

for kdm
or

/usr/bin/gdm

if you prefer gdm

to your /etc/rc.d/rd.local file
changing runlevel altho it would work makes access to text consoles problematic - please see bottom of intitab for details
(by the way slack uses 4 for gui not 5)

as for your changes to lilo did you run

/sbin/lilo

after making your changes

good luck
 
Old 06-30-2003, 08:01 PM   #9
grym
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Gentoo/Slackware/Debian/Mandrake
Posts: 285

Rep: Reputation: 30
I would like to change to 840 for my default resolution

Do you mean 800x600 or 640x480?

changing default resolution is done in /etc/X11/XF86Config file.
In the Screen section put the mode that you want first as the first listed dfor your default depth

example

Section "Screen"
Identifier "Screen 1"
Device "NVIDIA GeForce"
Monitor "My Monitor"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

as you can see my DefaultDepth is 24 and the first Mode listed for 24 is "1600x1200" so that would be the default resolution.

keyboard map is changed in the same file. look for
# Option "XkbLayout" "de"

uncomment it by removing the # symbol and change "de" to the spanish map

and for text console use loadkeys for more information see
http://www.linuxhq.com/ldp/howto/Danish-HOWTO-2.html

good luck
 
Old 06-30-2003, 08:37 PM   #10
nuzzy
Member
 
Registered: Aug 2001
Location: New Hampshire, USA
Distribution: Ubuntu 6.06 LTS
Posts: 204

Rep: Reputation: 31
Half_Elf is right. Change the /etc/inittab entry he mentioned.
 
Old 07-01-2003, 03:37 AM   #11
grym
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Gentoo/Slackware/Debian/Mandrake
Posts: 285

Rep: Reputation: 30
inittab

i know changing inittab works to an extent however as i said there are reasons not to do it that way which are mentioned in the inittab file itself at the bottom. if your happy with it that way tho that's what matters.
 
Old 07-02-2003, 02:36 AM   #12
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Original Poster
Rep: Reputation: 30
Thanks all, Now works , Thanks Again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Does Slackware have a GUI? zahadumy Slackware 27 11-25-2005 11:54 PM
No GUI in SLackware 10?! Worksman Slackware 20 11-19-2004 09:53 PM
GUI for Slackware btexpress Slackware 10 05-17-2004 12:30 AM
slackware GUI ggrzech Linux - Newbie 1 03-14-2004 01:57 AM
slackware gui? emory7825 Linux - Newbie 3 11-26-2001 04:16 PM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration