LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Slackware 8: ./configure --prefix=/opt/gnome not working (http://www.linuxquestions.org/questions/linux-software-2/slackware-8-configure-prefix%3D-opt-gnome-not-working-10113/)

vendemmian 12-14-2001 08:12 PM

Slackware 8: ./configure --prefix=/opt/gnome not working
 
I ve got loads of tar.gz apps, I want to compile for gnome, so to keep with the Slackware standard, I tried to build them using:

./configure --prefix=/opt/gnome
make
make install prefix=/usr/src/tgz/install/
then build tgz files

The build and making the files goes great,
but for some strange reason they keep going into /bin or /share /man.

Is there something Iam doing wrong?

Aussie 12-14-2001 08:43 PM

I just do,
./configure --prefix=/opt/gnome
make
su
make install
and don't bother with making .tgz packages, I've had everything install in /opt/gnome with no problems.

paavaka 12-14-2001 11:49 PM

Suggestion:

make install prefix=/usr/src/tgz/install/opt/gnome

When I was compiling Gnome I found that if I didn't specify the opt/gnome directory within the temporary one, it sent the files elsewhere.

But if you go to linuxpackages.net, they have two tools there that can help in managing source code installs on Slackware. They are 'checkinstall' and 'protopkg'. I haven't tried protopkg yet, but I will soon as I am not entirely happy with checkinstall, though it works great if you are in a hurry. Checkinstall monitors the install process and creates a package for you, and if for whatever reason the install fails, it will replace the files that were overwritten. I believe protopkg allows you to create a parameter file used to build the package and then it takes care of the rest.

Whatever you do, don't place the fake destination in the configure --prefix=. I was doing that with the intention of wrapping the files in the package and installing them, but if your package contains any libraries then the fake path is hardcoded into them, causing all sorts of problems. Though it does work for smaller packages.


All times are GMT -5. The time now is 10:10 AM.