LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-10-2009, 08:00 PM   #1
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
Slackware 12.2 won't boot to initrd


The computer boots fine to the HUGE kernel, but if I set up initrd with the generic, I get the 'no /sbin/init on rootdev' error. I have the same setup on another computer and it works fine.

I'm using a standard Slackware install on a P3 ASUS TUSL2.
I have an Adaptec 2940xx that I use for the cd-rw. I think that may be causing the problem. I have used this card before with Slackware 12.0 and 12.1 without issue, but I noticed that mkinitrd seems to be fussier on 12.2.

Is is possible that the kernel (or initrd.gz) is interpreting the SCSI as hda? If so, what can I do?
 
Old 01-11-2009, 01:38 AM   #2
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Original Poster
Rep: Reputation: 21
Got it.
I added aic7xxx module to the mkinitrd along with reiserfs and away we go.
One side note...be sure and run lilo after making changes to lilo.conf or mkinitrd (so says Pat V.) Had I done that I think it would have taken less time.
 
Old 01-11-2009, 06:37 PM   #3
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Original Poster
Rep: Reputation: 21
Something else...After getting up and running, I checked out the changelog and noticed an update for mkinitrd. Some of the issues that were fixed had contributed to the trouble that I was having.
Also, although my system was running fine with only the reiserfs mod being loaded at startup (before the upgrade to 12.2,) I noticed that loading aic7xxx seems to help my cd-rw drive to be identified without linux trying to load wd7000 and other scsi and raid drivers and, I think, making the drive more useful.
I always thought that you only need to load modules at boot for the drives and controllers that you will need for your boot partition. I would strongly recommend that if you have a controller (scsi or sata or whatever) that you add the module to mkinitrd even if it is not needed for boot. Not only will your /dev be identified more accurately, but you may find that the device functions better. It does on mine.
 
Old 01-11-2009, 06:43 PM   #4
bapigoo9
Member
 
Registered: Aug 2008
Posts: 107

Rep: Reputation: 16
Quote:
Originally Posted by ryerke View Post
Not only will your /dev be identified more accurately, but you may find that the device functions better. It does on mine.
Any specifications on how much better your device (what device?) is running? Using the correct driver for a device is always what you should do. You have solved your post question?
 
Old 01-12-2009, 12:52 AM   #5
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Original Poster
Rep: Reputation: 21
When I had the computer booting to the HUGE kernel, the Adaptec card would attempt to load the aic7xxx driver followed by numerous other drivers and eventually be identified by wd7000 (Western Digital scsi controller) according to lspci. I could play cd's and even write cdr's but I didn't have all of the options that I should have had with the HP CD-Writer. I also don't think that I was getting the performance that I should have been getting. Adding aic7xxx to the initrd has caused the scsi card to remain Adaptec 2940xx in lspci.
Yes, the problem is solved. I was not able to boot until I added the aic7xxx to the initrd. I think that the controller was confusing the boot process into thinking that the scsi was hda, making the ide channes 1 appear as hdb. I considered trying to change the boot device to hdb1 but that seemed like more of a hack than a cure for the problem. Adding the module to inird straightened everything out so that I can boot to hda1.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12.2 not starting with an initrd Didier Spaier Slackware - Installation 4 12-20-2008 01:44 PM
Slackware 12 initrd issue nc3b Slackware 15 04-17-2008 09:05 PM
Failed to symbolic-link boot/initrd.img-2.6.18-4-486 to initrd.img Scotteh Linux - Software 8 06-01-2007 11:24 PM
slackware 11.0 and initrd mscole Slackware 4 10-13-2006 06:44 AM
slackware 10.2, kernel 2.6.16, and initrd alphisb0t Slackware 3 03-22-2006 01:58 PM


All times are GMT -5. The time now is 01:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration