LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-29-2004, 01:52 PM   #1
harlow400
LQ Newbie
 
Registered: Jan 2003
Location: South Portland, Maine USA
Distribution: Slackware 9.0
Posts: 12

Rep: Reputation: 0
Exclamation slack 9.0 apachectl startssl doesn't work


hello:

i have a new install of apache 1.3.29 on slackware 9.0. apachectl start works fine, but if i say apachectl startssl i get the following error:

Syntax error on line 1043 of /usr/local/apache/conf/httpd.conf:
Invalid command 'SSLEngine', perhaps mis-spelled or defined by a module not included in the server configuration
/usr/local/apache/bin/apachectl startssl: httpd could not be started


any ideas?

thx!

jh
 
Old 02-29-2004, 01:53 PM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
do you have ssl installed and did you compile apache with ssl?
 
Old 02-29-2004, 04:05 PM   #3
harlow400
LQ Newbie
 
Registered: Jan 2003
Location: South Portland, Maine USA
Distribution: Slackware 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
yeah, i have openssl and mod_ssl installed. now instead of the error listed above, it just says

usr/local/apache/bin/apachectl startssl: httpd could not be started

with no details or hints....:-(
 
Old 02-29-2004, 04:07 PM   #4
harlow400
LQ Newbie
 
Registered: Jan 2003
Location: South Portland, Maine USA
Distribution: Slackware 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
here is what the logs say:

[29/Feb/2004 16:44:33 07007] [error] Init: Unable to read server certificate from file /usr/local
/apache/conf/ssl.crt/server.crt (OpenSSL library error follows)
[29/Feb/2004 16:44:33 07007] [error] OpenSSL: error:0D06B08E:asn1 encoding routines:ASN1_d2i_bio:
not enough data
 
Old 02-29-2004, 09:03 PM   #5
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
hmmm.... i'm googling on the first line of the error and maybe it is a configure issue with you when building apache.

http://www.mail-archive.com/modssl-u.../msg09554.html

here's a page on configuring apache to use ssl (httpd.conf editing).

http://ist.uwaterloo.ca/security/lib.../howto/ssleay/

Last edited by megaspaz; 02-29-2004 at 09:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack 10.1 will a Slack 10 Wine pkg work? acummings Slackware 1 03-25-2005 04:55 AM
apachectl startssl error message harlow400 Linux - Software 2 03-01-2004 02:31 AM
apachectl startssl doesn't work on SuSE 9.0 ahargrove Linux - Software 3 02-16-2004 11:02 PM
startssl segfaults :'( chr15t0 Linux - Software 7 01-21-2003 03:59 AM
Adding "apachectl startssl" to startup morbo Linux - Networking 2 10-01-2002 05:48 AM


All times are GMT -5. The time now is 09:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration