LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-28-2012, 04:01 PM   #1
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: Debian Testing with xfce
Posts: 219

Rep: Reputation: 19
Skype Won't Install


Anyone tried to install Skype in Debian Testing lately?
Code:
# dpkg -i skype-debian_4.1.0.20-1_i386.deb 
(Reading database ... 178138 files and directories currently installed.)
Preparing to replace skype 4.1.0.20-1 (using skype-debian_4.1.0.20-1_i386.deb) ...
Unpacking replacement skype ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libqt4-dbus (>= 4:4.5.3); however:
  Package libqt4-dbus:i386 is not configured yet.
 skype depends on libqt4-network (>= 4:4.8.0); however:
  Package libqt4-network:i386 is not configured yet.
 skype depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml:i386 is not configured yet.
 skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
  Package libqtcore4:i386 is not configured yet.
 skype depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:i386 is not configured yet.
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
  Package libqtwebkit4:i386 is not installed.
 skype depends on libxss1; however:
  Package libxss1:i386 is not configured yet.
 skype depends on libxv1; however:
  Package libxv1:i386 is not configured yet.

dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 skype
It's demanding packages that are older than what I have installed.

I tried putting this in sources.list:
deb http://download.skype.com/linux/repos/debian/ stable non-free
... but that directory doesn't exist and download.skype.com/linux/repos/debian/ won't let me have a directory listing.

Last edited by Quantumstate; 11-29-2012 at 11:34 AM.
 
Old 11-29-2012, 03:11 AM   #2
pan64
Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 5,139

Rep: Reputation: 1363Reputation: 1363Reputation: 1363Reputation: 1363Reputation: 1363Reputation: 1363Reputation: 1363Reputation: 1363Reputation: 1363Reputation: 1363
first try yo install the missing package (Package libqtwebkit4:i386 is not installed).
 
Old 11-29-2012, 03:57 AM   #3
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622
Quote:
Originally Posted by Quantumstate View Post
Anyone tried to install Skype in Debian Testing lately?
Yes in Wheeezy amd64 and Sid amd64, it will not install even though it is supposed to be multiarch. If you are using Debian amd64 then sorry can't help you, if you are using Debian i386 load Squeeze into your sources list and force the install of the older packages. Not very tidy but it may work for you.
 
Old 11-29-2012, 08:35 AM   #4
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,455

Rep: Reputation: 104Reputation: 104
probably there are complete binaries available at skype.com that should work because they have the qt libraries compiled in. At least there were in the past, don't know the current state
 
Old 11-29-2012, 11:34 AM   #5
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: Debian Testing with xfce
Posts: 219

Original Poster
Rep: Reputation: 19
It turns out that there's a bug in Debian that prevents install. If you go here down to 7.0+ at 64-bit, and read -all- the instructions, it will install. I have it working now.
 
Old 11-29-2012, 08:39 PM   #6
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: Debian Testing with xfce
Posts: 219

Original Poster
Rep: Reputation: 19
Well, maybe I spoke too soon.

Skype runs, and logs into my account, and I can hear audio, but when I speak it does not work through the call testing service. My mike seems to be dead. Maybe it's muted, but pulse mixer in xfce doesn't have a Mike setting.

Anyone had this experience?

Also I find in Advanced settings that incoming calls come in on port 3075. My firewall is very tight, so anyone know if this is TCP, or UDP?
 
Old 11-29-2012, 09:35 PM   #7
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622
It won't install for me at all on this install. I'll give it a while cause I'm going to do a clean install sometime soon and try it again.
 
Old 11-30-2012, 01:00 AM   #8
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: Debian Testing with xfce
Posts: 219

Original Poster
Rep: Reputation: 19
No idea what kind of error you're getting k3lt01. Did you read -all- the instructions?
 
Old 11-30-2012, 01:09 AM   #9
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622
Yes I have read all the instructions, I cannot get the dependencies to install. There are more dependencies for 4.1 than there are for 4.0 and it just wont install for me on any of my current systems.
 
Old 11-30-2012, 03:52 PM   #10
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: Debian Testing with xfce
Posts: 219

Original Poster
Rep: Reputation: 19
Well, there aren't any dependencies for the method I'd described and used.
 
Old 11-30-2012, 06:17 PM   #11
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622
Quote:
Originally Posted by Quantumstate View Post
Well, there aren't any dependencies for the method I'd described and used.
I'm overjoyed for you.
 
Old 12-01-2012, 02:00 PM   #12
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622
Quote:
Originally Posted by Quantumstate View Post
Well, there aren't any dependencies for the method I'd described and used.
Tried again and Gdebi said there were 62 dependencies, couple of minutes later it is installed. Will test it tonight or tomorrow morning when a friend of mine gets online.
 
Old 12-01-2012, 05:30 PM   #13
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: Debian Testing with xfce
Posts: 219

Original Poster
Rep: Reputation: 19
You are just not getting what I am saying. I am trying to help you, even though no one is helping me.

Here are the instructions I followed, and they work (except for microphone):
Quote:
7.0+ at 64-bit

Using a terminal, enter the following command under the root and press Enter:

dpkg --add-architecture i386 && apt-get update

Download and install Debian 7.0+ i386. (multiarch)

Important: If you have libqtwebkit4:amd64 already installed, the installation will fail due to a Debian bug.

To fix this, using a terminal and under root, enter the following command and press Enter:

rm /usr/share/doc/libqtwebkit4/changelog.Debian.gz && apt-get -f install
There is no apt-get install, so there can be no dependencies. Use dpkg -i to install Skype.

Last edited by Quantumstate; 12-01-2012 at 05:35 PM.
 
Old 12-01-2012, 07:22 PM   #14
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622
Quote:
Originally Posted by Quantumstate View Post
You are just not getting what I am saying. I am trying to help you, even though no one is helping me.

Here are the instructions I followed, and they work (except for microphone):


There is no apt-get install, so there can be no dependencies. Use dpkg -i to install Skype.
Whoa there Quantumstate. I did get what you said and regardless of what you said Skype 4.1 would not install on my system. I followed the method in your prior posts and it did not work. I have been working on this since 4.1 was released and only now has it actually installed and the issue was skype required dependencies on my system that were not there and would not install until this morning.

Nothing worked, gdebi, dpkg, apt, nothing, until this morning. Thanks for your efforts I do appreciate them but it seems your problem was not the same as mine.
 
Old 12-25-2012, 04:04 AM   #15
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622Reputation: 622
Code:
root@michael-laptop:/home/uluru# dpkg --add-architecture i386 && apt-get update
Hit http://security.debian.org wheezy/updates InRelease
Hit http://security.debian.org wheezy/updates/main amd64 Packages              
Hit http://security.debian.org wheezy/updates/contrib amd64 Packages           
Hit http://security.debian.org wheezy/updates/non-free amd64 Packages          
Hit http://security.debian.org wheezy/updates/main i386 Packages               
Hit http://security.debian.org wheezy/updates/contrib i386 Packages            
Hit http://security.debian.org wheezy/updates/non-free i386 Packages           
Hit http://ftp.au.debian.org testing InRelease                                 
Err http://au.debian.org experimental InRelease                                
  
Err http://au.debian.org experimental Release.gpg                              
  Could not resolve 'au.debian.org'
Hit http://ftp.au.debian.org wheezy-proposed-updates InRelease                 
Hit http://ftp.au.debian.org testing/main amd64 Packages/DiffIndex             
Hit http://ftp.au.debian.org testing/contrib amd64 Packages/DiffIndex          
Hit http://ftp.au.debian.org testing/non-free amd64 Packages/DiffIndex         
Get:1 http://ftp.au.debian.org testing/main i386 Packages/DiffIndex [7,876 B]  
Get:2 http://ftp.au.debian.org testing/contrib i386 Packages/DiffIndex [7,819 B]
Hit http://ftp.debian.org wheezy-updates InRelease                             
Ign http://mozilla.debian.net experimental InRelease                           
Get:3 http://www.deb-multimedia.org wheezy InRelease [32.8 kB]                 
Hit http://repo.mate-desktop.org wheezy InRelease                              
Ign http://linux.dropbox.com wheezy InRelease                                  
Get:4 http://ftp.au.debian.org testing/non-free i386 Packages/DiffIndex [7,819 B]
Hit http://ftp.au.debian.org testing/contrib Translation-en/DiffIndex
Hit http://ftp.au.debian.org testing/main Translation-en/DiffIndex
Hit http://ftp.au.debian.org testing/non-free Translation-en/DiffIndex
Hit http://ftp.au.debian.org wheezy-proposed-updates/contrib amd64 Packages
Hit http://ftp.au.debian.org wheezy-proposed-updates/non-free amd64 Packages
Hit http://ftp.au.debian.org wheezy-proposed-updates/main amd64 Packages/DiffIndex
Hit http://ftp.au.debian.org wheezy-proposed-updates/contrib i386 Packages
Hit http://ftp.au.debian.org wheezy-proposed-updates/non-free i386 Packages    
Get:5 http://ftp.au.debian.org wheezy-proposed-updates/main i386 Packages/DiffIndex [7,819 B]
Hit http://linux.dropbox.com wheezy Release.gpg                                
Get:6 http://mozilla.debian.net experimental Release.gpg [828 B]               
Hit http://ftp.au.debian.org wheezy-proposed-updates/contrib Translation-en    
Hit http://ftp.au.debian.org wheezy-proposed-updates/main Translation-en/DiffIndex
Hit http://repo.mate-desktop.org wheezy/main amd64 Packages                    
Hit http://ftp.debian.org wheezy-updates/main amd64 Packages                   
Hit http://ftp.au.debian.org wheezy-proposed-updates/non-free Translation-en   
Hit http://www.deb-multimedia.org wheezy/main amd64 Packages/DiffIndex         
Hit http://linux.dropbox.com wheezy Release                                    
Hit http://mozilla.debian.net experimental Release                             
Ign http://mozilla.debian.net experimental Release                             
Hit http://linux.dropbox.com wheezy/main amd64 Packages                        
Ign http://security.debian.org wheezy/updates/contrib Translation-en_AU        
Ign http://security.debian.org wheezy/updates/contrib Translation-en           
Ign http://security.debian.org wheezy/updates/main Translation-en_AU           
Hit http://repo.mate-desktop.org wheezy/main i386 Packages                     
Ign http://security.debian.org wheezy/updates/main Translation-en              
Hit http://ftp.debian.org wheezy-updates/contrib amd64 Packages                
Ign http://mozilla.debian.net experimental/iceweasel-beta amd64 Packages/DiffIndex
Ign http://security.debian.org wheezy/updates/non-free Translation-en_AU       
Hit http://www.deb-multimedia.org wheezy/non-free amd64 Packages/DiffIndex     
Ign http://security.debian.org wheezy/updates/non-free Translation-en          
Hit http://linux.dropbox.com wheezy/main i386 Packages                         
Ign http://mozilla.debian.net experimental/iceweasel-aurora amd64 Packages/DiffIndex
Hit http://ftp.debian.org wheezy-updates/non-free amd64 Packages               
Get:7 http://www.deb-multimedia.org wheezy/main i386 Packages/DiffIndex [2,023 B]
Ign http://mozilla.debian.net experimental/iceweasel-beta i386 Packages/DiffIndex
Hit http://ftp.debian.org wheezy-updates/main i386 Packages                    
Ign http://mozilla.debian.net experimental/iceweasel-aurora i386 Packages/DiffIndex
Get:8 http://www.deb-multimedia.org wheezy/non-free i386 Packages/DiffIndex [2,023 B]
Hit http://ftp.debian.org wheezy-updates/contrib i386 Packages                 
Hit http://ftp.debian.org wheezy-updates/non-free i386 Packages                
Ign http://linux.dropbox.com wheezy/main Translation-en_AU                     
Ign http://linux.dropbox.com wheezy/main Translation-en                        
Ign http://repo.mate-desktop.org wheezy/main Translation-en_AU                 
Ign http://repo.mate-desktop.org wheezy/main Translation-en                    
Ign http://www.deb-multimedia.org wheezy/main Translation-en_AU       
Ign http://www.deb-multimedia.org wheezy/main Translation-en                   
Ign http://www.deb-multimedia.org wheezy/non-free Translation-en_AU            
Hit http://mozilla.debian.net experimental/iceweasel-beta amd64 Packages       
Ign http://www.deb-multimedia.org wheezy/non-free Translation-en               
Hit http://mozilla.debian.net experimental/iceweasel-aurora amd64 Packages     
Hit http://mozilla.debian.net experimental/iceweasel-beta i386 Packages        
Hit http://mozilla.debian.net experimental/iceweasel-aurora i386 Packages
Ign http://mozilla.debian.net experimental/iceweasel-aurora Translation-en_AU
Ign http://mozilla.debian.net experimental/iceweasel-aurora Translation-en
Ign http://mozilla.debian.net experimental/iceweasel-beta Translation-en_AU
Ign http://mozilla.debian.net experimental/iceweasel-beta Translation-en
Ign http://ftp.debian.org wheezy-updates/contrib Translation-en_AU
Ign http://ftp.debian.org wheezy-updates/contrib Translation-en
Ign http://ftp.debian.org wheezy-updates/main Translation-en_AU
Ign http://ftp.debian.org wheezy-updates/main Translation-en
Ign http://ftp.debian.org wheezy-updates/non-free Translation-en_AU
Ign http://ftp.debian.org wheezy-updates/non-free Translation-en
Fetched 69.1 kB in 16s (4,078 B/s)
Reading package lists... Done
W: GPG error: http://mozilla.debian.net experimental Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 85A3D26506C4AE2A
W: Failed to fetch http://au.debian.org/debian/dists/experimental/InRelease  

W: Failed to fetch http://au.debian.org/debian/dists/experimental/Release.gpg  Could not resolve 'au.debian.org'

W: Some index files failed to download. They have been ignored, or old ones used instead.
W: Duplicate sources.list entry http://mozilla.debian.net/ experimental/iceweasel-beta amd64 Packages (/var/lib/apt/lists/mozilla.debian.net_dists_experimental_iceweasel-beta_binary-amd64_Packages)
W: Duplicate sources.list entry http://mozilla.debian.net/ experimental/iceweasel-beta amd64 Packages (/var/lib/apt/lists/mozilla.debian.net_dists_experimental_iceweasel-beta_binary-amd64_Packages)
W: Duplicate sources.list entry http://mozilla.debian.net/ experimental/iceweasel-beta i386 Packages (/var/lib/apt/lists/mozilla.debian.net_dists_experimental_iceweasel-beta_binary-i386_Packages)
W: Duplicate sources.list entry http://mozilla.debian.net/ experimental/iceweasel-beta i386 Packages (/var/lib/apt/lists/mozilla.debian.net_dists_experimental_iceweasel-beta_binary-i386_Packages)
root@michael-laptop:/home/uluru# 


root@michael-laptop:/home/maralinga/Downloads# dpkg -i skype-debian_4.1.0.20-1_i386.deb
Selecting previously unselected package skype.
(Reading database ... 145120 files and directories currently installed.)
Unpacking skype (from skype-debian_4.1.0.20-1_i386.deb) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libasound2 (>= 1.0.16).
 skype depends on libc6 (>= 2.3.6-6~).
 skype depends on libc6 (>= 2.7).
 skype depends on libgcc1 (>= 1:4.1.1).
 skype depends on libqt4-dbus (>= 4:4.5.3).
 skype depends on libqt4-network (>= 4:4.8.0).
 skype depends on libqt4-xml (>= 4:4.5.3).
 skype depends on libqtcore4 (>= 4:4.7.0~beta1).
 skype depends on libqtgui4 (>= 4:4.8.0).
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13).
 skype depends on libstdc++6 (>= 4.6).
 skype depends on libx11-6.
 skype depends on libxext6.
 skype depends on libxss1.
 skype depends on libxv1.
 skype depends on libssl1.0.0.

dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 skype
root@michael-laptop:/home/maralinga/Downloads#
Totally new Debian Wheezy install and this is what I get with tryong to install Skype. Please don't come and tell me there are no dependencies

Went to the Debian Wiki and followed the instructions there.

dpkg installed 66 dependencies and then installed Skype.

Last edited by k3lt01; 12-25-2012 at 04:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why won't Skype let me open an account? moxieman99 General 5 11-16-2011 12:52 PM
[SOLVED] skype won't work on my rhel 6.0 Hassan989 Linux - Software 4 04-11-2011 12:22 PM
noise in skype to skype calls in skype v2.1 beta for fedora mq15 Linux - Software 0 01-20-2010 01:04 AM
Skype won't install in Suse 10.3 Sandie Suse/Novell 3 03-18-2008 09:20 AM
Skype won't install on Mandriva 2007 x86 64 BLACADDER Linux - Newbie 6 11-12-2006 10:07 AM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration