LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-15-2006, 05:59 PM   #1
giueno
LQ Newbie
 
Registered: Oct 2004
Location: Italy
Distribution: Debian
Posts: 7

Rep: Reputation: 0
Skype: problem with audio device


hi

I'm running debian unstable
My audio device works very well
I'm using alsa
My audio device work from user too
All the members of all the groups are well setted
I'm using udevd.


but when i try to call a skype user i get this message:

volume_open: error opening /dev/mixer: No such file or directory
/dev/dsp-1: Permission denied

of course, I don't have:
/dev/dsp
/dev/dsp*
/dev/mixer

and i think that I don't need it: I'm using alsa and udevd!
Someone can help me to solve this stupid isses? Google is tired to execute my searches..
 
Old 05-15-2006, 06:25 PM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Redo skype config, or symlinks /dev/sound/dsp to /dev/dsp etc...
 
Old 05-16-2006, 03:57 AM   #3
giueno
LQ Newbie
 
Registered: Oct 2004
Location: Italy
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: 0
I haven't /dev/sound folder...

looking in /dev/ folder, I can find only

/dev/.static/dev/dsp
/dev/.static/dev/dsp1
/dev/.static/dev/dsp2
/dev/.static/dev/dsp3

and

/dev/.static/dev/mixer
/dev/.static/dev/mixer1
/dev/.static/dev/mixer2
/dev/.static/dev/mixer3

eh?
 
Old 05-16-2006, 08:06 AM   #4
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Then do symlinks, ie:
ln -s /dev/.static/dev/dsp /dev/dsp
etc...
 
Old 05-23-2006, 06:54 AM   #5
giueno
LQ Newbie
 
Registered: Oct 2004
Location: Italy
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: 0
solved anyway

thanks a lot, but I didn't work..and I don't know why.

It worked when I recompiled the kernel with the alsa-oss emulation in the alsa window menu.

Thanks for all!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why I can't use USB audio device when onboard audio enabled in install RockyZ Fedora 6 03-28-2009 07:40 PM
Skype: "Problem with Sound Device" Gay R0b0t Suse/Novell 1 06-12-2005 07:36 PM
Problem with my audio device AJ_Cantos Slackware 10 05-03-2005 10:03 PM
XMMS problem : ** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): sureshrk19 Slackware 4 04-01-2004 09:17 PM
audio problem/device usage tig_grrrrr Linux - General 1 12-04-2003 08:21 AM


All times are GMT -5. The time now is 08:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration