LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-20-2002, 05:06 PM   #1
Salesmunn
LQ Newbie
 
Registered: Aug 2002
Posts: 2

Rep: Reputation: 0
Unhappy Sim City 3000 Unlimited trouble


I installed Sim City 3000 Unlimited for Linux in my Redhat 7.3. I then installed the latest patch from Loki's website. When I start up the software, the beginning movie will run fine with sound. If I attempt to skip the movie or let it run to the end, the screen will lock. I can tell that the game is running in the background via the sound and the reaction of the mouse cursor as I move it around the screen but I can't see anything. The screen will freeze on whatever frame of the movie it's on. I can't exit the game either, i have no choice but to restart the machine.

I've installed Unreal Tournament WITH a bunch of mods in that PC. That took a little work but it runs great. Anyone have any ideas? I'm still kind of a n00b at Linux and I'm really hoping to get this sucker running. Thanks in advance.

"Salesmen do it for profit"

-------------------
System Specs
-------------------
HP Pavilion 6465 US
Pentium 2 433 Celeron
256mb RAM
9.6GB HD
ATI Radeon 7000 64mb AGP Video
RedHat 7.3 (only)
 
Old 08-20-2002, 05:32 PM   #2
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Rep: Reputation: 30
im having problems running heretic 2 for linux and no one seems to be able to fix my problem. i've just decided not to buy any loki games anymore. sorry i cant be of assistance.
 
Old 08-20-2002, 05:38 PM   #3
Salesmunn
LQ Newbie
 
Registered: Aug 2002
Posts: 2

Original Poster
Rep: Reputation: 0
Unhappy uh ok

thanks anyway. Anyone else?
 
Old 09-22-2002, 03:02 PM   #4
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Rep: Reputation: 30
Loki games are good. I have Heavy gear2 heroes of mightand magic 3 quake 3 arena and soem more on way so far they all run good. The only problem i have is with sim city 3000 i get this error

BUG! (Segmentation Fault) Going down hard...
Sim City 3000 Unlimited 2.0.955
Built with glibc-2.1
Stack dump:
{
/lib/i686/libpthread.so.0 [0x4002be55]
}
Please send a full bug report,
along with the contents of autosave to: support@lokigames.com

when i find a fix I will post it. the heretic game I had problems with but there is actualy a fixfor it here on LQ just search for heretic 2.

Gonus
 
Old 11-18-2002, 09:57 PM   #5
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Rep: Reputation: 30
If you have not found this yet go to www.lokigames.com then go to updates and choose the game and there are the patches.

Gonus
 
Old 07-31-2004, 11:31 AM   #6
ctux
Member
 
Registered: Jul 2004
Location: Catalunya (Pa´sos Catalans)
Distribution: Fedora Core 3
Posts: 50

Rep: Reputation: 15
i have the same problem with mandrake 10. I have dowloaded the patch. The initial video runs ok, but then the screen comes black. Any suggestion?
 
Old 07-31-2004, 12:09 PM   #7
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
Quote:
Originally posted by gonus
Loki games are good. I have Heavy gear2 heroes of mightand magic 3 quake 3 arena and soem more on way so far they all run good. The only problem i have is with sim city 3000 i get this error

BUG! (Segmentation Fault) Going down hard...
Sim City 3000 Unlimited 2.0.955
Built with glibc-2.1
Stack dump:
{
/lib/i686/libpthread.so.0 [0x4002be55]
}
Please send a full bug report,
along with the contents of autosave to: support@lokigames.com

when i find a fix I will post it. the heretic game I had problems with but there is actualy a fixfor it here on LQ just search for heretic 2.

Gonus
That looks like a threading issue. Do you have thread support compiled into your kernel?
 
Old 08-07-2004, 03:44 PM   #8
ctux
Member
 
Registered: Jul 2004
Location: Catalunya (Pa´sos Catalans)
Distribution: Fedora Core 3
Posts: 50

Rep: Reputation: 15
Angry LokiGames doesn't do anything

I sent an e-mail to Loki Games a lot of days ago about this problem. And i'm still waiting for the answer

At least they could say "Sorry, we know about this problem and trying to patch" or "My apologies, all the programmers are on holidays now". But, no ! No answer.

 
Old 08-07-2004, 04:04 PM   #9
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Re: LokiGames doesn't do anything

Quote:
Originally posted by ctux
I sent an e-mail to Loki Games a lot of days ago about this problem. And i'm still waiting for the answer

At least they could say "Sorry, we know about this problem and trying to patch" or "My apologies, all the programmers are on holidays now". But, no ! No answer.

LOL, if you read the website, you would have seen that LOKI filed for bankruptcy.........
Don't wait for an email reply............
 
Old 08-07-2004, 04:23 PM   #10
ctux
Member
 
Registered: Jul 2004
Location: Catalunya (Pa´sos Catalans)
Distribution: Fedora Core 3
Posts: 50

Rep: Reputation: 15
Ow!


In the 3 times i have visited this page I have never read the loki's news

Who can i ask then?
EA ? Maxis ? God ?

i want to play sim city
 
Old 09-14-2004, 05:13 PM   #11
a.mcneill
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 6

Rep: Reputation: 0
Sim City 3000 Solution

I am using SuSE linux 9.1. Of course I had the problems everyone else had with Sim City 3000 (loki). "Segmentation Fault".

Well this only came AFTER installing the patch. But after doing some playing around this is what I came up with...

Install the patch.

Ok,

First, in a terminal window, type "export LD_ASSUME_KERNEL=2.2.5" (without the quotes).
Second, type "./sc3u -w" (the -w is needed on my pc, full screen is eradic). (Again, without the quotes).

And Tah-Dah...

Now the only problem I am having is with sound, for some reason I get an error stating:

"open /dev/dsp: Device or resource busy"

This does not prevent the game from working, i just have no sound. I will see if i can fix this as well. (Unless someone can help me with this).

Not bad for a 4 week old linux newbie... Heh Heh!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sim City 3000 Gerardoj Linux - Software 10 07-30-2006 10:20 AM
Sim City 3000 setup won't start because of glibc dopehouse Linux - Games 14 01-27-2006 05:37 PM
Problems with Sim City 3000 unlimited odiseo77 Linux - Games 13 12-12-2005 07:02 AM
sim city 3000 berrance Linux - Games 3 01-23-2005 03:19 AM
Sim City 3000 and Cross Over office jelitegamer Linux - Games 1 03-22-2004 03:23 PM


All times are GMT -5. The time now is 11:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration