LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-09-2003, 11:59 AM   #76
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48

what does the ldd command show now?
 
Old 01-09-2003, 12:06 PM   #77
Faeroon
Member
 
Registered: Jan 2003
Location: Germany
Distribution: right now: Vector Linux4
Posts: 96

Original Poster
Rep: Reputation: 15
Code:
ldd /usr/aw/maya4.5/bin/maya.bin
        libMaya.so => /usr/aw/maya4.5/lib/libMaya.so (0x40033000)
        libKinSlice.so => /usr/aw/maya4.5/lib/libKinSlice.so (0x40064000)
        libAnimSlice.so => /usr/aw/maya4.5/lib/libAnimSlice.so (0x4016e000)
        libTranslators.so => /usr/aw/maya4.5/lib/libTranslators.so (0x40353000)
        libProjectSlice.so => /usr/aw/maya4.5/lib/libProjectSlice.so (0x403f9000
)
        libSharedUI.so => /usr/aw/maya4.5/lib/libSharedUI.so (0x4041a000)
        libShared.so => /usr/aw/maya4.5/lib/libShared.so (0x40804000)
        libPoly.so => /usr/aw/maya4.5/lib/libPoly.so (0x40cda000)
        libPolyEngine.so => /usr/aw/maya4.5/lib/libPolyEngine.so (0x40dab000)
        libRenderModel.so => /usr/aw/maya4.5/lib/libRenderModel.so (0x40fec000)
        libNurbs.so => /usr/aw/maya4.5/lib/libNurbs.so (0x41627000)
        libDataModel.so => /usr/aw/maya4.5/lib/libDataModel.so (0x4176b000)
        lib3dGraphics.so => /usr/aw/maya4.5/lib/lib3dGraphics.so (0x41cb0000)
        libImage.so => /usr/aw/maya4.5/lib/libImage.so (0x41d42000)
        libAnimEngine.so => /usr/aw/maya4.5/lib/libAnimEngine.so (0x41d8c000)
        libNurbsEngine.so => /usr/aw/maya4.5/lib/libNurbsEngine.so (0x41e09000)
        libGeometryEngine.so => /usr/aw/maya4.5/lib/libGeometryEngine.so (0x4200
2000)
        libExtensionLayer.so => /usr/aw/maya4.5/lib/libExtensionLayer.so (0x4235
6000)
        libDependEngine.so => /usr/aw/maya4.5/lib/libDependEngine.so (0x42744000
)
        libCommandEngine.so => /usr/aw/maya4.5/lib/libCommandEngine.so (0x4293c0
00)
        libFoundation.so => /usr/aw/maya4.5/lib/libFoundation.so (0x42a16000)
        libLinux.so => /usr/aw/maya4.5/lib/libLinux.so (0x43094000)
        libStringCatalog.so => /usr/aw/maya4.5/lib/libStringCatalog.so (0x430a60
00)
        libversion.so => /usr/aw/maya4.5/lib/libversion.so (0x430a8000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x430aa000)
        libGLU.so.1 => /usr/lib/libGLU.so.1 (0x430f3000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4316e000)
        libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x4324300                          0)
        libm.so.6 => /lib/i686/libm.so.6 (0x43286000)
        libc.so.6 => /lib/i686/libc.so.6 (0x432a8000)
        libXm.so.2 => /usr/aw/maya4.5/lib/libXm.so.2 (0x433dd000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x43584000)
        libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x435d0000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x435d7000)
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0x435ec000)
        libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x43600000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x43610000)
        libImf.so => /usr/aw/maya4.5/lib/libImf.so (0x43618000)
        libdl.so.2 => /lib/libdl.so.2 (0x436b7000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x436ba000)
        libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x436c7000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x43a62000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x43a6a000)
Here's the new ldd log - seems that the export_path command is
only temporarily working? it changed back to /usr/lib/...

PS: Just in case you didn't read my last changed posting on page 5:

My good friend told me that some things are DEFINITELY needed to run maya:
1.)libXm.so.2
Code:
locate libXm.so.2
/usr/X11R6/lib/libXm.so.2.1
/usr/X11R6/lib/libXm.so.2
/usr/aw/COM/lib/libXm.so.2
/usr/aw/COM/lib/libXm.so.2.1
/usr/aw/maya4.5/lib/libXm.so.2
/usr/aw/maya4.5/lib/libXm.so.2.1
/usr/aw/open_motif/X11R6/lib/libXm.so.2.1
and 2.) libGL.so.1
Code:
locate libGL.so.1
/usr/lib/libGL.so.1
/usr/lib/libGL.so.1.0.3123
/usr/X11R6/lib/xxx.libGL.so.1.2.RPMSAVE
/usr/src/redhat/BUILD/NVIDIA_GLX-1.0-3123/usr/lib/libGL.so.1.0.3123
Maybe we've to change something there? Just a thought...
Because while running ldconfig I still get:
Code:
/sbin/ldconfig
/sbin/ldconfig: /usr/aw/maya4.5/lib/libXm.so.2 is not a symbolic link
There seem to be more links to wrong directories like /usr/lib

Last edited by Faeroon; 01-09-2003 at 12:07 PM.
 
Old 01-09-2003, 12:11 PM   #78
Faeroon
Member
 
Registered: Jan 2003
Location: Germany
Distribution: right now: Vector Linux4
Posts: 96

Original Poster
Rep: Reputation: 15
After the export it says:

Code:
libstdc++-libc6.2-2.so.3 => /usr/aw/maya4.5/lib/libstdc++-libc6.2-2.so.3                               (0x43243000)
I've exported as root AND faeroon - both times it changed back to
Code:
libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x43243000)
after I've closed the terminal the change is terminated
 
Old 01-09-2003, 12:32 PM   #79
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
Ok, the export LD_LIBRARY_PATH command sets an
environment variable, so it needs to be run after you become
root. If you didn't do this previously, do so now, and post the
ldd command again.
Also, do:
Code:
mv libXm.so.2 ..
ln -s libXm.so.2.1 libXm.so.2
ldconfig
 
Old 01-09-2003, 12:33 PM   #80
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
sorry, we got our wires crossed. . .
 
Old 01-09-2003, 12:41 PM   #81
Faeroon
Member
 
Registered: Jan 2003
Location: Germany
Distribution: right now: Vector Linux4
Posts: 96

Original Poster
Rep: Reputation: 15
Hm... somehow I didn't understand what you wanted to tell me with this:
Code:
mv libXm.so.2 ..
ln -s libXm.so.2.1 libXm.so.2
ldconfig
>>sorry, we got our wires crossed. . .
Did you mean the root /export thing with this? As I was saying - it's seems
to be temporarily working. :-/
 
Old 01-09-2003, 01:02 PM   #82
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
Quote:
Originally posted by Faeroon
Hm... somehow I didn't understand what you wanted to tell me with this:
Code:
mv libXm.so.2 ..
ln -s libXm.so.2.1 libXm.so.2
ldconfig
I think it may not matter.

Quote:
>>sorry, we got our wires crossed. . .
Did you mean the root /export thing with this? As I was saying - it's seems
to be temporarily working. :-/
Yeah, it works, but if you log out or switch users, it goes away,
that's because it's an environment variable and when your
environment changes, it can disappear. . .

Anyway, I have now almost convinced myself it's not the
libraries.

Can you try re-installing Maya? Save the maya_libs.tgz that
I sent you, and use rpm to remove and then reinstall Maya.
(ugh, I hate reinstalling)
 
Old 01-09-2003, 01:40 PM   #83
Faeroon
Member
 
Registered: Jan 2003
Location: Germany
Distribution: right now: Vector Linux4
Posts: 96

Original Poster
Rep: Reputation: 15
Ok... deinstalled all of the installed maya parts using KPackage...
installed it again - no errors - put the maya_libs.tgz into /usr/aw/maya4.5,
extracted it and run maya
Code:
/usr/aw/maya4.5/bin/maya.bin encountered a fatal error

Signal: 6 (Unknown Signal)
Attempting to save in
        /usr/tmp/faeroon.030109.1925.ma
I've NO idea... moses - could you contact me via ICQ, got a specific question to you
 
Old 01-13-2003, 11:37 AM   #84
n99joker
LQ Newbie
 
Registered: Jan 2003
Posts: 2

Rep: Reputation: 0
I would like to know more about this problem. I've installed Maya 4.5 succesfully - including the motif rpm from the cd, but I've the exact same problem when starting Maya in rh8? Did you guys found a solution or what? I don't think motif is the problem.
 
Old 01-13-2003, 11:50 AM   #85
Faeroon
Member
 
Registered: Jan 2003
Location: Germany
Distribution: right now: Vector Linux4
Posts: 96

Original Poster
Rep: Reputation: 15
@n99joker:
Mo' , MasterC and I searched for DAYS and DAYS but yet
we found nothing that could be the absolute core of the problem.
Moses told me that it MIGHT BE something with RH (some missing libs or something like that) - AW told anyone "use it! It's our reference" but HELL - this is some shit talk as I've never heard before! I know several people who have major problems get Maya running under RH and
that's why I follow the hint of Mo' and MC and install other distros, to test wether maya runs on them or not.
At this moment I've got a thread in the slackware section of this board
and I'm trying to install slackware 8.1 (sounds like a decent and great distro, but I think MC could tell you more about that *big fat grin*) - I hope that maya works there,
because I've sent my maya version to Moses and it worked JUST fine on his slackware8.1

Let us hope that maya is really on sw8.1...

PS: DAMN THIS RH SHIT.... *grrr* sorry.... lost my nerves about this
 
Old 01-13-2003, 10:08 PM   #86
CRego3D
Member
 
Registered: Jan 2003
Posts: 67

Rep: Reputation: 15
Same problem here, RH 8 wont' work with Maya .. exact same error .. please keep us updated on any progress you make
 
Old 01-14-2003, 01:08 AM   #87
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
The solution:
http://www.linuxquestions.org/questi...threadid=41367
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
squid stops due to signal 6 and signal 25 simplyrahul Linux - Software 3 05-28-2011 02:05 AM
Getting AP signal strength via C program ... toships Linux - Wireless Networking 5 01-07-2009 03:35 AM
program cpp0 got fatal signal 11 cellist Debian 2 10-22-2004 06:25 PM
Signal 6: Unknown Signal <=> Error with MAYA4.X under Linux SOLVED!!!! Faeroon Linux - Software 9 05-09-2003 02:57 PM
Signal handling in Multithreaded program souvik Programming 4 08-23-2002 08:28 AM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration