LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-13-2005, 01:08 PM   #1
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Distribution: Frustrated Ubuntu 6.10 Edgy User
Posts: 257

Rep: Reputation: 30
Shortening Network timeout on Boot...


Hi guys,

This is probably a simple question but for the life of me I can't figure it out.

How do I shorten the default timeout for my ethernet card on boot? I have Ubuntu Hoary installed on my Toshiba A30 laptop, but when I turn it on without a connection plugged in, it takes about 60 seconds before it fails and continues on it's way.

It works fine when there is a cable and connection present, but I often use my laptop with a connection and it's frustrating waiting for something I know it won't find.

Also, Fedora Core 3 had a GUI for enabling and disabling services easily (called "Services" in the GNOME menu) - Could someone please tell me how I can get it on Ubuntu or what it was called?


Many Thanks,
 
Old 09-14-2005, 02:44 AM   #2
Ike M.
Member
 
Registered: Aug 2005
Posts: 60

Rep: Reputation: 15
Your ethernet

timeout is not an OS specific issue- this is something that you would set in BIOS. Go ahead and google how to change BIOS settings for your particular machine

[for instance, my Dell requires a Ctrl-Alt-Enter during the very first stage of boot to enter this... my Syntax motherboard requires me to hold down Delete in a similar way]

and somewhere in there there should be a way to change this (although you may have to turn off 'boot over LAN/ethernet adapter completely)

BTW don't change anything else in there unless you really know what you are doing. As a side note, I might say something about the fact that ONE of my machines still tries to do this even if I set BIOS not to...


On my Dell there is a place where I can set up which devices I wish to be able to boot from, and no matter how many times I take the etherboot off of the list, it still ends up back in there somehow. How, I do not know. It is not a problem with the battery- this thing keeps the time in a way that is competitive with any of the best watches I have ever owned.

If after going into your BIOS and changing this (or similar) etherboot setting, you still have some sort of undesireable problem, I am sorry that this did not take care of that. You are not alone in this
 
Old 09-14-2005, 06:48 AM   #3
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Distribution: Frustrated Ubuntu 6.10 Edgy User
Posts: 257

Original Poster
Rep: Reputation: 30
It has nothing to do with the BIOS at all - you misunderstood me.

It is not "Boot from LAN" like you would boot from a HDD or a CDROM, it IS an OS specific issue, because when I was using Fedora Core 3 I fixed it, but I can't for the life of me remember how.

When LINUX is booting and AFTER Grub has passed, it detects my hardware, goes through the standard boot procedure, mounting filesystems etc, but when it gets to "Configuring Network Interfaces" it pauses for 60 seconds when no cable is plugged in.

Additionally because of that, I also get a smaller pause when LINUX tries to contact an NTP time server, because there is no connection to my network.

Like I said before, it works fine when a network cable is plugged in, but it is nothing whatsoever to do with "Boot from LAN" or "Wake on LAN".

Many Thanks,
 
Old 09-14-2005, 03:00 PM   #4
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Distribution: Frustrated Ubuntu 6.10 Edgy User
Posts: 257

Original Poster
Rep: Reputation: 30
Anyone?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tilde name shortening steveel Slackware 6 11-21-2005 03:55 AM
Wireless Network Timeout Maybe? normf Linux - Wireless Networking 0 11-11-2005 07:51 AM
setting network start timeout at boot sayantam Linux - Networking 1 06-10-2004 04:20 AM
Disable network timeout for remote subnets MalcolmV8 Linux - Networking 1 02-09-2004 10:04 AM
network timeout absolute0net Linux - Networking 8 07-15-2003 08:06 AM


All times are GMT -5. The time now is 12:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration