LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-27-2005, 04:26 AM   #1
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Rep: Reputation: 15
shell prints bad code when returning message


Some exaples:
I typed in command line # "ls root",the shell return me with"ls:root:....."(...... stand for bad code);
I typed in #"man ll",the shell return me with "man:......(...... stand for bad code).etc.

Must I change my shell environment variable?Which one?
 
Old 06-27-2005, 09:16 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
I don't see the problem here, please explain in more detail.
 
Old 06-27-2005, 09:29 PM   #3
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
My shell message return me bad code(chaos code).
 
Old 06-27-2005, 09:31 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
I'm not sure what you mean by "bad code" or "chaos code".
 
Old 06-27-2005, 10:07 PM   #5
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
Did you keep monitoring posting in the forum?Thank you very much.I am a Chinese.I don't know how to express what I actually meant.I meant the returned message neither in English nor in Chinese.I am so sorry for occupying lot of your time.
 
Old 06-27-2005, 10:15 PM   #6
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
Could you please try to copy/paste the message you get here, as closely as possible?
 
Old 06-27-2005, 11:26 PM   #7
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
Now, please tell me how to set up for shell's environment variable "LANG= "to English.That will meet my problom.The message cannot to be able to be pasted or copied.Maybe the different code systems caused that.
 
Old 06-28-2005, 08:42 AM   #8
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
Code:
export LANG="en_US"
I believe.
 
Old 06-28-2005, 08:51 PM   #9
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
I have been expressing myself with wrong words"bad code",actually I meant "junk characters" by that.Not all of shell's output in junk characters,only its behind part.
 
Old 06-28-2005, 10:46 PM   #10
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
That's weird. Did setting LANG help any? You might also want to set LC_ALL.
 
Old 06-29-2005, 12:23 AM   #11
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
Thank you very much.I will promptly try on what you teached me when I was free.
 
Old 06-29-2005, 02:06 AM   #12
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
I have got progress when try code"export LANG="en_US".Now I have ????? instead junk characters.For example,shell saids "ls:root:???? when I issured command"ls root".

How to set LC_ALL?Please.
 
Old 06-29-2005, 02:28 AM   #13
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
Well, at least they are readable characters. Set LC_ALL in the same way as LANG.
 
Old 06-29-2005, 02:48 AM   #14
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
Mater,I am realy appriciate your help.I also set LANGUAGE="en_US".Now the shell give me all Eglish characters.

By the way,"LC_ALL="en_US" did not work.What argument is LC_ALL ?And where does it located?

see you late.
 
Old 06-29-2005, 02:53 AM   #15
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
LC_ALL sets the locale, where LANG just sets the language. I think it's a minor distinction somewhere.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My shell return message always print chaos code backpacker Linux - Newbie 1 06-24-2005 07:05 AM
Problem with wvdial returning exit code 15 bossmonkey666 Linux - Networking 0 08-09-2004 04:17 AM
bad interpreter error message ffenics2002 Linux - Software 2 04-15-2004 12:17 PM
Bad message with compiled kernel melinda_sayang Linux - General 2 02-18-2004 10:06 PM
Bad message from freshmeat :( LinFreak! General 7 09-24-2003 03:47 AM


All times are GMT -5. The time now is 04:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration