LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-07-2003, 10:30 PM   #1
pow2k2
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 11

Rep: Reputation: 0
Setting up X in Slackware 8.1


I can't seem to get X to work properly. It says that there are 'no screens found'. I ran XF86config, manually put in the paramaters for my ViewSonic G90fb monitor, and it doesn't seem to want to set my geforce3 properly. I tried to manually edit the config, and set the driver to 'nv' and it still won't work. Anyone know how to fix this?

Thanks.
 
Old 02-08-2003, 11:19 AM   #2
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
Well the way I did it when I first set up Slackware was w/o X I set up my internet connection, through lynx I went to NVIDIA site and downloaded the tarballs for NVIDIA drivers, then I ran xf86cfg this is the tool to set up XFree86 4.x, I saw an ugly highest resolution screen my card and monitor can handle (1600x1200), ctrl-backspace'd out of X, and compiled the NVIDIA drivers, edited the /etc/X11/XF86Config according to NVIDIA instructions, and then startx'd to get to X.
 
Old 02-08-2003, 04:57 PM   #3
pow2k2
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 11

Original Poster
Rep: Reputation: 0
ok. I'll do that. thanks.
 
Old 02-08-2003, 07:00 PM   #4
restless
Member
 
Registered: Feb 2003
Location: Belgium
Distribution: Debian
Posts: 166

Rep: Reputation: 31
i've had some problems with it too recently...
what i've done was this... when you start xf86config and he asks for the horizontal resolution go and look in your book of your monitor what EXACT hor. freq it has at f.e. 1024 and what EXACT vert freq it has 768, for me it was something like 67.4 and 85...

then when he asks if the resolution modes a good just edit it... and set it only to 1024*768, i think it's the 3rd choice...

when he asks for a 3d card if your card isn't in the list choose 0, set your ram and give it a name... don't try the geforce, just use a standard vesa (i think, i know it's 0) and if you've done all this try to start x, this should work now...
 
Old 02-08-2003, 10:22 PM   #5
pow2k2
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 11

Original Poster
Rep: Reputation: 0
Update:

I setup my internet connection, and I downloaded the latest nvidia drivers. Now when I try 'startx' , the screen shows the nvidia logo, and then it gives me this:



Code:
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Feb 8 22:13:21 2003
(==) Using config file: "/etc/X11/XF86Config"
(II) [GLX]: Initializing GLX extension
(EE) xf85OpenSerial: Cannot open device /dev/mouse
      No such device.
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
No core pointer

Fatal server error:
failed to initialize core devices

XIO:   fatal IO error 104 (Connection reset by peer) on X server ":0.0"
       after 0 requests (0 known processed) with 0 events remaining.

I have a M$ wheelmouse optical plugged into the PS/2 port. Any idea how to fix this?
 
Old 02-09-2003, 06:40 AM   #6
restless
Member
 
Registered: Feb 2003
Location: Belgium
Distribution: Debian
Posts: 166

Rep: Reputation: 31
what did you enter with the xf86config??? did you enter a special microsoft mouse pointer, or did you just enter PS/2 ?
this is another xfree problem...
 
Old 02-09-2003, 10:32 AM   #7
simbolo
Member
 
Registered: Mar 2002
Location: US, CT
Distribution: Gentoo
Posts: 56

Rep: Reputation: 15
# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "imps/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZaxisMapping" "4 5"

try this in your mouse section of you XF86Config, edit #of buttons and what not, if its usb try:
Option "Device" "/dev/input/mice"
ps2 mouse use: Option "Device" "/dev/psaux"
as /dev/mouse is just a link to one of those two
 
Old 02-09-2003, 03:32 PM   #8
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Rep: Reputation: 30
if you have a usb mouse edit your /etc/X11/XF86Config file
and change the protocol to "IMPS/2"

also edit the /etc/rc.d/rc.modules file and uncomment the required usb stuff, ie: usb support for ohci and so forth
also ensure you have support for usb mice enabled
this tells your kernel to enable support for usb.

im guessing when you setup slack you just used the default kernel?
 
Old 02-10-2003, 05:39 PM   #9
pow2k2
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 11

Original Poster
Rep: Reputation: 0
I got it working... I ended updating the kernel to 2.4.20, and configured it for USB HID. Everything works great now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting the time on Slackware 10.1 hitest Slackware - Installation 3 07-03-2005 05:14 PM
setting up new slackware system hirts123 Slackware 17 05-29-2005 02:11 PM
Help Setting Up NIC With Slackware 10.0 Christopher Slackware 7 07-20-2004 04:25 PM
Setting up djbdns on Slackware 9.1 (2.6.7) thekore Slackware 1 07-07-2004 02:23 PM
setting up slackware 9.1 venom_zx Slackware 12 10-04-2003 02:58 PM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration