LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-13-2002, 08:47 AM   #1
Remco
LQ Newbie
 
Registered: Oct 2002
Posts: 3

Rep: Reputation: 0
Setting the path


Hello,

I run Peanut Linux 9.3 and I recently installed java (sdk1.4.0) and teTeX. To access the commands quickly, I added the bin directories of both to my PATH in my .bashrc file in my home directory. The PATH line in this file looks now something like this:

PATH="/usr/bin:/bin:/usr/sbin:/sbin:/opt/kde3/bin:/usr/X11/bin:$OPENWINHOME/bin:/usr/local/bin:/usr/java/j2sdk1.4.0_02/bin:/usr/local/teTeX/bin:/usr/local/sbin:."

The path to the bin directories are correct, I checked that. But now, when I start my computer and log in and I open a terminal and type which java, then it says it can't find it (it then sums the path, everything except the two path's to teTeX and java). Then when I type su and my password in the terminal and switch to root and then switch back again, and again type which java, it does find the path. It's just as if it doesn't read the file at first. Does anybody know if I have to change other files as well?

Thanks for any help!

Remco
 
Old 10-13-2002, 09:39 AM   #2
Remco
LQ Newbie
 
Registered: Oct 2002
Posts: 3

Original Poster
Rep: Reputation: 0
Sorry guys, I found it out myself (don't know exactly why though):

When I open a e-terminal then I get the messages described in my message above, but when I take a normal X-console or X-terminal or konsole, then it's fine. I'll try it in enlightenment now, maybe that's the reason why.

Remco
 
Old 10-13-2002, 04:33 PM   #3
Remco
LQ Newbie
 
Registered: Oct 2002
Posts: 3

Original Poster
Rep: Reputation: 0
OK,

Apparently my e-terminal only reads from the /etc/profile. OK, I don't know why, but it works now.

Remco

P.S. This turned out to be a one man show
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting the path.... joel112 Slackware 5 08-28-2003 02:27 PM
Setting the path Milkman00 Linux - General 2 07-26-2002 09:44 AM
setting PATH tda Linux - Newbie 1 04-29-2002 01:54 PM
Setting up PATH Sonny Linux - Newbie 4 01-28-2002 02:02 PM
PATH SETTING webboss Linux - Newbie 2 03-17-2001 06:29 PM


All times are GMT -5. The time now is 08:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration