LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-02-2003, 11:24 PM   #1
Witch-King
LQ Newbie
 
Registered: Dec 2002
Location: California, US
Distribution: RedHat-8.0
Posts: 14

Rep: Reputation: 0
Setting Mozilla as Default Browser


I've searched all over these forums and on the mozilla web page and I can't seem to find an easy answer. What I want is for Mozilla to open when I execute the command htmlview %u. That works if I use the RPM-build of Mozilla packaged with RedHat 8.0 (i.e. Mozilla-1.0.1); however, I uninstalled that version (i.e. rpm -e ) and installed Mozilla-1.2.1. Now, when I execute the command htmlview %u, the browser that appears is lynx.

Since Ximian Evolution also uses this command when you click on URLs within eMail messages, I'd like to figure out how to point that command to the correct location.

Thanks.
 
Old 01-03-2003, 07:03 AM   #2
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
If you're using kde: klipper > preferences > actions
 
Old 01-03-2003, 11:51 AM   #3
Witch-King
LQ Newbie
 
Registered: Dec 2002
Location: California, US
Distribution: RedHat-8.0
Posts: 14

Original Poster
Rep: Reputation: 0
I'm running GNOME 2.0.2 on RedHat 8.0

I have found in preferences where you can set the default browser, but that doesn't appear to do a thing.
 
Old 02-04-2003, 09:33 AM   #4
jazzyjay
LQ Newbie
 
Registered: Feb 2003
Posts: 1

Rep: Reputation: 0
Talking

Here is info from the Mozilla FAQ: (http://www.mozilla.org/start/1.0/faq/browser.html#2.2):


GNOME (Unix/Linux): Open the Control Panel. Go to Document Handlers | URL Handlers | Default: gnome-moz-remote --newwin "%s" .Then put the following text in ~/.gnome/gnome-moz-remote (create the file if it does not exist):

[Mozilla]
filename=absolute path of Mozilla install directory/mozilla


It worked for me.
 
Old 02-26-2003, 12:13 AM   #5
Slycordinator
Member
 
Registered: Dec 2002
Location: Washington State
Posts: 30

Rep: Reputation: 15
Quote:
Originally posted by jazzyjay
Here is info from the Mozilla FAQ: (http://www.mozilla.org/start/1.0/faq/browser.html#2.2):


GNOME (Unix/Linux): Open the Control Panel. Go to Document Handlers | URL Handlers | Default: gnome-moz-remote --newwin "%s" .Then put the following text in ~/.gnome/gnome-moz-remote (create the file if it does not exist):

[Mozilla]
filename=absolute path of Mozilla install directory/mozilla


It worked for me.
I don't see a gnome control panel. I do have a section marked "Control Center" but it doesn't have "Document Handlers" as a choice beyond that.

I'm running Redhat 8.0
 
Old 03-01-2003, 08:45 PM   #6
Anand Joshi
LQ Newbie
 
Registered: Mar 2003
Posts: 1

Rep: Reputation: 0
Re: Setting Mozilla as Default Browser

An easy solution is create /etc/htmlview.conf and put X11BROWSER=mozilla command line in that file.
Alternatively create ~/.htmlviewrc and put X11BROWSER=mozilla commandline in that file if you don't have root access.
Don't know if this is the only solution. Works for me.
Hope it helps.
Anand

Quote:
Originally posted by Witch-King
I've searched all over these forums and on the mozilla web page and I can't seem to find an easy answer. What I want is for Mozilla to open when I execute the command htmlview %u. That works i lynx.

[snip]


Since Ximian Evolution also uses this command when you click on URLs within eMail messages, I'd like to figure out how to point that command to the correct location.

Thanks.
mozilla command line

Last edited by Anand Joshi; 03-01-2003 at 09:12 PM.
 
Old 03-14-2003, 04:26 PM   #7
astroturtle
LQ Newbie
 
Registered: Mar 2003
Posts: 10

Rep: Reputation: 0
Got it sorted...

Evolution looks at the Gnome default browser even if, like me, you are using KDE.

If you edit the file:

/home/[your home dir]/.gnome/Gnome

and change the line that says "default-show=" to include the full path to the new location everything should work correctly. Don't forget to add the "%s" so Mozilla receives the URL.

My file looks like this:

[URL Handlers]
default-show=/usr/local/mozilla/mozilla "%s"
info-show=nautilus "%s"
man-show=nautilus "%s"
ghelp-show=nautilus "%s"

Yaay!
Turtle
 
Old 03-16-2003, 09:42 AM   #8
colonblow
LQ Newbie
 
Registered: Mar 2003
Posts: 2

Rep: Reputation: 0
What gnome config file in RH 8 contains the URL Handlers command? I cannot find it. I see gnome config files in my home directory but can't find the one to set the default browser.

I am having the same problem as witch. And by great surprise the origianl mozilla installed with RH 8 is gone. I installed mozilla 1.3 in usr/local/mozilla and just didnt use the old install. But forgot that clicking on links in other apps referred to a default browser. Now the original disappeared, strange. Mozilla may be set to update itself, but when the next distro comes with a new version of mozilla I am afraid that wont install properly cause it cant find the old one.
 
Old 03-16-2003, 03:10 PM   #9
astroturtle
LQ Newbie
 
Registered: Mar 2003
Posts: 10

Rep: Reputation: 0
See the "got it sorted..." e-mail above. That is the url handlers config file for gnome...

Later,
Turtle
 
Old 03-16-2003, 08:47 PM   #10
colonblow
LQ Newbie
 
Registered: Mar 2003
Posts: 2

Rep: Reputation: 0
Well your post is what made me look for it in the first place None of the files contain that text, in .gnome or .gnome2. Maybe its different because youre using kde and I am using gnome. I think mozilla 1.3 may have done something too and installs differently then 1.2.
 
Old 03-20-2003, 10:19 PM   #11
astroturtle
LQ Newbie
 
Registered: Mar 2003
Posts: 10

Rep: Reputation: 0
> None of the files contain that text, in .gnome or .gnome2.

Hmmm... That's odd. I don't think it's because I'm using KDE though... Have you tried adding the lines and seeing what happens?

Later,
Turtle
 
Old 03-23-2003, 06:17 PM   #12
zeke_cl
LQ Newbie
 
Registered: Mar 2003
Posts: 5

Rep: Reputation: 0
multi windows with htmlview

Ok I upgraded everything correctly and got htmlview %u to open mozilla but noe everytime I have a mozilla browser open and I use htmlview %u to open another it opens the profile manager and says to pick a profile but when I pick mine (the only profile) it says that it is in use and I have to create a new one.

Is there a way to make it so that it always uses mine? and does not ask for a profile?

Thanks for any help in advanced.

Zeke_cl
 
Old 03-23-2003, 06:35 PM   #13
astroturtle
LQ Newbie
 
Registered: Mar 2003
Posts: 10

Rep: Reputation: 0
> noe everytime I have a mozilla browser open and I use
> htmlview %u to open another it opens the profile manager
> and says to pick a profile but when I pick mine (the only profile)

I had this problem too. When you run mozilla it creates a 'lock' file so no more than 1 user can access that profile. Thankfully it's relatively easy to shut that off!

http://mozdev.org/pipermail/project_...ry/002290.html

I've been using this method for a while now and have never had a problem. Or an annoying 'profile' window.

Turtle
 
Old 03-23-2003, 06:58 PM   #14
zeke_cl
LQ Newbie
 
Registered: Mar 2003
Posts: 5

Rep: Reputation: 0
ok I put that little script into run-mozilla.sh but now when I have a browser open and I try htmlview %u it does nothing??? no new browser pops up???
 
Old 03-23-2003, 07:01 PM   #15
zeke_cl
LQ Newbie
 
Registered: Mar 2003
Posts: 5

Rep: Reputation: 0
sorry should of put this with last posting ...

here is an error I get

session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kdeinit: Fatal IO error: client killed
kdeinit: sending SIGHUP to children.
Mutex destroy failure: Device or resource busy
kdeinit: sending SIGTERM to children.
kdeinit: Exit.


... I am running Gnome not KDE does that matter???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting a default browser imagineaxion Mandriva 12 01-07-2005 12:16 AM
setting default browser to mozilla cwynn Linux - Software 4 09-28-2004 07:38 PM
mozilla 1.5 default browser on fedora sebastiansosin Linux - Software 4 02-02-2004 08:59 PM
Mozilla Firebird As Default Browser Turbal Linux - Newbie 1 11-17-2003 01:58 PM
make Mozilla my default browser safrout Linux - General 1 09-09-2002 12:17 AM


All times are GMT -5. The time now is 10:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration