LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 06-28-2012, 10:54 AM   #1
Vinter
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Aptosid
Posts: 145

Rep: Reputation: 19
Setting Bluetooth Audio as Default Output


Hi!

As my internal sound card recently broke, I acquired a set of Creative T12 Wireless Bluetooth speakers to use for watching the occasional show and so on at my desk. I have already gotten that to work by putting
Code:
Enable=Socket
into /etc/bluetooth/audio.conf and putting
Code:
pcm.bt {
    type plug
    slave {
        pcm {
            type bluetooth
            device 00:02:3C:26:38:3A
            profile "auto"
        }   
    }   

    hint {
        show on
        description "BT Audio"
    }   
}

ctl.bt {
  type bluetooth
}
into ~/.asoundrc. (Tbh, I don't exactly know why the structure is what it is. I just copied that snippet from the Web.) Playing audio with ALSA's -D switch or any other way of specifying the interface works well.

However, I'd like to define the speakers as my standard audio output, as not all applications come with an option to change the sound device. (Also, I don't want to go through the hassle of changing that every time before I can use a program.) But all I can find on the Web is to just define

Code:
pcm.!default { 
  type bluetooth
  device 00:02:3C:26:38:3A
}
in ~/.asoundrc. Unfortunately, this only creates a "default" device I can play to using the -D switch or similar, and not a device that is actually used as a default. If I change the "bt" in the first snippet to "!default", it won't work either.

So, what am I doing wrong?

Thanks,
David
 
  


Reply

Tags
alsa, bluetooth


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No audio after setting a default soundcard RedNeck-LQ Linux - General 1 08-28-2011 06:28 PM
How do you make "/dev/dsp1" the default Audio Output Device? lothario Linux - Software 1 02-16-2011 04:01 AM
[SOLVED] Onboard Audio (hda_intel) for Mic Input and Soundcard (ca0106) for Audio Output? snowdonkey Linux - General 1 07-11-2009 04:17 PM
integrated hda audio modem bluetooth , (intel hda audio does not work) reggae linux Linux - Laptop and Netbook 1 07-05-2006 11:13 PM


All times are GMT -5. The time now is 03:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration