LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Set Path to Jre 1.5 (http://www.linuxquestions.org/questions/linux-software-2/set-path-to-jre-1-5-a-465686/)

Lambda_Core 07-19-2006 06:15 PM

Set Path to Jre 1.5
 
Hello,

I normally use Eclipse 3.2 for learning Java, and i've configured it to run Jre 1.5. Eclipse is really awesome great but its loading times are getting on my nerves, especially since it makes me create packages and such for simple beginner programs.

I wish to use either Emacs or Vim or KDevelop with console support but I don't know how to make Jre 1.5 the default, when I use javac <file>, console uses the eclipse-jre 1.4 compiler. I know how to compile and run with gcj but that too is a 1.4 compiler.

I whish to run a 1.5 based jre as my study material requires jre 1.5, i don't mind if it's GNU or not, just a solution that can be called up quickly.


Cheers,

Lambda_Core

P.S I'm a :newbie:

Lambda_Core 07-19-2006 11:37 PM

Nvm got it...
 
Bah, got it going, thanks anyways.

Mega Man X 07-20-2006 12:40 AM

Hi!

Just would like to point out that there are other IDE's available. One that is very famous in IT-schools and Universities is BlueJ. It works great and won't get on your way of doing things, plus it does not take so long to start up.

However, I've to say that it is better to learn Java concepts from the very start. Sooner or later you will have to move to another IDE as Eclipse. Real-time compiling and syntax check will come in hand when your programs get bigger. Well, IMHO indeed ^_^.


All times are GMT -5. The time now is 08:45 AM.