LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-16-2004, 08:33 PM   #1
www.rzr.free.fr
Member
 
Registered: Sep 2003
Location: france
Distribution: debian / knoppix
Posts: 31

Rep: Reputation: 0
serious trouble : slow program loading + ld libs not found etc


I suspect this problem makes my programs to load very slow
can you tell me what is wrong with my debian (knoppix hdd) system ?

I will give more details at
http://who.is.free.fr/wiki/index.php?Linux

#rzr@nrv:rzr/$ strace echo
execve("/bin/echo", ["echo"], [/* 42 vars */]) = 0
uname({sys="Linux", node="nrv", ...}) = 0
brk(0) = 0x804bc8c
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40017000
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.preload", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/i686/mmx/cmov/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/tls/i686/mmx/cmov", 0xbffff0c8) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/i686/mmx/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/tls/i686/mmx", 0xbffff0c8) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/i686/cmov/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
etc etc etc

#rzr@nrv:rzr/$ cat /etc/ld.so.conf
# /lib
# /usr/lib
/usr/X11R6/lib
/usr/i486-linuxlibc1/lib
/usr/lib/libc5-compat
/lib/libc5-compat

# ldconfig gives no errors

#rzr@nrv:rzr/$ uname -a
Linux nrv 2.4.22-amiloa #21 mer déc 10 17:51:40 CET 2003 i686 GNU/Linux

#rzr@nrv:rzr/$ cat /etc/debian_version
testing/unstable

#rzr@nrv:rzr/$ gcc --version
gcc (GCC) 3.3.2 (Debian)

#rzr@nrv:rzr/$ ld --version
GNU ld version 2.14.90.0.7 20031029 Debian GNU/Linux
 
Old 01-17-2004, 06:24 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Moved: More suitable in Software as this is not a Success Story. Please place your threads in the most appropiate forum and you should get answers in a more prompt fashion that way and save a moderator time as they could be helping others instead of moving threads all day long. Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Libs not found jonlake Linux - Software 9 02-06-2005 01:57 PM
chroot and shared libs not being found. netstv Linux - General 3 11-05-2004 11:36 AM
troubles with loading shared libs on x86-64 sleepylight Fedora 0 04-26-2004 08:54 AM
trouble with libs Vincent Slackware 7 02-15-2004 11:44 AM
qt-libs not found niklasw19 Programming 12 11-24-2003 03:17 PM


All times are GMT -5. The time now is 08:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration