LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-13-2004, 09:23 AM   #1
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Rep: Reputation: 66
Unhappy SERIOUS library problems... help!


A Newbies cry for help! ...just as everything seemed to be under control and great fun...

Something made me think I needed glib, so I installed glib-2.0.7. But now almost nothing works anymore.

I have redhat9, with gnome/fluxbox. Now when I startup, gkrellm doesn't appear in the slit anymore. Starting gkrellm from xterm gives:

error: /usr/lib/libgdk-x11-2.0.so: undefined symbol: g_get_application_name

Same error comes when I want to start ROX or Gedit (only then it's called 'relocation error)

Starting firebird gives:
'error while loading shared libraries: libgmodule-1.2.so.0: cannot open shared object file: no such file or directory

Thunderbird doesn't start either (without error message).

Emacs, xterm and Eterm still open without problem.

Log out also does not work, as it keeps stuck at this waiting-sand-thingie.

WHAT ON EARTH HAPPENED that everything changed so dramatically?
Please anyone, inform me with some wise words?

Leon.

PS: the obvious thing (to me...), i.e. get rid of glib-2.0.7, didn't work since there was a huge list of dependencies (I compiled glib from tar using .configure, make, checkinstall, so I would have the option to rpm -e it away...).

Last edited by BroX; 01-13-2004 at 09:27 AM.
 
Old 01-13-2004, 09:27 AM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
How exactly did you instal glib? What did you install and how did you install it exactly?
 
Old 01-13-2004, 09:29 AM   #3
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Original Poster
Rep: Reputation: 66
Does the EDIT above give you the answer? Or should I be more specific?
 
Old 01-13-2004, 09:58 AM   #4
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Original Poster
Rep: Reputation: 66
PHEW!

Simply adding /usr/lib (and running ldconfig, but is that nessecary?) makes a h*ll of a difference! Now most apps work well again. Sorry for the panic, but hey I'm new to all this so bear with me please ;-)

However, firebird still doesn't want to start. Anyone a good tip how to rescue that issue as well?

Thnx, Leon.
 
Old 01-14-2004, 03:14 AM   #5
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Original Poster
Rep: Reputation: 66
Smile the answer

After hunting down similar threads on gtk+ problems, I finally got it solved (and by reading documentation on www.gtk.org, learned a lot ;-)

I'll post the solution, hopefully it can be usefull for other newbies.

Thinking (please, correct me if I'm wrong, I merely guessing) that the apps that did not start up anymore must depend on an older version of gtk+, I wanted to reinstall gtk+-1.2 from the Redhat package CD. But for that I needed glib-1.2, which was exactly the problem why for example firebird didn't want to start. When glib-1.2 was installed (from Redhat CD) all was fine! (and as it turned out, gtk+-1.2 was already installed).

So I'm a happy fluxer again!

Cheers, Leon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with gd-library anttu Linux - Newbie 8 09-14-2004 03:28 AM
More library problems Outabux Debian 4 04-07-2004 08:33 PM
qt3 library problems kadaver Slackware 1 01-18-2004 05:04 PM
library problems Ismark Linux - Newbie 1 01-04-2002 05:50 PM
Library problems Ismark Linux - Software 3 01-04-2002 05:00 PM


All times are GMT -5. The time now is 05:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration