LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-18-2012, 11:08 AM   #1
kaplan71
Member
 
Registered: Nov 2003
Posts: 718

Rep: Reputation: 39
sendmail startup extremely slow


We have a CentOS 5.2 64-bit server that is running Sendmail 8.13 with MailScanner and SpamAssasin on it. Recently it was discovered the delivery of messages was taking a longer time than expected to complete. A restart of the the sendmail server has resulted in an extremely slow startup time. As of this posting, the sm-client has been 'starting up' for about fifteen minutes.

I have checked the messages an maillog files, and there are no apparent error messages within them. What would be causing this problem to occur, and how can I correct it?

Thanks.
 
Old 06-20-2012, 12:55 AM   #2
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 268

Rep: Reputation: 27
This happened to me when sendmail was configured for a domain other than the host machine's.
 
Old 06-20-2012, 01:22 AM   #3
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux, LFS, Slitaz
Posts: 3,056
Blog Entries: 1

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
I would check /etc/hosts and /etc/resolv.conf for correctness...

Also, making sure ip6 is disabled(if it is unneccesary) may help dns lookup time, if that is what is happening.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Java VM extremely slow startup when using iptables MASQUERADE? travishein Linux - Networking 1 01-27-2010 08:43 AM
Extremely slow XFCE startup in Slackware 12.2 DrCurl Slackware 5 02-10-2009 02:53 AM
FC4 bootup extremely slow? stuck in 'starting sendmail' renshao Fedora 3 03-12-2006 03:59 PM
Java 1.5.0_04 extremely slow startup papa Strumpf Programming 3 10-10-2005 10:05 AM
K3B Extremely Slow Startup K3yMaster Linux - Software 0 10-10-2003 03:00 AM


All times are GMT -5. The time now is 11:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration