LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Sendmail sending as host.domain.com, i want it to be from just domain.com. (http://www.linuxquestions.org/questions/linux-software-2/sendmail-sending-as-host-domain-com-i-want-it-to-be-from-just-domain-com-177447/)

PlatinumRik 05-03-2004 02:51 PM

Sendmail sending as host.domain.com, i want it to be from just domain.com.
 
currently mail is being sent like this "user@host.domain.com" i want it to go out from just the domain like this "user@domain.com" how do i make sendmail do this?

Rick

trickykid 05-03-2004 03:02 PM

What is it setup as in your config file?

PlatinumRik 05-03-2004 05:56 PM

divert(-1)
include(`/usr/share/sendmail-cf/m4/cf.m4')
OSTYPE(`linux')
DOMAIN(`mydomain.com')dnl
TURE(always_add_domain)dnl
FEATURE(`masquerade_entire_domain')
FEATURE(`masquerade_envelope')
FEATURE(`allmasquerade')
MASQUERADE_AS(`mydomain.com')
MASQUERADE_DOMAIN(`mydomain.com')
MASQUERADE_AS(mydomain.com)
FEATURE(`mailertable')
FEATURE(relay_entire_domain)dnl
FEATURE(access_db)dnl
FEATURE(`blacklist_recipients')dnl
FEATURE(nouucp,reject)dnl
FEATURE(`redirect')dnl
MAILER(local)dnl
MAILER(smtp)dnl
wlocalhost.localdomain

pauljtester 10-07-2004 11:52 AM

PlatinumRik -

Did you ever figure this out? I'm having the same prob as you and my conf file looks just abou the same.

Cheers,
PJT

Pete M 10-07-2004 01:23 PM

pauljtester

Edit /etc/mail/local-host-names

Add yourdomain.com like this

# local-host-names - include all aliases for your machine here.
yourdomain.com

Restart Sendmail

Pete

pauljtester 10-07-2004 04:32 PM

Pete -

Thanks for your reply. I tried what you mentioned, however, if I just have the domain in there and leave off the hostname, no mail is sent out at all.... Instead I've removed everything from /etc/mail/local-host-names and it's a bit better.

I've also edited the /etc/hosts file so that it's

xxx.xxx.xxx.xxx myhostname mydomainname.com

I had some other garbage in there that was mucking things up. It's still not working properly, but that's not the sendmail problem on my box, it's a problem with the relay it's going through.

Thanks for your help
PJT


All times are GMT -5. The time now is 08:16 AM.