LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-21-2006, 05:28 AM   #1
ps.nepali
LQ Newbie
 
Registered: Dec 2005
Posts: 9

Rep: Reputation: 0
Post sendmail problem ! more than 5 minutes when i restart the service


Hi,



Sendmail takes more than 5 minutes when i restart the service, also it takes very long time to send emails.
var/log/messages shows up no error/s.

I've erased and sendmail using :

# rpm -e sendmail --nodeps

and installed again using

# rpm -ivh sendmail<x.y.z>

but still i'm having same problem.


is there any better way to fully wipe out sendmail and install it again ? ?? ?

 
Old 03-21-2006, 05:44 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,675
Blog Entries: 54

Rep: Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953
Sendmail takes more than 5 minutes when i restart the service, also it takes very long time to send emails.
- What's the OS vendor/distro/release?
- Did this happen always or did it start suddenly?
- Did packages get installed/updated/reconfigged since this situation started?
- Noticed any issues resolving addresses?


var/log/messages shows up no error/s.
- Check /etc/syslog.conf where mail messages go to: most likely /var/log/maillog and check that file.


is there any better way to fully wipe out sendmail and install it again ? ?? ?
Can't evaluate "better": no data available.
Researching problems and troubleshooting builds knowledge whereas "wintedo behaviour" (pardon my french) of uninstalling / reinstalling does not. Search LQ for "sendmail slow start" should turn up some clues.
 
Old 03-21-2006, 06:36 AM   #3
ps.nepali
LQ Newbie
 
Registered: Dec 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Post RE : sendmail

- What's the OS vendor/distro/release?
OS - RHEL4
sendmail-8.13.1-2

- Did this happen always or did it start suddenly?
as far as i remember this has happed as i append " virtusertable "
and managed mails i.e.

info@abc.com info_abc
info@xyz.com info_xyz

test was successful and everything was smooth !
but as i restarted the computer it get stuck in " sendmail "

I got in through "interactive" mode without starting sendmail. (init 3) then i used " service sendmail start / restart "
it takes more than five minutes to restart.


- Did packages get installed/updated/reconfigged since this situation started?
- Noticed any issues resolving addresses?

Everything is perfect this area !



var/log/messages shows up no error/s.
- Check /etc/syslog.conf where mail messages go to: most likely /var/log/maillog and check that file.


Nothing specific here as well ! regular stuff
 
Old 03-21-2006, 12:07 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,675
Blog Entries: 54

Rep: Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953
as far as i remember this has happed as i append " virtusertable " (..) test was successful and everything was smooth ! but as i restarted the computer it get stuck in " sendmail "
Test if it really is virtusertable (disable /etc/mail/virtusertable).


I got in through "interactive" mode without starting sendmail. (init 3) then i used " service sendmail start / restart " it takes more than five minutes to restart.
To troubleshoot you could run it manually as "sh -x /etc/init.d/sendmail start 2>&1|tee /tmp/tee" and see where it aproximately spends its time, the tee logfile can serve as the log to copy lines from. Until you finish troubleshooting you could make it run from rc.local after everything else comes up, or run it as an at job in the background.
 
Old 03-23-2006, 12:35 PM   #5
ps.nepali
LQ Newbie
 
Registered: Dec 2005
Posts: 9

Original Poster
Rep: Reputation: 0
thanx for quick response

To troubleshoot you could run it manually as "sh -x /etc/init.d/sendmail start 2>&1|tee /tmp/tee" and see where it aproximately spends its time, the tee logfile can serve as the log to copy lines from. Until you finish troubleshooting you could make it run from rc.local after everything else comes up, or run it as an at job in the background.

thanx for quick response ! will try this and let u ppl know.


i appreciate your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to restart the service gauri Debian 6 03-02-2006 02:53 AM
Automatically Restart Service tulip4heaven Linux - General 1 04-23-2005 03:11 AM
auto restart service st3reo Linux - Newbie 4 12-07-2004 01:46 PM
How to restart a service in slackware? echojihui Slackware 7 08-31-2004 09:03 PM
service network restart - mandrake 9.1 problem perry Linux - General 0 01-25-2004 08:04 PM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration