LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 06-11-2009, 09:27 AM   #1
jcdlvsrbld
LQ Newbie
 
Registered: Jun 2009
Distribution: Ubuntu 9.04 32-bit
Posts: 4

Rep: Reputation: 0
Segmentation Fault? Help!!


i posted this at ubuntu forums: http://ubuntuforums.org/showthread.php?t=1184277 and no one even had the decency to reply!! (not even spam, geez)

well anyway, having issues with mupen64plus. i wasnt able to install it using the documentation's guide. I did manage to install it via apprunner. it was running fine; however, it recently quit. it now only runs when i use the "gui app- as root" script with apprunner. when i try to run the program with the launcher, nothing happens. i managed to uninstall and reinstall it the way the project site directed me to; however, i still have the same problem. and i get this when i try to run in the terminal i get this:

Quote:
(mupen64plus:3747): Gtk-WARNING **: Unable to locate theme engine in module_path: "ubuntulooks",
Config Dir: /home/justin/.mupen64plus/
Install Dir: /usr/local/share/mupen64plus/
Plugin Dir: /usr/local/share/mupen64plus/plugins/

Segmentation fault
ive never even seen a segfault before, so im clueless as to what the problem is or how to fix it (and the gtk-warning isn't a concern to me). also i get this when trying to run via the "any app- as any user" script in apprunner:
Quote:
(mupen64plus:4001): Gtk-WARNING **: Unable to locate theme engine in module_path: "ubuntulooks",
Config Dir: /home/justin/.mupen64plus/
Install Dir: /usr/local/share/mupen64plus/
Plugin Dir: /usr/local/share/mupen64plus/plugins/

/usr/bin/app-runner-launch: line 22: 4001 Segmentation fault $run_mode ./"$file_name"
edit: forgot to mention i am using 32-bit Ubuntu, version 9.04 (jaunty)

Last edited by jcdlvsrbld; 06-11-2009 at 09:33 AM.
 
Old 06-11-2009, 09:54 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,976

Rep: Reputation: Disabled
I'm not familiar with mupen64plus but can it run on a 32bit system? It doesn't require 64bit Ubuntu does it? I'm only asking because of the "64" in the name.
cheers,
jdk
 
Old 06-11-2009, 10:01 AM   #3
miedward
Member
 
Registered: Feb 2007
Distribution: RHEL 4, SOLARIS 10
Posts: 91

Rep: Reputation: 15
For application specific questions, you should probably post to a forum or mailing list for that specific application. That is not an ubuntu or even a linux specific application, where both this forum and the ubuntu forums are fairly general.

You might get help or you might not.

A "segmentation fault" is not a problem with linux, more likely a bug in the application itself which is causing the crash. Configuration problems are also possible, if you patched your ubuntu box recently that sometimes resets config files to defaults or move/remove files that the application uses.
 
Old 06-11-2009, 10:24 AM   #4
jcdlvsrbld
LQ Newbie
 
Registered: Jun 2009
Distribution: Ubuntu 9.04 32-bit
Posts: 4

Original Poster
Rep: Reputation: 0
no, the app isnt for 64-bit systems, its a n64 emulator. i havent patched my system, so that cant be the problem, and i do realize that it is a problem within the application's scripts. i wasnt asking about the app itself, i just wanted to know if there was anyway to fix segmentation faults, and some tools i need to do it.
 
Old 06-11-2009, 10:48 AM   #5
jcdlvsrbld
LQ Newbie
 
Registered: Jun 2009
Distribution: Ubuntu 9.04 32-bit
Posts: 4

Original Poster
Rep: Reputation: 0
thanks for trying to help. i uninstalled once more. i noticed that the scripts that the uninstaller ran, did not remove the configs in the .mupen64plus folder. i simply deleted these and reinstalled. works fine now!
 
  


Reply

Tags
fault, mupen64plus, segfault, segmentation fault


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation fault cybil001 Programming 39 02-19-2007 11:01 AM
segmentation fault? ferradura Slackware 3 07-05-2006 06:40 PM
segmentation fault Tavassoli Linux - Software 5 06-12-2006 10:48 AM
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika Suse/Novell 2 12-02-2005 10:34 AM
segmentation fault sakkie Linux - Security 7 03-27-2004 12:10 AM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration