LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-12-2007, 06:35 AM   #1
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
SEGFAULT while audacious startup


SEGFAULT while audacious startup.
Those who knows about this problem please response.

Last edited by STARHARVEST; 11-12-2007 at 06:54 AM.
 
Old 11-12-2007, 10:55 PM   #2
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
If you start in terminal, do you get any output except the segfault message?
 
Old 11-13-2007, 01:28 AM   #3
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
I'm getting only segfault message and nothing else..
 
Old 11-13-2007, 03:36 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Which version?

Try to run it with strace (install it if you don't have it)
strace audacious
And look for the last messages.

It may or may not help to track the problem..
 
Old 11-13-2007, 04:34 AM   #5
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
audacious-1.4.0

strace gives awefully huge output=) (with --- SIGSEGV (Segmentation fault) @ 0 (0) --- in the end)
 
Old 11-13-2007, 04:51 AM   #6
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
Finally done!
Just edited skin PATH in config and that's it!
 
Old 11-13-2007, 06:53 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Good, how did you find?

Yes the output of strace is HUGE because it traces everything but only the last page usually is needed.

Maybe this bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=436557
 
Old 11-13-2007, 07:05 AM   #8
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
One man (developer) on Audacious forum helped me. It was his advice to check and edit config file.=)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Streamtuner and Audacious bgeddy Slackware 2 07-11-2007 05:35 PM
audacious, mcs from -current bioe007 Slackware 11 05-01-2007 04:58 AM
about audacious - libraries problem tramni1980 Slackware 6 11-11-2006 01:25 PM
No output device in audacious Zmyrgel Slackware 7 11-09-2006 06:39 PM
anjuta crash at startup segfault nocturnal Linux - Software 1 12-17-2003 12:50 PM


All times are GMT -5. The time now is 02:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration