LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-06-2005, 01:11 AM   #1
95se
Member
 
Registered: Apr 2002
Location: Windsor, ON, CA
Distribution: Ubuntu
Posts: 740

Rep: Reputation: 32
SDL Performs Horribly on My Laptop


For some reason SDL is running incredibly slow on my laptop. It's not the greatest thing in the world, Toshiba Satellite Pro 4300, 600MHz, 192 MB ram, 8mb graphics card. However, I don't believe SDL should be running as slow as it is. I wrote a simple app that bounces 2 64x64 bitmaps around an area 640x480. This app averages 5 FPS... Yes! 5! That's all it does. This just doesn't seem right. I'm pretty sure my old P1 266MHz laptop out did this sucker. Does anyone have any idea what the problem could be? Any help would be GREATLy appreciated.
 
Old 11-06-2005, 04:09 AM   #2
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 47
Are you using the drivers for your video card?
 
Old 11-07-2005, 03:37 PM   #3
95se
Member
 
Registered: Apr 2002
Location: Windsor, ON, CA
Distribution: Ubuntu
Posts: 740

Original Poster
Rep: Reputation: 32
Ya, I'm using the savage driver w/ Xorg 6.8.2. I changed my color depth from 24bit to 16bit. It sped things up a bit, but there is still no reason for running as it does.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel compilation gone horribly wrong sleepisforwimps Slackware 1 06-04-2005 04:08 PM
Trying to program an SDL application but cannot find the SDL.h file:SuSE 9.2&KDevelop pujolasdf Linux - Newbie 4 03-13-2005 07:50 AM
older computer performs better new one maenho Linux - Hardware 6 12-18-2004 03:48 AM
qt fonts gone horribly ugly! axion0917 Linux - Software 2 12-11-2003 06:17 AM
Something's gone horribly wrong zikhermm Linux - General 4 08-13-2001 08:13 PM


All times are GMT -5. The time now is 11:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration