LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 11-21-2010, 02:22 PM   #1
LQ Newbie
Registered: Jun 2008
Posts: 4

Rep: Reputation: 0
Screen shuts off after 10 minutes-- NOT screensaver, not Power Options-- ubuntu 10.04

Watching a video, listening and working, every time I come back to it I see the screen has gone black, I have to jiggle the mouse. I estimate the shutoff to come after ~10 minutes. I have set the screen saver to wait 90 minutes, and the Power Options to NEVER shut off the screen. It still happens.
Old 11-21-2010, 03:57 PM   #2
Senior Member
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
If you are running gnome and compiz check the screensaver settings in both. One overrides the other.
Old 11-21-2010, 04:09 PM   #3
Senior Member
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Sometimes the Linux kernel will shut off the screen. I used to have this problem in other distros but not in Ubuntu 10.04. Here is some information about disabling the Linux kernel power save for the screen.

Note the line to add to ./.xinitrc. Ubuntu 10.04 doesn't have this file by default so you may have to create it or use the system xinitrc or something similar. Since I don't have this problem with my current configuration so I cannot find the specific answer for Ubuntu 10.04.

Note that this setting is independent of X or Gnome. It is a Linux kernel feature.

Last edited by stress_junkie; 11-21-2010 at 04:10 PM.
Old 11-23-2010, 04:09 AM   #4
Senior Member
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,481

Rep: Reputation: 88
Have you tried using a recent xscreensaver instance rather than the stock screensaver?

Also, try doing

ps -Af | grep screen
and seeing if anything interesting pops up. I had this on an older version (I think Fedora Core 3 or somesuch) where in KDE I explicitly turned off the screensaver, but it was STILL running - I had this same problem you describe here - suddenly finding the screen switching off when watching a video. Turned out I had to manually kill the screensaver process. But I still wanted a proper screensaver that heeded my time selections, so I got xscreensaver. I compiled and installed that and everything was fine.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
After installation of Ubuntu 10.4 server edition screen shuts off Lord Hakk Linux - Server 8 05-25-2010 11:18 AM
Power of screen shuts down during boot. Debian Etch ArchAngeL13 Debian 4 09-25-2007 02:58 PM
Ubuntu Power Options fultron Linux - Newbie 5 02-17-2007 12:32 PM
Winodws shuts down after 2-4 minutes? Viruse? or the new keyboard? Smiling Jack General 25 11-18-2006 03:40 PM
laptop monitor shuts off after a few minutes icepack Mandriva 2 03-19-2006 04:11 PM

All times are GMT -5. The time now is 02:33 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration