LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-07-2004, 04:54 PM   #1
newbieapr2004
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Rep: Reputation: 0
Angry Screen only show GRUB after reboot / installation


Hi all -

I am a true newbie in this Linux thing. I need to install Linux on my PC as the software I plan to use only run in Linux version. Unfortunetely, the installation went wrong. That's why what a relief when I see this site.....

I install a second hard drive (6 GB, FAT) on my Dell machine. The master one has 60 GB NTFS with windowsXP. I don't have floppy drive to make a boot disk.

Anyway, I install Red Hat 9.0 found in one of those "How to - Dummies" book (yep.. that's me indeed... !). The installation seemed to go smoothly - I mostly chose the default, except I made sure that I would only install it on the 2nd drive. I did not make a boot disk when it finished installing as I do not have floppy drive on my PC (another dummy thing I did when I ordered this PC !!) . I then reboot the computer - but the screen only shows "GRUB" - nothing else. I tried to re-install it again, this time I chose LILO - and this time, the screen only showed "L" - unfortunetely as I expected. Seems like the system was hang... I could not do anything...

Would you please advice this desperate user ?

Thank you very much... !!

Maria

Last edited by newbieapr2004; 04-07-2004 at 05:00 PM.
 
Old 04-07-2004, 05:20 PM   #2
Yell0w_c0w
LQ Newbie
 
Registered: Mar 2004
Posts: 14

Rep: Reputation: 0
I think probably instead of writing GRUB to MASTER BOOT RECORD you decided to write GRUB in the FIRST SECTOR OF PARTITION.

A solution, I think, at least a temporary one to get back to windows is to erase the MBR.

- Boot with Windows XP CD, select diagnostic tools
- Type fdisk /mbr

Doing so will clear the section in memory which says "Look for grub". It will (by some mechanism) look for the nt bootloader which resides in your C:\ probably. I forget the exact name, ntldr.dll ?

It seems a lil scary, but that should get you back standing at least

Yell0w_c0w
 
Old 04-07-2004, 07:41 PM   #3
newbieapr2004
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Hi - thank you sooo much for your advice - I got my windows back.... pheeeew.... !!!!!!

However, I did went through the installation process again, this time like you said, I made sure that I put the GRUB to master Boot Record. It was their default though. And the same thing happened again - my screen freeze with this GRUB word on it.

Any other suggestion I can go through... ?

Thank you very much.... !
Maria
 
Old 04-07-2004, 10:11 PM   #4
ckleuser
LQ Newbie
 
Registered: Mar 2004
Location: Curitiba, PR, Brazil
Distribution: SuSE 9.0
Posts: 2

Rep: Reputation: 0
Smile

Well, first of all, you'll need to write again your MBR to replace the wrong GRUB installed bootloader with the default XP bootloader.
To do this, simply boot your machine with the Windows XP installation CD and
choose to 'R' Repair your installation when the installation prompts you that!!!
Propably, the repair prompt will ask you a password for administrador, just hit
<enter> and go on, there's no passoword....
Now choose the installation of XP for Repair, pressing 1..2..3..so on, that will
be asked to you....
Now, run this command at the prompt :

> FIXMBR

and follow the instructions. Don't try to run FDISK / MBR in Windows XP, it
doesn't work.
After that, reboot your machine by typing "EXIT" in the command line and wait.
If everything comes back to normal and your XP boot's normally, then
put again your RedHat Boot disk in your CD tray.
Boot again your PC and wait......
I don't remember as well as good because I use SuSE 9.0, but try to find
in your RedHat Boot, some option for Rescue your system, that you can boot
your /deb/hdb previously installed. If you could do that, enter as ROOT user
and do the following :

verify these files :

/boot/grub/menu.lst
/etc/grub.conf

after you seen thats everything on place, save the files and run this
command:

> grub-install /dev/hda
> reboot

see what happens!!!
I hope is works, if not, just do it again the XP booting process.....

If not works, enter your BIOS and see if there's some BOOT protection VIRUS option or something similar to Disable, okay ???

See ya....

[]s, Cristian

Last edited by ckleuser; 04-07-2004 at 10:12 PM.
 
Old 04-20-2004, 12:18 PM   #5
louisw
LQ Newbie
 
Registered: Apr 2004
Location: New York, NY
Posts: 3

Rep: Reputation: 0
Need further help

I did the same thing. (Red Hat 9.0 found in one of those "How to - Dummies" book (yep.. that's me indeed... !). The installation seemed to go smoothly - I mostly chose the default, except I made sure that I would only install it on the 2nd drive. I then reboot the computer - but the screen only shows "GRUB" - nothing else. ))



Then I used the windows rescue cd and used FIXMBR to bring back windows.


I used the redhat installation cd and entered rescue mode but do not know how to log in as ROOT user.

What is the step to do that?

Thanks for your help

Lou


Quote:
Originally posted by ckleuser
then
put again your RedHat Boot disk in your CD tray.
Boot again your PC and wait......
I don't remember as well as good because I use SuSE 9.0, but try to find
in your RedHat Boot, some option for Rescue your system, that you can boot
your /deb/hdb previously installed. If you could do that, enter as ROOT user
and do the following :

verify these files :

/boot/grub/menu.lst
/etc/grub.conf

after you seen thats everything on place, save the files and run this
command:

> grub-install /dev/hda
> reboot
 
Old 04-25-2004, 09:37 AM   #6
louisw
LQ Newbie
 
Registered: Apr 2004
Location: New York, NY
Posts: 3

Rep: Reputation: 0
Figured out solution

The solution was to change the settings in the BIOS.

The computer I bought from Dell had the BIOS set to not detect the second hard drive ("OFF" vs "AUTO"). After I made that change (Which i did after I installed fedora), then everything worked swimmingly.

Of couse, now I have to deal with the Dell soundcard (Soundblaster Live issue) that apparently there are really no free linux drivers for.

Lou
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Show Login Screen on SuSE 9.2 Zakirium Linux - Newbie 2 01-17-2006 01:44 PM
slide show screen saver ion9 Linux - Software 2 11-30-2004 12:54 AM
GRUB reading fails at first reboot during installation Recirqie Suse/Novell 3 11-01-2004 06:10 PM
Grub Splashscreen Will Not Show schmmd Linux - General 2 03-16-2004 05:00 PM
Nvidia G4 with TV-Out (TV won't show full screen) MasterC Linux - Hardware 7 08-02-2003 10:50 AM


All times are GMT -5. The time now is 05:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration