LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-16-2010, 06:07 AM   #1
samineru
LQ Newbie
 
Registered: Apr 2010
Posts: 15

Rep: Reputation: 0
screen/byobu keybindings not working


I've used screen for a little while and just found out about byobu.
I much prefer the byobu keybindings over the C-a nonsense that screen needs. However, I have no need for the byobu status bar, as I have conky running as well, with nice fonts too. I edited my byobu profile and commented out
Code:
# Window tabs, second to last line
# caption always "%12`%?%-Lw%50L>%?%{=r}%n*%f %t%?(%u)%?%{-}%12`%?%+Lw%?%11` %=%12`%110`%109`%122`%111`%10`%<"

# Status string, last line
# hardstatus string '%99`%{-}%{=r}%12` %100`%112`%= %130`%102`%101`%129`%131`%127`%114`%115`%108`%128`%125`%126`%113`%119`%117`%116`%106`%104`%103`%105`%107`%123`%132`%120`%121`'
as their comments suggest they are the two status lines I do not care for. I'm not sure if it's because of this, but now the screen creation and switching keybinds do not work, even though in the config options for byobu I have it set to use the f-keys keybind set.
I can still retitle, detach and pull up the byobu options with f-keys.
Additionally, by default I can just scroll up with the scroll wheel, I don't need to enter scrollback mode, which seems strange as their is a keybind for "Scrollback Mode"
Any ideas as to whats going on?
 
Old 02-12-2011, 07:36 PM   #2
DarwinSurvivor
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Rep: Reputation: 1
Disable Status Bar

Look for the line "hardstatus alwayslastline" and change it to "hardstatus ignore" to hide it completely or "hardstatus message" to have it alternate back and forth with the list of screens (basically makes it blink back/forth).

What you are most likely looking for is to change it to "hardstatus ignore" like I've done.

Unfortunately I was unable to find any documentation stating this, but if you change the value after hardstatus and refresh byobu it quickly flashes the valid options and I was able to figure out what most of them do by trial/error.

Sorry for resurecting an old thread, but I was unable to find any other answers/questions about this problem and this seemed the most logical place to put it (given it's relatively high google results placement).
 
  


Reply

Tags
hotkeys, keybinding, keys, screen, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Byobu, Gmail and /var/mail/$user sisyphus1978 Linux - Software 0 12-23-2009 04:53 AM
LXer: Enhancing terminals with byobu on Ubuntu 9.10 LXer Syndicated Linux News 0 11-12-2009 04:00 PM
keybindings Jayla Linux - Newbie 3 06-23-2008 07:32 AM
Gnome Keybindings stopped working kg4ysy Linux - Software 1 08-27-2005 01:19 PM
keybindings in linux isajera Programming 1 08-11-2001 04:28 AM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration