LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-22-2008, 11:00 PM   #1
sandaili
LQ Newbie
 
Registered: Jun 2007
Posts: 25

Rep: Reputation: 15
SCIM font - got SCIM working, now all flash has japanese font.....help!


I put this in my .bash_profile to get SCIM to work. That's great and all. But when I want to play flash games, they all are using the japanese font, which is not so great for me to read (it shows as english but it's that really weird english font).

Is there a way for me to specify what font gets used instead of the japanese one? Or now do I every time have to log in and out and edit that file if I want to use Japanese input/play flash games.

Thanks,

L

PS here is the code I put in to make SCIM work:

export PATH
unset USERNAME
xport XMODIFIERS='@im=SCIM'
export GTK_IM_MODULE="scim"
export QT_IM_MODULE="scim"
export LC_CTYPE=ja_JP.utf8
scim -d
 
Old 05-23-2008, 01:11 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
You don't need the "LC_CTYPE=ja_JP.utf8" there. LC_CTYPE is the environment setting that specifies what language most of the gui will be in. You shouldn't need to set any of the locale variables to Japanese for the scim IME to work; just as long as they're using a utf8 encoding (I use en_US.UTF-8, for most of my locale settings, for example).
 
Old 05-23-2008, 03:34 AM   #3
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
To my knowledge, LC_CTYPE shouldn't influence the language settings - just the "character type".

LANG is for setting language (menus, tooltips, manpages, error messages etc.) and LC_ALL sets all LC-environment variables including LANG.

But it's correct that you don't have to load a japanese locale setting to use scim with japanese input.

I'm using this combination for example:

Code:
export LC_CTYPE="de_DE.utf-8"
export LC_COLLATE="de_DE.utf-8"
export LANG=en_US.utf-8
(make umlauts work properly everywhere and use UTF-8, make sort order according to german dictionary sort order (influences programming languages like perl for example), but leave all language settings untouched in english - I hate translated error messages...)

To type japanese in romanji on a german keyboard with Anthy I use scim (scim-anthy) with this setting:

Code:
export XMODIFIERS="@im=SCIM"
export XIM_PROGRAM="scim -d"
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
scim -f socket -ns socket -d
scim -f x11 -s socket -c socket -d
This setup - proper unicode-enabled font provided everywhere including Firefox - lets me type german, english and japanese with scim and shows japanese websites correctly. (And most other languages supported by my chosen font for that matter...)
 
Old 05-27-2008, 12:46 PM   #4
sandaili
LQ Newbie
 
Registered: Jun 2007
Posts: 25

Original Poster
Rep: Reputation: 15
Thank you both!!!

It's funny, it only affected flash and anything that was KDE related (I run Gnome, but I run a few KDE programs).

L
 
Old 06-14-2008, 06:18 PM   #5
harryhaller
Member
 
Registered: Sep 2004
Posts: 429

Rep: Reputation: Disabled
Can anyone explain how I can enlarge the characters in the SCIM input box? It is the suggested chinese characters which one sees when entering pinyintone that need enlarging.

Is there an english translation of the SCIM documentation?
 
Old 06-15-2008, 09:04 AM   #6
harryhaller
Member
 
Registered: Sep 2004
Posts: 429

Rep: Reputation: Disabled
Solved

It's hard to spot, but it's there.

click on the panel, choose scim-setup, panel, gtk, there under miscellaneous (bottom right) there's a tiny button with "fonts" beside it.
 
Old 03-24-2009, 07:27 AM   #7
IsaoHK
LQ Newbie
 
Registered: Mar 2009
Posts: 5

Rep: Reputation: 0
フラシューアップリにはまだ入力出来なくて
This is just a test, I'm sorry. But how can get SCIM working in flash applets ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
font size in scim Kirmonkey Linux - Software 2 06-16-2008 01:42 AM
chinese/Japanese input via SCIM in ubuntu 6.10 leong3779 Linux - Desktop 13 05-14-2007 03:28 AM
Japanese kb layout broken after upgrading to FF. SCIM issues. Ariox Ubuntu 0 04-26-2007 12:55 AM
Japanese input not working in Qt with SCIM-QTIMM AireTamStorm Linux - Software 1 04-30-2006 10:33 AM
Skim/Scim not working in Firefox 1.0.6? koyi Slackware 1 09-23-2005 07:55 AM


All times are GMT -5. The time now is 11:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration