LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   SCIM font - got SCIM working, now all flash has japanese font.....help! (http://www.linuxquestions.org/questions/linux-software-2/scim-font-got-scim-working-now-all-flash-has-japanese-font-help-644192/)

sandaili 05-22-2008 11:00 PM

SCIM font - got SCIM working, now all flash has japanese font.....help!
 
I put this in my .bash_profile to get SCIM to work. That's great and all. But when I want to play flash games, they all are using the japanese font, which is not so great for me to read (it shows as english but it's that really weird english font).

Is there a way for me to specify what font gets used instead of the japanese one? Or now do I every time have to log in and out and edit that file if I want to use Japanese input/play flash games.

Thanks,

L

PS here is the code I put in to make SCIM work:

export PATH
unset USERNAME
xport XMODIFIERS='@im=SCIM'
export GTK_IM_MODULE="scim"
export QT_IM_MODULE="scim"
export LC_CTYPE=ja_JP.utf8
scim -d

David the H. 05-23-2008 01:11 AM

You don't need the "LC_CTYPE=ja_JP.utf8" there. LC_CTYPE is the environment setting that specifies what language most of the gui will be in. You shouldn't need to set any of the locale variables to Japanese for the scim IME to work; just as long as they're using a utf8 encoding (I use en_US.UTF-8, for most of my locale settings, for example).

Su-Shee 05-23-2008 03:34 AM

To my knowledge, LC_CTYPE shouldn't influence the language settings - just the "character type".

LANG is for setting language (menus, tooltips, manpages, error messages etc.) and LC_ALL sets all LC-environment variables including LANG.

But it's correct that you don't have to load a japanese locale setting to use scim with japanese input.

I'm using this combination for example:

Code:

export LC_CTYPE="de_DE.utf-8"
export LC_COLLATE="de_DE.utf-8"
export LANG=en_US.utf-8

(make umlauts work properly everywhere and use UTF-8, make sort order according to german dictionary sort order (influences programming languages like perl for example), but leave all language settings untouched in english - I hate translated error messages...)

To type japanese in romanji on a german keyboard with Anthy I use scim (scim-anthy) with this setting:

Code:

export XMODIFIERS="@im=SCIM"
export XIM_PROGRAM="scim -d"
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
scim -f socket -ns socket -d
scim -f x11 -s socket -c socket -d

This setup - proper unicode-enabled font provided everywhere including Firefox - lets me type german, english and japanese with scim and shows japanese websites correctly. (And most other languages supported by my chosen font for that matter...)

sandaili 05-27-2008 12:46 PM

Thank you both!!!

It's funny, it only affected flash and anything that was KDE related (I run Gnome, but I run a few KDE programs).

L

harryhaller 06-14-2008 06:18 PM

Can anyone explain how I can enlarge the characters in the SCIM input box? It is the suggested chinese characters which one sees when entering pinyintone that need enlarging.

Is there an english translation of the SCIM documentation?

harryhaller 06-15-2008 09:04 AM

Solved
 
It's hard to spot, but it's there.:)

click on the panel, choose scim-setup, panel, gtk, there under miscellaneous (bottom right) there's a tiny button with "fonts" beside it.

IsaoHK 03-24-2009 07:27 AM

フラシューアップリにはまだ入力出来なくて
This is just a test, I'm sorry. But how can get SCIM working in flash applets ?


All times are GMT -5. The time now is 06:00 AM.