LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-17-2004, 01:13 AM   #1
houshuang
LQ Newbie
 
Registered: Mar 2004
Location: Hangzhou, CN
Distribution: Mepis 2004.05 / Debian testing
Posts: 4

Rep: Reputation: 0
Question SCIM chinese input works selectively (Mandrake 10)


So far my RH 10 install has gone very well, and finally I seem to be switching to Linux fulltime after numerous tryout installs during the last few years. One of the persistent problems has been Chinese input (I am not Chinese, but live in China and study Chinese and use it on a daily basis). This time, I've gotten a lot further than before, but still not perfect. I start up the scim server, set the LC_CTYPE=zh_CN.gb2312 and XMODIFIERS=@im=scim, then start oowriter from that shell. Wow - Chinese input works like a dream! BUT that is the only programme I have gotten it to work with - both Thunderbird and Firefox, two of my most commonly used programmes, do not work when started right after from the exact same shell...

Any help would be most appreciated!

--
On a side note, copying Chinese text between programmes (ie oowriter, which works, and Thunderbird, which displays incoming Chinese mails perfectly - does not work). Also, the Chinese fonts Firefox uses are quite ugly and hard to read, as compared to Windows (still Firefox), and I can't get Kopete to display Chinese, let alone enter it.

China has a huge population that will be more and more interested in Linux as the WTO tightens copyright enforcement for Windows etc. My girlfriend loved Knoppix when she saw it. But if they have to go through this entire ordeal to get something working that works out of the box with Win XP, it's not going to happen. Ideally, Chinese input would be one more choice on the KDE language switch bar (which works perfectly for me from Norwegian to English, although it would be nice if it remembered its mode for each window, rather than making global switches, or maybe there is a setting for this?), without implying any locale settings etc. (It should be possible to type in Chinese without having Chinese menus for example. And what if you want to type in Chinese and Japanese intermittently?)

Thanks again (sorry for the outburst of opinion)

Stian / houshuang
Hangzhou, China
 
Old 03-17-2004, 03:50 PM   #2
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
SCIM chinese input works selectively (Mandrake 10)

Hi,

I've tried SCIM recently on MDK 9.2 (MDK10 shouldn't be any different really), but I use fcitx - http://www.fcitx.org/ - this seems to have worked with everything I have tried it with, and the input bar is pretty cool too...

SCIM works with unicode, but with fcitx you need to set the locale settings to zh_CN (LANG, LC_CTYPE). XMODIFIERS will be @im=fcitx as well...

I agree totally with you about how easy it is to use the keyboard switcher in Windows, and how easy it is to change from Chinese to Japanese to Korean or whatever whilst you're typing one document, but unfortunately at the moment Linux doesn't have this functionality, so we just make do as best we can...I am no programmer so I can't help much there!

cheers,

jdw
 
Old 03-17-2004, 10:11 PM   #3
houshuang
LQ Newbie
 
Registered: Mar 2004
Location: Hangzhou, CN
Distribution: Mepis 2004.05 / Debian testing
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the reply! In deed, I did try out fcitx, partly after reading the gentoo chinese faq. It works like a dream in every program, _except_ I cannot change the input method to Pinyin, it only let's me do wubi. Since I have no idea about wubi, this is completely useless. I tried all the short keys, also checked the config files if there was a "default input method" setting etc, and it isn't working. Could I be missing some files or something? (I did a source install, with the latest version).

Thanks again! When only I can get this fixed, I am up and running...

Stian
 
Old 03-17-2004, 10:23 PM   #4
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
SCIM chinese input works selectively

yeah, i hear you...make sure you download the proper version of fcitx 2.0, the release candidate only had wubi in it...

the full version has intelligent (zhineng) pinyin...

cheers,

jdw
 
Old 08-18-2004, 09:53 PM   #5
ThePenguin
Member
 
Registered: Sep 2003
Location: GA, US
Distribution: RedHat 9.0
Posts: 50

Rep: Reputation: 15
Red face

Does it work with Korean text? I need to input korean text and can't atm.
 
Old 08-18-2004, 10:04 PM   #6
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
SCIM chinese input works selectively (Mandrake 10)

Hi,

fcitx is for Simplified Chinese only...

give SCIM a try...it has Korean input.

Any good Linux distro will ami as the default Korean input editor though, does it not work???

cheers,

jdw
 
Old 08-18-2004, 10:08 PM   #7
ThePenguin
Member
 
Registered: Sep 2003
Location: GA, US
Distribution: RedHat 9.0
Posts: 50

Rep: Reputation: 15
ahh i dont know about AMI working or not. -_-

How do I check?

Went on a tangent, sorry. Anyways AMI sounds good and so does
SCIM, I had a look at SCIM and it looks nice~

Have a nice day! ^^
 
Old 08-18-2004, 10:18 PM   #8
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
hi,

to see if ami is installed type :

$ whereis ami

at a command line prompt and if it is installed it will output the location of the binary of this application, e.g. /usr/bin/ami

if not then it most likely isn't installed, which would suggest that you did not select Korean support when you installed Mandrake.

It would have been on about the first or second screen during install, in order to install support for additional languages you would have had to have pressed the "Advanced" button, and then select Korean from the list...

if you did select it then the installer would have installed Korean fonts, locales and the ami input server so that you could input Korean.

So, before we move on to how you get the Korean input working, please check & answer the above and we will take it from there...

jdw
 
Old 08-18-2004, 10:29 PM   #9
ThePenguin
Member
 
Registered: Sep 2003
Location: GA, US
Distribution: RedHat 9.0
Posts: 50

Rep: Reputation: 15
Quote:
Originally posted by JDW
hi,

to see if ami is installed type :

$ whereis ami

at a command line prompt and if it is installed it will output the location of the binary of this application, e.g. /usr/bin/ami

if not then it most likely isn't installed, which would suggest that you did not select Korean support when you installed Mandrake.

It would have been on about the first or second screen during install, in order to install support for additional languages you would have had to have pressed the "Advanced" button, and then select Korean from the list...

if you did select it then the installer would have installed Korean fonts, locales and the ami input server so that you could input Korean.

So, before we move on to how you get the Korean input working, please check & answer the above and we will take it from there...

jdw
Alright, (thanks for helping me by the way!) I know I installed all the korean language support GNOME and KDE. I did use the advanced tab.
LOL, by the way, your "whereis" command helped me find the SCIM executable. I may need assistance with it as well -_-.

EDIT: lol, got SCIM to work and im not sure how( i see it in the bar on my corner). I found some tables as well.

I did the "whereis ami" and got $whereis ami <next line> ami: (blank)
so "ami: (blank)" probably means I dont have it >.<.

Last edited by ThePenguin; 08-18-2004 at 10:45 PM.
 
Old 08-18-2004, 10:44 PM   #10
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
SCIM chinese input works selectively (Mandrake 10)

Hi,

If you installed Korean support it should have installed ami by default...anyway, from your main KDE or GNOME Start menu go to Configuration, and select Install New Packages...(I'm doing this from memory, but I think that's the order on the menu items!)

Select to put the list in alphabetical order, and ami should be there...select ami and it will ask you for one of the Mandrake CDs...insert that, let it install and then make sure you are in a Korean locale environment* and run a program like oowriter with ami with the following command :-

$ ami & oowriter

* you can do this simply by typing the following commands at the command line :-

$ export LANG=ko_KR
$ export LC_ALL=ko_KR
$ export LC_CTYPE=ko_KR
$ export XMODIFIERS=@im=ami

test this by typing the following command :-

$ locale

it should spit out a dozen or two lines of settings all ending in ko_KR...

good luck, and if it still isn't happening, please feel free to ask...

jdw
 
Old 08-18-2004, 10:59 PM   #11
ThePenguin
Member
 
Registered: Sep 2003
Location: GA, US
Distribution: RedHat 9.0
Posts: 50

Rep: Reputation: 15
I did everything you told me and got to the following line (last step)

bash: XMODIFIERS-@im-ami: command not found

i did a $locale and all were KO, so I'm in good shape there, now my problem is
how do I put text in OpenOfficeWriter?

edit: and do I have to do this everytime at boot up?

Last edited by ThePenguin; 08-18-2004 at 11:00 PM.
 
Old 08-18-2004, 11:04 PM   #12
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
SCIM chinese input works selectively (Mandrake 10)

$ export XMODIFIERS=@im=ami


should be an " = " sign, not a -

jdw
 
Old 08-18-2004, 11:14 PM   #13
ThePenguin
Member
 
Registered: Sep 2003
Location: GA, US
Distribution: RedHat 9.0
Posts: 50

Rep: Reputation: 15
OK, I got everything up and going. But I still need a font to use in OOW...I know i got the korean TTF's. How do I use them?
I checked the fonts in OOW..None are Korean characters
 
Old 08-18-2004, 11:20 PM   #14
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
SCIM chinese input works selectively (Mandrake 10)

cool, almost there...

try any font that has the words "batang", "dotum" or "gulim" in the title...

if there aren't any of these, you should be able to find some on the Mandrake CDs (but think you will find these)...the Mandrake font installer is pretty nifty as well in these situations...

cheers,

jdw
 
Old 08-18-2004, 11:25 PM   #15
ThePenguin
Member
 
Registered: Sep 2003
Location: GA, US
Distribution: RedHat 9.0
Posts: 50

Rep: Reputation: 15
I have all 3...But they do not give korean text~
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
chinese input SCIM -d doesn't work xjchen001 Linux - Newbie 1 09-15-2005 09:14 PM
Chinese input using SCIM in OpenOffice satellite360 Linux - Software 4 05-17-2005 09:21 AM
Chinese simplified input problems, Mandrake 9.2. giotu007 Mandriva 19 03-29-2004 07:07 PM
Chinese input under RXvt -- Mandrake 9.1 Jiawen Linux - Software 4 09-17-2003 03:06 PM
Chinese Input in Mandrake 9.0 or MD8.2 awtoc123 Linux - General 2 09-15-2002 09:54 AM


All times are GMT -5. The time now is 07:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration