LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-08-2003, 05:30 PM   #16
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48

Yeah, you can remove the symlink (if the above command is the
one you issued, the symlink is /dev/usbscanner) with:
Code:
rm /dev/usbscanner
I don't think that's the problem, but it's certainly worth a shot, and
I'd be happy to be wrong.

Last edited by moses; 01-08-2003 at 05:39 PM.
 
Old 01-08-2003, 06:10 PM   #17
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
I'm getting both /dev/usbscanner and /dev/usb/scanner0 reported in xsane when I start it, either one works if I select it. What version of xsane are you using and did you install it from rpm?
 
Old 01-09-2003, 03:39 PM   #18
tonyath
LQ Newbie
 
Registered: Mar 2002
Location: New Zealand
Distribution: Mandrake 9
Posts: 18

Original Poster
Rep: Reputation: 0
Hullo again,

I've managed to work-out how to break the symlink causing the above double device report-back.

code: sane-find-scanner now shows just the one :

found usb scanner (vendor=0x04a9, product=0x2204) at device/dev/usb/scanner0

Still not having any joy with either the xsane or scanimage commands. Still getting the: 'Failed to start scanner, Device busy' messages.

Any further suggestions would be most appreciated.

Regards,
tonyath
 
Old 01-09-2003, 03:53 PM   #19
tonyath
LQ Newbie
 
Registered: Mar 2002
Location: New Zealand
Distribution: Mandrake 9
Posts: 18

Original Poster
Rep: Reputation: 0
Hi Aussie,

I have both xsane & xsane-gimp installed. Both are version 0.87-1mdk.

Yes, these were both installed from rpm.

Regards,
 
Old 01-09-2003, 04:01 PM   #20
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Uninstall the xsane rpm's and try the source.
 
Old 01-09-2003, 04:29 PM   #21
tonyath
LQ Newbie
 
Registered: Mar 2002
Location: New Zealand
Distribution: Mandrake 9
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks,

I'll let you know how it goes.
 
Old 03-08-2004, 10:19 PM   #22
fureto
LQ Newbie
 
Registered: Mar 2004
Location: Edmonton, Canada
Distribution: Mandrake 10.1
Posts: 1

Rep: Reputation: 0
Hello

I was also having a very similar problem and have happened onto a cheap hack to fix it.

- Start xsane
- Hitting scan / preview will now cause the "Device Busy" error.
- Cycle the power on the scanner.
- Now hitting the scan / preview buttons does not do much of anything but the "Device Busy" no longer appears.
- Without closing xsane run scanimage -d ... (just like before)
- Ctrl-C the scanimage once the scanner starts going.
- This should now leave you with a working instance of xsane.

You have to do this everytime you restart xsane.
 
Old 03-15-2004, 07:55 PM   #23
galen
Member
 
Registered: Sep 2003
Location: Halifax, Nova Scotia, Canada
Distribution: Sparky, PartedMagic, Puppy, xubuntu. BOYCOTTING: Vector, Beatrix, BLAG, Slackware
Posts: 76
Blog Entries: 1

Rep: Reputation: Disabled
same problem here I/O error with an UT12 plustek, runnning arch linux [kernel 2.4.25], sane from source

#xsane plustek:/dev/usb/scanner0

reports an I/O error, no pulse from scanner
even though
#sane-find-scanner
does find it

also I've
#modprobe scanner
and usb-storage is lsmod active
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SANE to INSANE mikeghet Linux - Newbie 2 06-16-2005 11:11 PM
need help with xsane and sane jbzy3000 Linux - Software 11 08-09-2004 11:11 PM
Redhat WS and sane awtoc123 Red Hat 0 04-21-2004 04:13 AM
xsane and sane demmylls Linux - General 1 11-16-2003 12:39 AM
Sane Pedroski Linux - Software 9 10-05-2003 02:07 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration