LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   samba won't mount windows shares (http://www.linuxquestions.org/questions/linux-software-2/samba-wont-mount-windows-shares-47221/)

ixion 02-26-2003 09:43 AM

samba won't mount windows shares
 
We have a Suse linux server on our network (across the WAN), and need to mount Windows shares with it. I can mount shares just fine on windows boxes from my laptop (Slackware) on the local network. I come from a Slackware/Gentoo background, and am apparently not mounting correctly with Suse. This is my procedure:

mount -t smbfs //192.168.0.1/temp /mnt/windows
7822: session request to 192.168.0.1 failed (Called name not present)
7822: session request to 192 failed (Called name not present)
7822: session request to *SMBSERVER failed (Called name not present)
SMB connection failed


I glanced over the /etc/samba/smb.conf file and it appears ok. Any suggestions?

acid_kewpie 02-26-2003 09:57 AM

can you ping the address? if so then you should be able to actually use the server name rather than the IP

ixion 02-26-2003 10:00 AM

I can ping the IP address, but not by hostname, ie 'ping 192.168.0.1' works, 'ping windowsbox' does not.

acid_kewpie 02-26-2003 10:02 AM

yes, fair enough. afaik samba doesn't actually resolve computer names by dns means, but instead broadcasts out and waits for the compuet to own up to being that machine. try just using the host name. of course, i might be completely wrong. that's been known a few times

ixion 02-26-2003 10:04 AM

hehe, already tried that. Mounting with hostname results in this:

tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
tdb((null)): tdb_open_ex: could not open file //var/lib/samba/unexpected.tdb: No such file or directory
8126: Connection to windowsbox failed
SMB connection failed

TexasDex 02-27-2003 05:26 PM

Two THings:
try using the command SMBMOUNT instead of mount

try using backslashes in the command, I'm not sure if that makes a difference.
e.g.
\\192.168.0.1\sharename /folder/mountpoint

That's all I can think of, I'm not very experienced in this, although Samba is my strength.

axis 02-28-2003 01:51 AM

Im having the same problem with slackware 8.1 did you figure out what is wrong?

chris


All times are GMT -5. The time now is 12:38 AM.