LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Samba setting (http://www.linuxquestions.org/questions/linux-software-2/samba-setting-561100/)

swmok 06-12-2007 02:15 AM

Samba setting
 
I've installed samba in my Linux.
I want to let the Linux user read/write their files
from WinXP.

However, the passwords in Linux are different from the passwords in Samba.

I want to make them "equal". The Samba passwords follow the change of Linux passwords.

When I add "smb passwd file = /etc/samba/smbpasswd" in
smb.conf, the testparm don't read this line.

My questions:
How to make the passwords "equal"?
What is the use of "swat"? Is it use for the setting of samba through browser?

Thanks.

ZAMO 06-12-2007 02:44 AM

You can make the /etc/passwd to smbpasswd by using "cat /etc/passwd>mksmbpasswd.sh|cat >/etc/samba/smbpasswd" .
Ofcourse you can use swat to browse windows share in Linux. If you find any difficulty to install and configure SWAT, You can go for windows share in nautilus(any window), and on the address bar type smb:/// and enter. This will bring you all windows share to you.

ALL the best

jschiwal 06-12-2007 02:44 AM

added "port = 901" to the posted file.
 
Use the "smbpasswd" program to create linux users & passwords corresponding to the Windows users.

Check if your distro supplies a samba-doc package. It includes three Samba 3 books, including "Samba 3 by Example" which will guide you step by step on setting up several different possible configurations. It may also contain the html version of "Using Samba 2nd Ed.".

Yes, samba swat allows you to configure samba via a browser interface. Before you use it, you need to configure xinetd to allow access to it.

Here is my /etc/xinetd.d/swat file:
Code:

cat /etc/xinetd.d/swat
# SWAT is the Samba Web Administration Tool.
service swat
{
        port            =  901
        socket_type    =  stream
        protocol        =  tcp
        wait            =  no
        user            =  root
        server          =  /usr/sbin/swat
        only_from      =  127.0.0.1
        log_on_failure  += USERID
        disable        =  no

}

It is possible that this file exists, and you just need to change "disable = yes" to "disable = no".

Then restart the xinet daemon with "sudo killall -SIGHUP xinetd". This will cause it to restart, reloading the config files.

Now point your web browser on the server to "http://localhost:901".


All times are GMT -5. The time now is 08:49 PM.