LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 09-30-2003, 03:37 PM   #1
mla
Member
 
Registered: Sep 2003
Location: Canada
Posts: 86

Rep: Reputation: 15
samba server is not accessible


i am using rh9.
cannot make work samba.
in smb.conf changed workgroup name.
enabled shared folder for samba users in samba gui.

when trying to browse from w98 can see samba computer.
when click on icon getting message: \\X is not accessible.
the computer or sharename could not be found.

when try to find samba server by ip address no success at all.

what i have to add in smb.conf?
thanks.
Michael.
 
Old 09-30-2003, 04:02 PM   #2
Kintar
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat 9
Posts: 8

Rep: Reputation: 0
Hi, Michael. A good start might be to take a look at the Samba HOWTO Collection.

In general, you'll need to make sure your smb.conf file has the following lines in it:

Code:
  workgroup = <workgroupname>
  security = server
  password server = <windows domain controller machine name>
  encrypt passwords = yes
Hope it helps!

-- Kintar
 
Old 09-30-2003, 04:04 PM   #3
mossy
Member
 
Registered: Aug 2003
Location: USexIRL
Distribution: *nix
Posts: 849

Rep: Reputation: 30
NB - simple but easily forgotten is....

~shutdown ALL firewalls first~


you'd be surprized.
 
Old 09-30-2003, 04:17 PM   #4
dnorseman
Member
 
Registered: Aug 2003
Location: Chicago, USA
Distribution: RHEL, CentOS, Ubuntu
Posts: 43

Rep: Reputation: 15
Did you create the smb password file? I run this command to create it:

cat /etc/passwd | /usr/bin/mksmbpasswd.sh > /etc/samba/smbpasswd

Then set smbpasswords for users:

smbpasswd user

Hope that helps.

Last edited by dnorseman; 09-30-2003 at 04:19 PM.
 
Old 09-30-2003, 04:47 PM   #5
mla
Member
 
Registered: Sep 2003
Location: Canada
Posts: 86

Original Poster
Rep: Reputation: 15
Mossy you are right.
I just disabled firewall...
Security level was medium. I put it to No firewall.
I want to put it to medium back.
How I can enable smb incoming protocol on firewall?
Thanks to all people that answered.
Michael.
 
Old 09-30-2003, 04:55 PM   #6
mossy
Member
 
Registered: Aug 2003
Location: USexIRL
Distribution: *nix
Posts: 849

Rep: Reputation: 30
close misbehaving firewall app and restart um said firewall. It should behave. If not try to add your share/ip/whatever as a dmz [demilitarized zone - unfirewalled ] if not - reinstall.

mossy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - Windows XP Problem (//Samba is not accessible) Covenent Linux - Networking 20 08-11-2011 04:07 PM
Samba not accessible tyrie Linux - Newbie 5 10-13-2005 08:28 AM
Samba mounts not accessible Milinu Linux - Newbie 2 09-06-2004 01:50 PM
SAMBA Server not accessible compassmanwi Linux - Networking 3 08-26-2004 07:50 PM
Samba share not accessible Quercus Linux - Software 2 12-07-2003 08:43 AM


All times are GMT -5. The time now is 05:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration