LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-07-2004, 01:24 AM   #1
shultzc
LQ Newbie
 
Registered: Feb 2004
Location: Portland, Oregon
Distribution: Debian, FreeBSD, Solaris, Mac OS X
Posts: 22

Rep: Reputation: 15
Samba requires authentication to browse unsecured Windows shares


Hello,

I did a quick search for a question like this one, but came up empty-handed. If this has already been answered, direction to the appropriate thread would be appreciated....

I am a reasonably competent Linux user running Fedora Core 1 on an Athlon with samba-3.0.0-15 installed from RPM as supplied in the original install image. Though I have used Linux continuously for several years, this is my first attempt at getting samba running, so please pardon my ignorance.

In short, I want to be able to access Windows shares, especially certain public shares that are set to not require a user name and password.

I have modified my smb.conf file to list the correct Windows Workgroup designated by my university and have initialized the samba service by running "/etc/init.d/smb start" as root. The remainder of the smb.conf file was left unchanged, including the security level. (This only has to do with the local SMB server, not client, right?)

By running "Network Servers" from the RedHat/Start menu in GNOME, I see various workgroups, including the one that I wish to browse. Inside the workgroup are all the Windows servers that should be present. However, when I try to browse volumes on ANY Windows server, including those that I know for a fact do NOT require a user name password (when accessed from a Windows machine), I am prompted for a name/password. I have been unable to figure out how to get around this, since these servers simply have no user names or passwords associated with them.

If anyone could suggest how to let me browse freely shared volumes on Windows machines, I would greatly appreciate it; I hate having to go to the computer lab to download homework assignments from share servers.

Thanks!

Conrad Shultz
 
Old 05-07-2004, 01:49 AM   #2
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
Probably dumb to ask this, but do you have guest logins enabled...? I know its not necessary

It probably wouldn't hurt to post your smb.conf
 
Old 05-07-2004, 02:08 AM   #3
shultzc
LQ Newbie
 
Registered: Feb 2004
Location: Portland, Oregon
Distribution: Debian, FreeBSD, Solaris, Mac OS X
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks for responding.

I presume that by guest logins being enabled you are referring to the servers to which I am trying to connect. I do not administer the servers in question. All I know is that these servers I ordinarily do not have to supply credentials for, whereas for other campus servers I do have to supply credentials. I.e. the server volumes in question are public read-only.

My smb.conf file (non-commented sections) is pasted below.

-Conrad

[global]
workgroup = REED
server string = Samba Server
printcap name = /etc/printcap
load printers = yes
log file = /var/log/samba/%m.log
max log size = 50
security = user
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
[homes]
comment = Home Directories
browseable = yes
writable = no
[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes
 
Old 05-07-2004, 05:57 AM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
This may be of little help, but I have never set any permissions when I set up my home network. I was too lazy to remember the samba syntax, so I used Linneighborhood (a GUI network browser). To access a share, I chose to "browse as user" and hit enter - as in no password. I can read/write between both machines that way. From the WindowsXP box, I can browse the shared folder on my Mandrake machine and vice-vera.

So, you may already be able to access the userless/passwordless shares without knowing it. Try to browse as user (use your user from the machine you're on) and don't enter a password. It might work (doesn't teach you anything, really, but if it works...)
 
Old 05-07-2004, 01:12 PM   #5
shultzc
LQ Newbie
 
Registered: Feb 2004
Location: Portland, Oregon
Distribution: Debian, FreeBSD, Solaris, Mac OS X
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks, but I tried that and it didn't do the trick.

-Conrad
 
Old 05-07-2004, 01:52 PM   #6
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Putting:

guest ok = yes
guest only = yes

In the share you want to be public should work, if that doesn't work, change

security = user

to

security = share

And try again.
 
Old 05-07-2004, 02:12 PM   #7
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
shultzc, I misread your first post. I thought you administered the servers in question. Sorry about that.

What is this tool you are using to access the shares? Is it just loading in Nautilus?

You could also check out LinNeighborhood... I use KDE myself and just use Konqueror to browse such shares at home/on my campus.

Your smb.conf shouldn't actually affect you browsing the shares. That file is used for the shares you have on your own machine.

In KDE, there is a network browsing section of the Control Center, thats where I supply the credentials my university wants me to provide. I am not sure if there is an equivalent area in Gnome.

Have you tried just leaving the username and password fields blank when you try to browse the shares?

Last edited by sorrodos; 05-07-2004 at 02:16 PM.
 
Old 05-09-2004, 05:32 AM   #8
Nichole_knc
Member
 
Registered: Mar 2004
Location: Georgia
Distribution: SlackWare 10.1+, FreeBSD 4.4-5.2, Amiga 1.3,2.1,3.1, Windors XP Pro (makes a fair answering machine)
Posts: 287

Rep: Reputation: 30
I to have this same issue... Linux requiring user/pass for public shares.
I have tried several options and found no fix... I figured since I was able to config samba to work across 3 networks it would be simple to stop the user/pass browsing requirement... NOPE...
 
Old 08-19-2009, 11:10 AM   #9
gankoji
Member
 
Registered: Nov 2007
Location: Southern California
Distribution: Slackware-13.0 x86_64, Slackware 12.2, slackware64-current
Posts: 225

Rep: Reputation: 35
if you know the server name and share name of what you are trying to get to (or just the server, if it's browseable) then just go to konqueror.
in the address bar type smb://ServerName/ShareName or just smb://ServerName. konqueror supports browsing without credentials just fine.
 
Old 08-19-2009, 05:16 PM   #10
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Good advice for this dusty old thread
 
Old 08-19-2009, 05:38 PM   #11
gankoji
Member
 
Registered: Nov 2007
Location: Southern California
Distribution: Slackware-13.0 x86_64, Slackware 12.2, slackware64-current
Posts: 225

Rep: Reputation: 35
haha no sooner than I had I posted that I noticed last post was in '04. Good to see somebody's still paying attention :-D.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble setting shares so samba networked xp box can browse files mjewell Mandriva 4 11-13-2005 08:20 AM
can mount samba shares, but not browse them broxtor Linux - Software 0 11-19-2004 12:00 PM
Windows XP requires Login from Samba teaorcoffee Linux - Networking 5 03-01-2004 05:56 AM
Linux can mount samba shares but not windows shares bindsocket Linux - Software 1 12-01-2003 05:28 PM
browse windows shares from linux system judemathias Linux - Software 1 09-29-2003 10:00 AM


All times are GMT -5. The time now is 06:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration