LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-16-2003, 12:52 PM   #16
MobbyDick
LQ Newbie
 
Registered: Jul 2003
Distribution: SuSE Linux 8.2
Posts: 17

Original Poster
Rep: Reputation: 0

I ment that I installed the printerhardware in the YAST2 Configurationutility which is unique to the SuSE Linux distibution. I guess other Distris. have other tools like this.
When I startet the hardwaredetection the system says:
OKI Data OKI 610ex on queu lp installed. Printingqueue lp (or something in that way).
After that I started my Webbrowser and used webmin to vreate the printing share. I told the system that I am printing with cups and chose a CUPS printer driver.
In the field spool directory I typed in the "/var/spool/lpd" directory.
After that I changed to the directory "/var/spool" and made a "chmod 777 lpd" (everything as root in the console, of course).
Restarted samba via webmin and everything worked.

The directory you are using does exist ?
(Different distrib. have sometimes different dirs.)
Did you do the chmod 777 on that dir ?

My Printershare looks now like the following lines:

[oki610ex]
printer = lp
printable = yes
writeable = no
public = yes
path = /var/spool/lp

Looks a littel bit different to yours. If you make some changes so that it is suiteable for your configuration it may work (hopefully).

Last edited by MobbyDick; 07-16-2003 at 12:55 PM.
 
Old 07-16-2003, 01:42 PM   #17
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
Im using redhat. I can print locally of the Linux box. I will try the webmin config.

I will let you know what happens!

Paul
 
Old 07-16-2003, 02:11 PM   #18
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
ARGGGG! It still isnt working... even if I configure my print system to be LPD, i can print locally but not remotely! Does any one have any idea about a LPD client for windows that is free?
 
Old 07-16-2003, 02:36 PM   #19
MobbyDick
LQ Newbie
 
Registered: Jul 2003
Distribution: SuSE Linux 8.2
Posts: 17

Original Poster
Rep: Reputation: 0
Donīt get me wrong, I still use CUPS on the Linux System.

But if it still doesnīt work with the chmod 777 you shurely made, I donīt know, either. Sorry.
 
Old 07-16-2003, 03:10 PM   #20
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
ok, i'll have to do some more searching... thanx for you help anyway
 
Old 07-16-2003, 03:32 PM   #21
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Lightbulb Reply concerning pnh73's problem

Hey pnh73,

I just noticed you did not have the printcap name and load printers options in the Global share.

Add the following in the Global share:
Code:
printcap name = /etc/printcap
load printers = yes
 
Old 07-16-2003, 03:37 PM   #22
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
hmm, this could be my solution...

let me see
 
Old 07-16-2003, 03:47 PM   #23
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
ok here is my smb.conf at the moment:


[global]
workgroup = MSHOME
netbios name = WEBSERVER
server string = RH8 Server
security = SHARE
null passwords = Yes
obey pam restrictions = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printing = lprng
printcap name = /etc/printcap
load printers = yes

[laser]
path = /var/spool/lpd/ml-4500
guest ok = Yes
printable = Yes
public = yes

is this correct?
 
Old 07-16-2003, 03:53 PM   #24
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
Im still not having any luck...
 
Old 07-16-2003, 05:52 PM   #25
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Can you post your smb.conf file once again.

Also, what version of RedHat are you using?
(In RedHat 7.3 and below, Samba does not support CUPS).

Can you print locally ?



P.S. consider adding the name and version of your distribution to your profile.
 
Old 07-16-2003, 05:58 PM   #26
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
I am using Red Hat 8, and yes I can print locally...
 
Old 07-16-2003, 06:16 PM   #27
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
You forgot to post your smb.conf.

Or

I will use the one right on top

Last edited by Mathieu; 07-16-2003 at 06:19 PM.
 
Old 07-16-2003, 06:20 PM   #28
pnh73
Member
 
Registered: Jul 2003
Location: Birmingham, UK
Distribution: Ubuntu,Debian
Posts: 381

Rep: Reputation: 30
Sorry . Here you go:

[global]
workgroup = MSHOME
netbios name = WEBSERVER
server string = RH8 Server
security = SHARE
null passwords = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printing = lprng

[laser]
path = /var/spool/lpd/ml-4500
guest ok = Yes
printable = Yes
printer name = lp
 
Old 07-16-2003, 06:45 PM   #29
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
[global]
workgroup = MSHOME
netbios name = WEBSERVER
server string = RH8 Server

security = user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
unix password sync = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*

log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

printcap name = /etc/printcap
load printers = yes
printing = lprng


[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
guest ok = yes
writable = no
printable = yes


If this doesn't work, then it is possible that your guest user does not have permission to print.

You can:
Create a Linux user and then a Samba user (smbpasswd -a <username>)
OR
There is a file called smbusers, just re-assign the guest user to a valid Linux user.
 
Old 07-16-2003, 09:52 PM   #30
donz
LQ Newbie
 
Registered: Jul 2003
Location: Orlando, FL
Posts: 3

Rep: Reputation: 0
Someone much earlier had the answer, but I think it got lost in the noise. Try the following under the appropriate [printer] section:

use client driver = yes

this stops the "unable to connect..." messsages

Before I added it, I could print to the samba printer from windows but I couldn't see any info about the printer itself. Now it works fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change access permissions on Samba share from win2k? TongueTied Linux - Software 2 03-25-2011 03:28 PM
Can't access my linux share through samba. I get permission denied. mlsbraves Linux - Software 1 08-16-2005 08:59 PM
Very stupid, but here we go: pam_mount + samba share = access denied? Thakowbbery Linux - Software 8 05-23-2005 11:43 AM
change access permissions on Samba share from win2k? TongueTied Linux - Software 1 08-27-2003 05:00 PM
access is denied : samba PDC, win2k client dkodegwc Linux - Networking 6 12-14-2002 12:02 PM


All times are GMT -5. The time now is 04:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration