LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-01-2004, 04:07 PM   #1
Mikessu
Member
 
Registered: Sep 2003
Distribution: Gentoo, FreeBSD 5.1
Posts: 122

Rep: Reputation: 15
Samba password


I have tried to set Samba and I've got client work, but I have problems with server. It always keeps asking password and username when trying to download files from windoze machine and even guest account doesnt work. What have I might be done wrong?
 
Old 03-02-2004, 03:06 AM   #2
muah
Member
 
Registered: Aug 2003
Location: Europe
Distribution: Slackware (current)
Posts: 228

Rep: Reputation: 33
Can u paste your smb.conf? One of solutions is to use the same username/password in linux and windows. It doesnt ask for a pw then, just logs u in.
 
Old 03-02-2004, 03:19 PM   #3
Mikessu
Member
 
Registered: Sep 2003
Distribution: Gentoo, FreeBSD 5.1
Posts: 122

Original Poster
Rep: Reputation: 15
Quote:
# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2004/03/01 22:58:39

# Global parameters
[global]
workgroup = KOTI
server string = Mikon kone
security = SHARE
encrypt passwords = Yes
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = cups
dns proxy = No
printer admin = @adm
printing = cups

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
browseable = No

[print$]
path = /var/lib/samba/printers
write list = @adm root
guest ok = Yes

[pdf-generator]
comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
print command = /usr/share/samba/scripts/print-pdf %s ~%u //%L/%u %m %I &

[pdf-screen]
comment = PDF Generator - Screen quality (only valid users)
path = /var/tmp
printable = Yes
print command = /usr/share/samba/scripts/print-pdf %s ~%u //%L/%u %m %I "" %S &
copy = pdf-generator

[pdf-printer]
comment = PDF Generator - Print quality (only valid users)
path = /var/tmp
printable = Yes
print command = /usr/share/samba/scripts/print-pdf %s ~%u //%L/%u %m %I "" %S &
copy = pdf-generator

[pdf-prepress]
comment = PDF Generator - PrePress quality (only valid users)
path = /var/tmp
printable = Yes
print command = /usr/share/samba/scripts/print-pdf %s ~%u //%L/%u %m %I "" %S &
copy = pdf-generator

[MIKKO_JAETUT]
comment = /home/mikko/jaetut
path = /home/mikko/jaetut
guest ok = Yes

[MIKKOMUSIIKK]
comment = /home/mikko/Musiikki
path = /home/mikko/Musiikki
guest ok = Yes
wide links = No
 
Old 03-02-2004, 03:58 PM   #4
muah
Member
 
Registered: Aug 2003
Location: Europe
Distribution: Slackware (current)
Posts: 228

Rep: Reputation: 33
You can add
Code:
[global]
guest ok = yes
guest only = yes
guest account = smbguest
and remove
map to guest = bad user

Then you should be able to connect to linux server without asking for pw (except print$ share, there u should specify
guest only = no
public = no
to give ppl with write access a chance to login)


Another option for users is as i mention above to use the same logins/passwords on windows/linux

Last edited by muah; 03-02-2004 at 04:00 PM.
 
Old 03-03-2004, 10:45 AM   #5
Mikessu
Member
 
Registered: Sep 2003
Distribution: Gentoo, FreeBSD 5.1
Posts: 122

Original Poster
Rep: Reputation: 15
Now when I try to browse smb:/ it just keeps asking password and Windoze machines now dont even see my computer...
 
Old 03-03-2004, 11:13 AM   #6
muah
Member
 
Registered: Aug 2003
Location: Europe
Distribution: Slackware (current)
Posts: 228

Rep: Reputation: 33
Paste your new smb.conf
If u added lines i mentioned, are u sure you have user/group smbguest on your computer?

Edit: Also run 'testparm' everytime u change smb.conf to check that there are no errors.

Last edited by muah; 03-03-2004 at 11:18 AM.
 
Old 03-03-2004, 11:24 AM   #7
fur
Member
 
Registered: Dec 2003
Distribution: Debian, FreeBSD
Posts: 310

Rep: Reputation: 35
Look into 'smbpasswd'


http://us1.samba.org/samba/ftp/docs/...bpasswd.8.html
 
Old 03-04-2004, 06:43 AM   #8
Mikessu
Member
 
Registered: Sep 2003
Distribution: Gentoo, FreeBSD 5.1
Posts: 122

Original Poster
Rep: Reputation: 15
Now I've done following things:
* edited smb.conf as muah told.
* added user & group smbguest
* runned testparm succesfully

Now I can see directories that I've shared but when I try to enter some of them it still asks password.

My configs:
smbusers: http://www.sourcecode.no/pastebin/en...key=1h7grxirz6
smbpasswd: http://www.sourcecode.no/pastebin/en...key=8v30ml3ikx
smb.conf: http://www.sourcecode.no/pastebin/en...&key=jz3lcot0w

Last edited by Mikessu; 03-04-2004 at 06:45 AM.
 
Old 03-04-2004, 01:38 PM   #9
muah
Member
 
Registered: Aug 2003
Location: Europe
Distribution: Slackware (current)
Posts: 228

Rep: Reputation: 33
Well I dont know why it still asks for a password here is my smb.conf

Code:
[global]
  workgroup = workgroup
  server string = Samba Server
  netbios name = Majestic
  security = share
  log level = 1
  log file = /var/log/samba/%m.log
  max log size = 50
  dns proxy = no
  deadtime = 15
  
  guest ok = yes
  guest account = smbguest
  guest only = yes
  
  
  invalid users = root
  
[public]
  path = /home/public
  create mode = 0777
  directory mode = 0777
  writable = yes
  browsable = yes
  public = yes
  
[moviez]
  path = /d/movies
  writable = no
  browsable = yes
  public = yes
I can access \\Majestic and all its shares without password from windows
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba and password changes hazza96 Linux - Networking 11 08-07-2004 08:15 AM
Logon samba on other samba password list hernandi Linux - Networking 1 10-14-2003 01:46 PM
Logon samba on other samba password list hernandi Linux - Networking 0 10-14-2003 01:40 PM
Just change Samba password, not Unix password? sorrodos Linux - Networking 1 08-14-2003 08:52 PM
password in samba loganwva Linux - Networking 1 03-26-2002 12:39 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration