LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   SAMBA frustration (http://www.linuxquestions.org/questions/linux-software-2/samba-frustration-38379/)

Riptide 12-14-2002 09:14 PM

SAMBA frustration
 
Greetings fellow techies!

I tried out SAMBA on Mandrake 7.0 a couple of years ago and was able to ger it working, but this time around RedHat 8 and SAMBA loaded on a real server (I usualy use whatever junk I have laying around) has netted me nothing. It hasn't made me crazy yet, but who knows how long my brain can hold out!

Preliminaries: I loaded absolutely everything as I have plenty of space. The server and test client get IP addresses from a Win98 box running ICS (junk, but dumping that is phase 2). Both boxes see out to the internet as I can browse from both. Any box can ping any other box on my local net. I have created my users and assigned passwords in Linux and Samba.

Symptoms: Before I put the server and client on their own workgroup I was able to see the server name but not browse any shares or map to them. after changing the workgroup name for both clients I get semaphore timeout errors on the client and do not see the server name in network neighborhood.

smb.conf:

# Samba config file created using SWAT
# from UNKNOWN (127.0.0.1)
# Date: 2002/12/14 12:36:11

# Global parameters
[global]
workgroup = SHEEP
netbios name = STORM
server string = Samba Server
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
unix password sync = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
os level = 60
preferred master = True
dns proxy = No
hosts allow = wool spring ewetoo hightide ram
printing = lprng

[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[public]
comment = Shared Family Stuff
path = /home/public
valid users = kerryl kira patricia
read only = No

[private]
comment = Kerry's Private Directory
path = /home/private
valid users = kerryl
read only = No


Any ideas :Pengy:
Riptide

Riptide 12-14-2002 10:48 PM

Update
 
I am now getting account not authorized to login from this station.

I moved client to static IP and put that IP in the /etc/hosts file.

any ideas?

Ciccio 12-15-2002 12:14 AM

have you read the smb.conf that was includesd in the package of the samba server? (man smb.conf)

check hosts_access for more info about hosts allow

Instead of read only try with wribale

writable = yes

I think that the arguments after = are to be serpareted by , like this:
Code:

valid users = greg, pete, java, netkill
in the global part of the script try adding a line
Code:

security = share
and then ckeck if you can access the shares

after that set it to
Code:

security = user
report back your status after doing all that.


All times are GMT -5. The time now is 07:22 PM.