LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-10-2007, 02:40 PM   #1
tendonut
Member
 
Registered: Nov 2005
Location: Niagara Falls, NY
Distribution: SuSE 10.2, Fedora Core 7, Ubuntu 6.06
Posts: 49

Rep: Reputation: 15
Samba doesn't allow certain connections?


I posted something about this over a month ago, but I didn't have that much information on the problem and the thread seemed to have died.

I have Fedora 7 currently installed on this machine. It is considered my "file server" and is running Samba, which is sharing just one directory.

When I connect to the Samba share from a Windows or Mac computer, I am prompted for a username and password, then everything works beautifully. But for some strange reason, when using either the Win2K3 FTP server or Serv-U (on a seperate networked machine), when those apps attempt to connect to the samba share, the directory appears blank. I am not entirely sure if the Samba machine is rejecting the connection or the FTP servers are just not displaying the contents, but this all started back with FC6 when I updated to the lastest version of Samba. Thinking FC7 would fix the problem, I installed it and updated it, still the same problem. What is causing this? The FTP servers are using the exact same login information as I use when connection just as a network share with Windows Explorer, so it shouldn't be an authorization problem, but you never know.
 
Old 09-11-2007, 11:07 PM   #2
Julix
LQ Newbie
 
Registered: Aug 2007
Location: Argentina
Distribution: Debian Etch, Slackware 12
Posts: 28

Rep: Reputation: 15
Did you checked your smb.conf file? On my file there is this section:

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
; hosts allow = 192.168.1. 192.168.2. 127.

On the last line you can see that the instruction "host allow" is ignored by samba due to the semicolon, maybe this line is not active in your file and therefore restricting access.

Regards,
Julix
 
Old 09-12-2007, 02:03 AM   #3
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
SAMBA is not an FTP server. It uses the SMB/CIFS protocol which is Windows file sharing. Though if you want multiple computers to access it, you may want to include the amount of connections SAMBA can have open.
 
Old 09-12-2007, 04:32 AM   #4
Astol
Member
 
Registered: Aug 2007
Location: Perth, Australia
Distribution: RHEL 5 + 4.5, Fedora
Posts: 88

Rep: Reputation: 15
Quote:
Originally Posted by Electro View Post
Though if you want multiple computers to access it, you may want to include the amount of connections SAMBA can have open.
how do you do that?
 
Old 09-12-2007, 01:16 PM   #5
tendonut
Member
 
Registered: Nov 2005
Location: Niagara Falls, NY
Distribution: SuSE 10.2, Fedora Core 7, Ubuntu 6.06
Posts: 49

Original Poster
Rep: Reputation: 15
I understand that Samba is not an FTP server. I am having a Win2K3 machine that is running an FTP server app (Serv-U at the moment) connect to Samba for the directories that it is sharing. So in Serv-U, it's sharing, in my case, //server/fileserver. What confuses me though, is Serv-U connects to the Samba share using the same login that Windows Explorer uses to connect, so I don't see how there is any problem. As I said earlier, this all started when I updated Samba. It has been running beautifully for 2 years non-stop until I updated.

As for what Julix said, the machine that is running Serv-U can access the Samba share without any problems if I were to access it as a mapped drive or as the direct IP/network name. But Serv-U itself does not seem to be able to make the connection, so it's not a problem with Samba not allowing connections from that host.

From a user standpoint, they can go to my FTP address (i.e. ftp://123.456.789) and they are able to log in with the accounts that I have set up, but instead of displaying the contents of their home directory (in this case, everyone's home directory is //server/fileserver), it displays a blank directory as if the home directory was empty. If I change their home directory to a LOCAL folder, like C:/, it works great. So strange..

Last edited by tendonut; 09-12-2007 at 01:25 PM.
 
Old 09-13-2007, 12:10 AM   #6
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The maximum amount of connections by default is infinite, so I am wrong. It might be a file lock problem or something else. I suggest re-compile samba with the debug option or set samba to log everything it is doing.

On my SAMBA, a VMware VM guest running Windows XP or Windows 98 accessing a directory on the SAMBA share delays other people from accessing the SAMBA share.

I suggest post /etc/samba/smb.conf. Also I suggest check /etc/host.deny and /etc/host.allow because option "host allow" in smb.conf may conflict with the tcpwrapper files mentioned earlier.
 
Old 09-13-2007, 12:22 PM   #7
tendonut
Member
 
Registered: Nov 2005
Location: Niagara Falls, NY
Distribution: SuSE 10.2, Fedora Core 7, Ubuntu 6.06
Posts: 49

Original Poster
Rep: Reputation: 15
I have 5 other computers all accessing the Samba share at the same time by the way, ranging from Windows machines to a Mac laptop, all with no problems at all. When I get home though, I will post my smb.conf file
 
Old 03-16-2008, 10:42 AM   #8
Mandorr
LQ Newbie
 
Registered: Mar 2008
Posts: 1

Rep: Reputation: 0
I have this problem today!

Hi

Any one found a solution for this?

/Mandorr
 
  


Reply

Tags
ftp, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables: how do I allow samba connections? bioe007 Slackware 4 07-13-2007 01:58 AM
Samba Connections joshuarowley Linux - Networking 5 01-08-2006 09:18 AM
Samba connections DanyUP Linux - Networking 1 10-24-2005 02:22 PM
Samba: denying external connections ryback Linux - Security 3 02-16-2005 04:52 AM
Samba connections between 2 linux pc's kpachopoulos Linux - Networking 2 10-19-2004 12:57 AM


All times are GMT -5. The time now is 08:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration