LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-30-2011, 11:56 PM   #1
gqqnbig
LQ Newbie
 
Registered: Apr 2011
Posts: 12

Rep: Reputation: 1
samba connection failed


I'm using Ubuntu 10.10. I've installed Samba by apt-get install samba.

My samba.conf is
Code:
[global] 
workgroup = LinuxSir 
netbios name = LinuxSir05 
server string = Linux Samba Server TestServer 
security = share 
[linuxsir] 
path = /opt/linuxsir 
writeable = yes 
browseable = yes 
guest ok = yes
The permission of linuxsir directory is 777.
I've run smbd and nmbd.

Then,

smbclient -L //LinuxSir05
Enter loveright's password:
Connection to LinuxSir05 failed (Error NT_STATUS_BAD_NETWORK_NAME)

How to solve the problem?
I do not need any security consideration, I only want to make it work.
 
Old 05-01-2011, 12:00 AM   #2
corp769
Guru
 
Registered: Apr 2005
Posts: 5,814

Rep: Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001
Hello,

The bad network name error is due to the hostname; Have you tried using the IP address of the host? And also, I highly recommend changing the permissions to your directory, since 777 gives ALL users read, write, and execute permissions.

Cheers,

Josh
 
Old 05-01-2011, 12:44 AM   #3
gqqnbig
LQ Newbie
 
Registered: Apr 2011
Posts: 12

Original Poster
Rep: Reputation: 1
it works

Thank you for you suggestion.

I try using ip, it shows
loveright 12:16:38 opt$ smbclient -L 192.168.190.132
Enter loveright's password:
Domain=[LINUXSIR] OS=[Unix] Server=[Samba 3.5.4]
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
tree connect failed: NT_STATUS_ACCESS_DENIED

then, in /etc/samba/smb.conf, in [global], I add "client lanman auth = yes".

Now it really works. Thank you very much.
 
1 members found this post helpful.
Old 05-01-2011, 12:58 AM   #4
corp769
Guru
 
Registered: Apr 2005
Posts: 5,814

Rep: Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001
Not a problem! Mark your thread as solved using the thread tools at the top, and give rep if you want to. Thanks!

Josh
 
  


Reply

Tags
samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba 4: Connection to \\localhost\netlogon failed - NT_STATUS_LOGON_FAILURE Sum1 Linux - Software 0 12-22-2010 08:03 AM
newbie > samba Connection to localhost failed P-P Linux - Software 2 01-18-2007 12:33 AM
CentOS+WinXP and Samba: connection failed achtung_linux Linux - Networking 1 08-03-2006 08:33 AM
SAMBA connection failed masterlodi Linux - Networking 2 03-13-2005 08:24 AM
Connection to LOCALHOST failed when I try to browse the LAN in Samba jeffcheng Linux - Networking 0 09-21-2004 07:55 AM


All times are GMT -5. The time now is 01:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration