LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   samba connection failed (http://www.linuxquestions.org/questions/linux-software-2/samba-connection-failed-878088/)

gqqnbig 04-30-2011 11:56 PM

samba connection failed
 
I'm using Ubuntu 10.10. I've installed Samba by apt-get install samba.

My samba.conf is
Code:

[global]
workgroup = LinuxSir
netbios name = LinuxSir05
server string = Linux Samba Server TestServer
security = share
[linuxsir]
path = /opt/linuxsir
writeable = yes
browseable = yes
guest ok = yes

The permission of linuxsir directory is 777.
I've run smbd and nmbd.

Then,

smbclient -L //LinuxSir05
Enter loveright's password:
Connection to LinuxSir05 failed (Error NT_STATUS_BAD_NETWORK_NAME)

How to solve the problem?
I do not need any security consideration, I only want to make it work.

corp769 05-01-2011 12:00 AM

Hello,

The bad network name error is due to the hostname; Have you tried using the IP address of the host? And also, I highly recommend changing the permissions to your directory, since 777 gives ALL users read, write, and execute permissions.

Cheers,

Josh

gqqnbig 05-01-2011 12:44 AM

it works
 
Thank you for you suggestion.

I try using ip, it shows
loveright 12:16:38 opt$ smbclient -L 192.168.190.132
Enter loveright's password:
Domain=[LINUXSIR] OS=[Unix] Server=[Samba 3.5.4]
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
tree connect failed: NT_STATUS_ACCESS_DENIED

then, in /etc/samba/smb.conf, in [global], I add "client lanman auth = yes".

Now it really works. Thank you very much.

corp769 05-01-2011 12:58 AM

Not a problem! Mark your thread as solved using the thread tools at the top, and give rep if you want to. Thanks!

Josh


All times are GMT -5. The time now is 12:53 PM.