LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-16-2001, 09:56 AM   #1
jkahlich
LQ Newbie
 
Registered: Oct 2001
Location: Dallas, Texas
Distribution: Red Hat
Posts: 6

Rep: Reputation: 0
Question samba connecting to linux shares hangs


I have a Red Hat 7.1 in a Windows NT Domain. I can access everything just fine. My problem is the initial connect it hangs for 10 to 30 seconds (somtimes timing out) then finally connects. I went through the diagnosis.txt at samba.org and found that I may have a problem with nmbd. The services is running just fine as is smbd but when I do nmblookup -B computername_samba_ it will not give me my machines IP. I think this is where my problem lies. Also when I do a netstat -a |grep 137 (looking to see if port 137 is out there) I get nothing back. So bottom line: Samba does work, It just hangs during the initial connection.

Thanks
 
Old 10-16-2001, 10:41 AM   #2
drjimstuckinwin
Member
 
Registered: Mar 2001
Location: Manchester UK
Distribution: Mainly Fedora
Posts: 496

Rep: Reputation: 30
Hello
Sounds like the same problem that I had. My win98 system hung whenever I tried to connect to samba, but the server showed up in Network Neighbourhood. The problems I blamed were...
1 Encrypted passwords. Had to put encrypt passwords = yes in smb.conf
2 Using wrong MS logon client
3 Having protocols other than TCP/IP on the windoze machine
4 Not having set up user accounts on the server properly, need a user account on the RH machine, and an account on samba. Username/PW have to be same as your windoze details. I had to create a new profile.
I used SWAT to change the samba related bits.
Jim
 
Old 10-16-2001, 11:29 AM   #3
jkahlich
LQ Newbie
 
Registered: Oct 2001
Location: Dallas, Texas
Distribution: Red Hat
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks Jim for the reply.

I do have the 4 things you mentioned all ready done.

I think I have found something. In my /etc/hosts file I do not have the domain's WINS server listed. I will modify this later today when activity on the network slows down since I am going to stop and restart the networking services.

I will respond with the results.
 
Old 10-17-2001, 02:55 PM   #4
jkahlich
LQ Newbie
 
Registered: Oct 2001
Location: Dallas, Texas
Distribution: Red Hat
Posts: 6

Original Poster
Rep: Reputation: 0
Thumbs up Samba works

I went into my /etc/hosts and added the name and IP of my WINS server. Samba no longer hangs when connecting initially!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba not connecting to windows shares, help pls john_d13 Linux - Software 0 12-18-2004 12:27 AM
samba and connecting to shares citrus Linux - Software 1 03-17-2004 02:51 PM
Linux can mount samba shares but not windows shares bindsocket Linux - Software 1 12-01-2003 05:28 PM
Problems connecting to samba shares from w2k or XP systemafter configuring smb.conf f marvc Linux - Software 0 06-09-2003 07:12 AM
Samba Linux Shares ggramajo Linux - Software 4 11-05-2001 07:45 PM


All times are GMT -5. The time now is 08:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration