LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-26-2003, 04:56 PM   #1
talkinggoat
Member
 
Registered: Sep 2003
Location: lafayette, la
Distribution: RHL 6.2, FC 3, Ubuntu 14.04, Ubuntu 16.04
Posts: 112

Rep: Reputation: 15
Question samba and swat problems


i'm tring to access the settings on my samba server using the web browser like swat says to do... the problem is that when i type in the address *http://localhos:901* nothing happens and the connection times out. how can i tell if swat is even working correctly? i got samba to start ok, but swat is apparently not working.
 
Old 09-26-2003, 05:02 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Take a look at:
/etc/xinetd.d/swat

Make sure disble is set to "no" and not "yes". If that is set then also make sure that you have not got any firewall rules that may be blocking requests.
 
Old 09-26-2003, 05:21 PM   #3
talkinggoat
Member
 
Registered: Sep 2003
Location: lafayette, la
Distribution: RHL 6.2, FC 3, Ubuntu 14.04, Ubuntu 16.04
Posts: 112

Original Poster
Rep: Reputation: 15
checked that... it is set to no... i know that this sounds stupid, but i have no idea how to check for a firewall. that is how new i am to this.
 
Old 09-26-2003, 05:36 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
To check your firewall rules:
iptables -L

Also make sure you have localhost defined in your hosts file:
grep localhost /etc/hosts

And that you have the loopback device up:
ifconfig

Also there should be a loopback route (lo):
route -n
 
Old 09-26-2003, 07:21 PM   #5
talkinggoat
Member
 
Registered: Sep 2003
Location: lafayette, la
Distribution: RHL 6.2, FC 3, Ubuntu 14.04, Ubuntu 16.04
Posts: 112

Original Poster
Rep: Reputation: 15
when i type in iptables -L, i get:

[root@localhost root]# iptables -L
/lib/modules/2.4.20-19.7/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-19.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.20-19.7/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.20-19.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
iptables v1.2.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
[root@localhost root]#

/etc/hosts:

# Do not remove the following line, or various programs
# that require network functionality will fail.
192.168.1.2 localhost

ifconfig

eth0 Link encap:Ethernet HWaddr 00:40:F4:47C:3B
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:357 errors:0 dropped:0 overruns:0 frame:0
TX packets:300 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:141354 (138.0 Kb) TX bytes:44614 (43.5 Kb)
Interrupt:11 Base address:0x9000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1994 (1.9 Kb) TX bytes:1994 (1.9 Kb

swat file:

# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
# to configure your Samba server. To use SWAT, \
# connect to port 901 with your favorite web browser.
service swat
{
port = 901
socket_type = stream
wait = no
only_from = localhost
user = root
server = /etc/samba
log_on_failure += USERID
disable = no
protocol = tcp
 
Old 09-27-2003, 07:06 AM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Your localhost entry in /etc/hosts should point to the loopback address. Change it to:
127.0.0.1 localhost
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing Samba-SWAT Dolphin2005 Linux - Newbie 1 11-18-2005 05:43 PM
Problems with Samba-Swat: Unable to see other Windoze machines on my network. sutherncomfort Linux - Networking 9 02-02-2005 09:30 PM
Newbie Samba problems, no swat... boardtc Mandriva 13 02-19-2004 10:06 AM
Samba and Swat ppuddick Linux - Networking 5 08-15-2002 03:20 AM
SAMBa and SWAT Snake007uk Linux - General 8 05-16-2002 07:30 PM


All times are GMT -5. The time now is 03:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration